summaryrefslogtreecommitdiff
path: root/sys-auth/google-authenticator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
commit434d713861b70f6c6563d6ee50a8e64f14c970d9 (patch)
treeb72c523c72e764420f835ba9d63d43ffef687dcf /sys-auth/google-authenticator
parentf78108598211053d41752a83e0345441bb9014ae (diff)
gentoo resync : 15.02.2018
Diffstat (limited to 'sys-auth/google-authenticator')
-rw-r--r--sys-auth/google-authenticator/Manifest2
-rw-r--r--sys-auth/google-authenticator/google-authenticator-1.05.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/sys-auth/google-authenticator/Manifest b/sys-auth/google-authenticator/Manifest
index 7ffe5e91fdab..df4356c8ad5e 100644
--- a/sys-auth/google-authenticator/Manifest
+++ b/sys-auth/google-authenticator/Manifest
@@ -1,4 +1,6 @@
DIST google-authenticator-1.04.tar.gz 54019 BLAKE2B 06afb1be1ceabb68bb7ba94921af415fe1dfd68b3b1ed75b58b3c5a58901ec482ae11063f487db0a7032868e833644022335ad9844f54734c2ad78c514f255a8 SHA512 e4b8ad74301312e17edd0a7f25257086fd805c8d5215b06b71d96e9a64a71b2c87d0c5a532d9eca21d6d67e30c02c2c2c77dbd338a2f49af25c32dcd355ee98e
+DIST google-authenticator-1.05.tar.gz 57778 BLAKE2B c31d7929e2aacffc159ee5384f6f31498585819b848f4f8b026519cf2f2fc566b8533e007844c64d348f1cf423a7175b3221f879c5c1ead360c4f1b3acea57ed SHA512 d97b26c6181dbce0612628484db37b1bf61e984fb2fb3d4974d04038e564404aa17415368dba524f0d17d96ec8d57ae4129b27f0c672d849d16ef03941d87996
EBUILD google-authenticator-1.04-r1.ebuild 1256 BLAKE2B 6719a49bc90468a752125b7a9c123d4691210602635925e12756b28fccdef35d0633dc7479230613b0c1e1300079d9e7b7a41e615fdbc6dcb7a30954c843fe6e SHA512 4d05c0f31011bf8899554bf6de92d2d621c3528d73072d8904387c2ab3662506a5d39b5ae812bdd5b30103e512707d382ff58044d0b72d0776eaa74f74cf9e88
+EBUILD google-authenticator-1.05.ebuild 1262 BLAKE2B 3b27489b8d18d5805611098bbfaf343db4c80a392617b3b902b9a63141fe731e3802378d4817fe8b7aedb522a5b3ada5617cc825d71f169063b77f7942255586 SHA512 c76193bd06000d3eb5b207eec16942eebc5bb096ce5be5fdd72dd5b78fef9e2b07beafd390d94a95933acd504ab49cb177625291ad3ffecaf3702eb3f7a5eb4f
EBUILD google-authenticator-9999.ebuild 1256 BLAKE2B 6719a49bc90468a752125b7a9c123d4691210602635925e12756b28fccdef35d0633dc7479230613b0c1e1300079d9e7b7a41e615fdbc6dcb7a30954c843fe6e SHA512 4d05c0f31011bf8899554bf6de92d2d621c3528d73072d8904387c2ab3662506a5d39b5ae812bdd5b30103e512707d382ff58044d0b72d0776eaa74f74cf9e88
MISC metadata.xml 262 BLAKE2B 9190d29ce12a5f82e0fc23c1cfb1bbd8642fe74392e1cbfcbac723b93255048ab06bcafc1b94ff52afe63be6dc1856f27b21022aab5357ae1f5b0204fd5df169 SHA512 fe36d12281e055298607afc0209c8bc1d3a3b9d61464b6f0d69b98b2d38b9c25bf6c979392be9427fd1ad4621b49b8e6c4b41a53ef28d4696150d1ee4525d8c3
diff --git a/sys-auth/google-authenticator/google-authenticator-1.05.ebuild b/sys-auth/google-authenticator/google-authenticator-1.05.ebuild
new file mode 100644
index 000000000000..cac4a833a725
--- /dev/null
+++ b/sys-auth/google-authenticator/google-authenticator-1.05.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/google/google-authenticator-libpam.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/google/google-authenticator-libpam/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ S="${WORKDIR}/google-authenticator-libpam-${PV}"
+fi
+
+DESCRIPTION="PAM Module for two step verification via mobile platform"
+HOMEPAGE="https://github.com/google/google-authenticator-libpam"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/pam"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # We might want to use getpam_mod_dir from pam eclass,
+ # but the build already appends "/security" for us.
+ econf --libdir="/$(get_libdir)"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "For further information see"
+ elog "https://wiki.gentoo.org/wiki/Google_Authenticator"
+ elog ""
+ elog "If you want support for QR-Codes, install media-gfx/qrencode."
+ fi
+}