summaryrefslogtreecommitdiff
path: root/sys-auth/google-authenticator-libpam-hardened/google-authenticator-libpam-hardened-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
commit586819755b4dbfdffdc8a725ab7c0f86095b8489 (patch)
treed6790c838cfe9607c996e4913fdf11bad5fdd528 /sys-auth/google-authenticator-libpam-hardened/google-authenticator-libpam-hardened-9999.ebuild
parent3f71901f8c228f4de570abed1831ce3ee425343e (diff)
gentoo resync : 15.09.2018
Diffstat (limited to 'sys-auth/google-authenticator-libpam-hardened/google-authenticator-libpam-hardened-9999.ebuild')
-rw-r--r--sys-auth/google-authenticator-libpam-hardened/google-authenticator-libpam-hardened-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-auth/google-authenticator-libpam-hardened/google-authenticator-libpam-hardened-9999.ebuild b/sys-auth/google-authenticator-libpam-hardened/google-authenticator-libpam-hardened-9999.ebuild
new file mode 100644
index 000000000000..9ce8f782e776
--- /dev/null
+++ b/sys-auth/google-authenticator-libpam-hardened/google-authenticator-libpam-hardened-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/mgorny/google-authenticator-libpam-hardened.git"
+inherit autotools git-r3
+
+DESCRIPTION="PAM Module for two step verification via mobile platform"
+HOMEPAGE="https://github.com/mgorny/google-authenticator-libpam-hardened"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+qrcode"
+
+DEPEND="sys-auth/oath-toolkit:=
+ virtual/pam
+ qrcode? ( media-gfx/qrencode:= )"
+RDEPEND="${DEPEND}
+ !sys-auth/google-authenticator"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ # TODO: use getpam_mod_dir after fixing build system
+ --libdir="/$(get_libdir)"
+
+ $(use_enable qrcode qrencode)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}