summaryrefslogtreecommitdiff
path: root/sys-auth/authenticator/authenticator-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /sys-auth/authenticator/authenticator-9999.ebuild
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'sys-auth/authenticator/authenticator-9999.ebuild')
-rw-r--r--sys-auth/authenticator/authenticator-9999.ebuild41
1 files changed, 26 insertions, 15 deletions
diff --git a/sys-auth/authenticator/authenticator-9999.ebuild b/sys-auth/authenticator/authenticator-9999.ebuild
index f11556202d24..5d876f945946 100644
--- a/sys-auth/authenticator/authenticator-9999.ebuild
+++ b/sys-auth/authenticator/authenticator-9999.ebuild
@@ -1,44 +1,60 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python3_{5,6} )
-inherit gnome2-utils meson python-r1 virtualx xdg-utils
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit gnome2-utils meson python-single-r1 virtualx xdg-utils
DESCRIPTION="Two-factor authentication code generator for GNOME"
-HOMEPAGE="https://github.com/bilelmoussaoui/Authenticator"
+HOMEPAGE="https://gitlab.gnome.org/World/Authenticator"
if [[ ${PV} == *9999 ]]; then
inherit git-r3
SRC_URI=""
EGIT_REPO_URI="${HOMEPAGE}"
else
- SRC_URI="https://github.com/bilelmoussaoui/Authenticator/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://gitlab.gnome.org/World/Authenticator/-/archive/${PV}/Authenticator-${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/Authenticator-${PV}"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-2+"
SLOT="0"
-
-DEPEND="
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+IUSE="test"
+RDEPEND="
+ ${PYTHON_DEPS}
app-crypt/libsecret
dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/pyotp[${PYTHON_USEDEP}]
+ dev-python/python-gnupg[${PYTHON_USEDEP}]
dev-python/pyzbar[${PYTHON_USEDEP}]
- media-gfx/gnome-screenshot
+ media-libs/gd
x11-libs/gtk+:3
"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ test? ( x11-apps/xhost )"
+
+src_prepare() {
+ default
-PATCHES=( "${FILESDIR}/disable-failing-tests.patch" )
+ sed -i -e "1s:#!/usr/bin/env python3:#!${PYTHON}:" "authenticator.py.in" || die "Could not fix shebang."
+
+ rm -r "subprojects/libgd" || die "Could not remove the subproject libgd folder."
+}
pkg_preinst() {
gnome2_icon_savelist
gnome2_schemas_savelist
}
+src_test() {
+ xdg_environment_reset
+ virtx meson_src_test
+}
+
pkg_postinst() {
gnome2_icon_cache_update
gnome2_schemas_update
@@ -48,8 +64,3 @@ pkg_postrm() {
gnome2_icon_cache_update
gnome2_schemas_update
}
-
-src_test() {
- xdg_environment_reset
- virtx meson_src_test
-}