summaryrefslogtreecommitdiff
path: root/sys-auth/AusweisApp2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /sys-auth/AusweisApp2
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'sys-auth/AusweisApp2')
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-1.20.0.ebuild40
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-9999.ebuild39
-rw-r--r--sys-auth/AusweisApp2/Manifest4
-rw-r--r--sys-auth/AusweisApp2/metadata.xml19
4 files changed, 102 insertions, 0 deletions
diff --git a/sys-auth/AusweisApp2/AusweisApp2-1.20.0.ebuild b/sys-auth/AusweisApp2/AusweisApp2-1.20.0.ebuild
new file mode 100644
index 000000000000..4cc7a6c7a052
--- /dev/null
+++ b/sys-auth/AusweisApp2/AusweisApp2-1.20.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebsockets:5[qml]
+ dev-qt/qtwidgets:5
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
+ cmake_src_configure
+}
diff --git a/sys-auth/AusweisApp2/AusweisApp2-9999.ebuild b/sys-auth/AusweisApp2/AusweisApp2-9999.ebuild
new file mode 100644
index 000000000000..a4ae965bed85
--- /dev/null
+++ b/sys-auth/AusweisApp2/AusweisApp2-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake git-r3
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+EGIT_REPO_URI="https://github.com/Governikus/AusweisApp2.git"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebsockets:5[qml]
+ dev-qt/qtwidgets:5
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
+ cmake_src_configure
+}
diff --git a/sys-auth/AusweisApp2/Manifest b/sys-auth/AusweisApp2/Manifest
new file mode 100644
index 000000000000..dadda0583db8
--- /dev/null
+++ b/sys-auth/AusweisApp2/Manifest
@@ -0,0 +1,4 @@
+DIST AusweisApp2-1.20.0.tar.gz 9727544 BLAKE2B 23d31b5cff2756948d563052ff53fffb737c6895fddada036969350b0a65f404f8def70f8ac4409a34fe9f83160e15cd8d4b6441f901f8e53e791ca386140383 SHA512 9222bc59521aa3533c79206df14b079e618f6efbdd04c11b4cc754027dc155d2ad4a321cabdbb35b9308f5e9631ca05e828969633125fe0ac651156669a784d0
+EBUILD AusweisApp2-1.20.0.ebuild 833 BLAKE2B 86af2e93ad1e61bb6fa6be7108e34e4d743e63280c9f1eb1b034268cd058979a22b4671666930a2655aa2716e7b6aaecb531f7e2319d2dd86b573c4df943044d SHA512 5357ce53f301725a0ecd31bdbec96a5e025f03cb8c389c28947626a7d968ebe4f8b40a6068e4c32ea35fc10a3411ebbb35e0486ed5db8032aa0b593c2f458a1a
+EBUILD AusweisApp2-9999.ebuild 797 BLAKE2B 9a0fb6f00651921fafe971fed89f73e50aab2aae439179a95c4712c481a1fb8327f131f439ed5e971c75e7f4b5a2a9f52cc367071c09f442ce8e8029eac28a58 SHA512 197dc3bf334e8fe49613f90754e0d3e39e317e389716282c28330de123c76fe147e46af56473370f483be6a10e6d4b4d86efed904040583ae77a429a02afac34
+MISC metadata.xml 569 BLAKE2B ff252fd4eb0ba94a0b1737dc7170be7e77c031bd7be1c642c1b1b6a83ab2c217facfdc3a689bf10bcbecf044d2b4fd01563e9bd77e84d8b31a85a900f865e137 SHA512 cafac913b71aa8a40dcca2e1dd69132aad723b2d2a75dae6fb0c8954c5c3692aea1cbfb94bb1e0d8638bf4d0a74c9adfeca4d8243fe6f20cd3ad941d239760e1
diff --git a/sys-auth/AusweisApp2/metadata.xml b/sys-auth/AusweisApp2/metadata.xml
new file mode 100644
index 000000000000..3139b2058361
--- /dev/null
+++ b/sys-auth/AusweisApp2/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@pogatzki.net</email>
+ <name>Volkmar W. Pogatzki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Governikus/AusweisApp2</remote-id>
+ </upstream>
+</pkgmetadata>