summaryrefslogtreecommitdiff
path: root/sys-apps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-12 06:46:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-12 06:46:08 +0000
commitc6e62298405d39e635c0d8dd6e026c8cb667a478 (patch)
tree797bd877e6cc2cdcfe3e39ecfedf34781075fc86 /sys-apps
parent2c3b9bbdb114cc13b6ef8e0e5933c9e374fca8b6 (diff)
gentoo auto-resync : 12:03:2024 - 06:46:08
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/Manifest.gzbin50841 -> 50840 bytes
-rw-r--r--sys-apps/baselayout/Manifest2
-rw-r--r--sys-apps/baselayout/baselayout-2.15.ebuild364
-rw-r--r--sys-apps/usbredir/Manifest3
-rw-r--r--sys-apps/usbredir/usbredir-0.14.0.ebuild (renamed from sys-apps/usbredir/usbredir-0.13.0.ebuild)7
5 files changed, 373 insertions, 3 deletions
diff --git a/sys-apps/Manifest.gz b/sys-apps/Manifest.gz
index 5867e38ffdff..608825bcfa13 100644
--- a/sys-apps/Manifest.gz
+++ b/sys-apps/Manifest.gz
Binary files differ
diff --git a/sys-apps/baselayout/Manifest b/sys-apps/baselayout/Manifest
index 620ce2103052..8ab2a3b6db7c 100644
--- a/sys-apps/baselayout/Manifest
+++ b/sys-apps/baselayout/Manifest
@@ -1,5 +1,7 @@
DIST baselayout-2.14.tar.bz2 30182 BLAKE2B c5f67795233e565c2c75c97a55c000aec98e901bb0a25f1aeb52b01b44d7c09bfc6e67813234629ca71ff32d603e82ada8e66e5ab6007fa0664b95367256320d SHA512 bffd118f5e92975b9247d854fc5683a311dbcd03efa37a13dfd05d04e92a6e784858d3a55aa689f782229afc5985e829eb332c08a79eed081bf0a47720ca7e8a
+DIST baselayout-2.15.tar.bz2 30214 BLAKE2B 58d81b935c52deddeae60314f040a85767c7df30e38c694090dded4a9d593be8fb3c181e6e9496cc8e0987481b6b13f57a74038f9f21a0b27c76528d066cd5f5 SHA512 3d1a64e2802b53bcc537633fd23224ebea60b79d58f4b692175598cd43015e0d60dfdfb81c03f3541d28fe77f04022298236db726ea7e5119cc217d6bfb74d4b
EBUILD baselayout-2.14-r2.ebuild 11345 BLAKE2B 1f596475501f3a7ddb82902cc803391c6706f9763acaa9cf48474b9435826cb5890bb9647da3d3cf24a51e61c6206ea544929f1da0f260d3728f8131f6c1f6b5 SHA512 29e49bc126fb45da7efab47bb8733d52aa019edbf621f12c589c089837dbd45b705e00af099f02c5ce8a5595fdf3541e5f4a0682bc694905ca6fca7c89eb8b00
EBUILD baselayout-2.14-r3.ebuild 11612 BLAKE2B bf1373a141a640239d3156e92789f168141fd5e2d3460db692201dcec7f12803a826948be72ab1f7b8a6ba3c5bcf1876ba06a81953cd273c6fb0e7a9cb166875 SHA512 9ac58944861e0a0da77927df7f07892977116146526a5e461ebc64a99f7aad4b734fc3a8760ef0c1101b8f8af5e64b688141a1f9526b631cde94905b0ea1bf50
+EBUILD baselayout-2.15.ebuild 11771 BLAKE2B bf13cdaf7b48f1b54257eb6824a0119bdbdc1dbc727e1a63bf38bbff97b9b8bc80b6ac5dba6a2cd446a81236fc1ee38ae0680c1348c140247c3b46ca7e3db2d7 SHA512 6fdb5c658923a3cbf9515f3bed4cc6ba1ad39c7d4a8465f590000887b8c5cb1960eafb1d72ebdf493d73909ae4fbd1df7d9e02740f3343ad25594489f0744d1a
EBUILD baselayout-9999.ebuild 11771 BLAKE2B bf13cdaf7b48f1b54257eb6824a0119bdbdc1dbc727e1a63bf38bbff97b9b8bc80b6ac5dba6a2cd446a81236fc1ee38ae0680c1348c140247c3b46ca7e3db2d7 SHA512 6fdb5c658923a3cbf9515f3bed4cc6ba1ad39c7d4a8465f590000887b8c5cb1960eafb1d72ebdf493d73909ae4fbd1df7d9e02740f3343ad25594489f0744d1a
MISC metadata.xml 528 BLAKE2B 74766eb4949cff7bc3c896dc2477058a121acdde032be40bb3d2cb35874a830fc1882b5c3e6887799ffcf9cddf9fef54001eadd1b510b635c081b84b9ffeb035 SHA512 08dc12b95610151124e7dcb454a353ed10b30202aac3a7f36013c929fd5ee94436452bb48dfc77fa96bd6bb33dba0eb9c98868ef2e978f32f73fef5defc8a040
diff --git a/sys-apps/baselayout/baselayout-2.15.ebuild b/sys-apps/baselayout/baselayout-2.15.ebuild
new file mode 100644
index 000000000000..8dfcf1d42876
--- /dev/null
+++ b/sys-apps/baselayout/baselayout-2.15.ebuild
@@ -0,0 +1,364 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib prefix
+
+DESCRIPTION="Filesystem baselayout and init scripts"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="build +split-usr"
+
+RDEPEND="!sys-apps/baselayout-prefix"
+
+riscv_compat_symlink() {
+ # Here we apply some special sauce for riscv.
+ # Two multilib layouts exist for now:
+ # 1) one level libdirs, (32bit) "lib" and (64bit) "lib64"
+ # these are chosen by us to closely resemble other arches
+ # 2) two level libdirs, "lib64/lp64d" "lib64/lp64" "lib32/ilp32d" ...
+ # this is the glibc/gcc default
+ # Unfortunately, the default has only one fallback, which is "lib"
+ # for both 32bit and 64bit. So things do not break in 1), we need
+ # to provide compatibility symlinks...
+
+ # This function has exactly two parameters:
+ # - the default libdir, to determine if 1) or 2) applies
+ # - the location of the symlink (which points to ".")
+
+ # Note: we call this only in the ${SYMLINK_LIB} = no codepath, since
+ # there never was a ${SYMLINK_LIB} = yes riscv profile.
+
+ case ${CHOST} in
+ riscv*)
+ # are we on a one level libdir profile? is there no symlink yet?
+ if [[ ${1} != */* && ! -L ${2} ]] ; then
+ ln -s . $2 || die "Unable to make $2 riscv compatibility symlink"
+ fi
+ ;;
+ esac
+}
+
+# Create our multilib dirs - the Makefile has no knowledge of this
+multilib_layout() {
+ local dir def_libdir libdir libdirs
+ local prefix prefix_lst
+ def_libdir=$(get_abi_LIBDIR $DEFAULT_ABI)
+ libdirs=$(get_all_libdirs)
+
+ if [[ -z "${SYMLINK_LIB}" || ${SYMLINK_LIB} = no ]] ; then
+ prefix_lst=( "${EROOT}"/{,usr/,usr/local/} )
+ for prefix in "${prefix_lst[@]}"; do
+ for libdir in ${libdirs}; do
+ dir="${prefix}${libdir}"
+ if [[ -e "${dir}" ]]; then
+ [[ ! -d "${dir}" ]] &&
+ die "${dir} exists but is not a directory"
+ continue
+ fi
+ if ! use split-usr && [[ ${prefix} = ${EROOT}/ ]]; then
+ # for the special case of riscv multilib, we drop the
+ # second part of two-component libdirs, e.g. lib64/lp64
+ libdir="${libdir%%/*}"
+ dir="${prefix}${libdir}"
+ if [[ -h "${dir}" ]] ; then
+ if use riscv ; then
+ # with riscv we get now double entries so we
+ # need to ignore already existing symlinks
+ einfo "symlink ${dir} already exists (riscv)"
+ else
+ die "symlink ${dir} already exists"
+ fi
+ else
+ einfo "symlinking ${dir} to usr/${libdir}"
+ ln -s usr/${libdir} ${dir} ||
+ die "Unable to make ${dir} symlink"
+ fi
+ else
+ einfo "creating directory ${dir}"
+ mkdir -p "${dir}" ||
+ die "Unable to create ${dir} directory"
+ fi
+ done
+ [[ -d "${prefix}${def_libdir}" ]] && riscv_compat_symlink "${def_libdir}" "${prefix}${def_libdir}/${DEFAULT_ABI}"
+ done
+ return 0
+ fi
+
+ [ -z "${def_libdir}" ] &&
+ die "your DEFAULT_ABI=$DEFAULT_ABI appears to be invalid"
+
+ # figure out which paths should be symlinks and which should be directories
+ local dirs syms exp d
+ for libdir in ${libdirs} ; do
+ if use split-usr ; then
+ exp=( {,usr/,usr/local/}${libdir} )
+ else
+ exp=( {usr/,usr/local/}${libdir} )
+ fi
+ for d in "${exp[@]}" ; do
+ # most things should be dirs
+ if [ "${SYMLINK_LIB}" = "yes" ] && [ "${libdir}" = "lib" ] ; then
+ [ ! -h "${d}" ] && [ -e "${d}" ] && dirs+=" ${d}"
+ else
+ [ -h "${d}" ] && syms+=" ${d}"
+ fi
+ done
+ done
+ if [ -n "${syms}${dirs}" ] ; then
+ ewarn "Your system profile has SYMLINK_LIB=${SYMLINK_LIB:-no}, so that means you need to"
+ ewarn "have these paths configured as follows:"
+ [ -n "${dirs}" ] && ewarn "symlinks to '${def_libdir}':${dirs}"
+ [ -n "${syms}" ] && ewarn "directories:${syms}"
+ ewarn "The ebuild will attempt to fix these, but only for trivial conversions."
+ ewarn "If things fail, you will need to manually create/move the directories."
+ echo
+ fi
+
+ # setup symlinks and dirs where we expect them to be; do not migrate
+ # data ... just fall over in that case.
+ if use split-usr ; then
+ prefix_lst=( "${EROOT}"/{,usr/,usr/local/} )
+ else
+ prefix_lst=( "${EROOT}"/{usr/,usr/local/} )
+ fi
+ for prefix in "${prefix_lst[@]}"; do
+ if [ "${SYMLINK_LIB}" = yes ] ; then
+ # we need to make sure "lib" points to the native libdir
+ if [ -h "${prefix}lib" ] ; then
+ # it's already a symlink! assume it's pointing to right place ...
+ continue
+ elif [ -d "${prefix}lib" ] ; then
+ # "lib" is a dir, so need to convert to a symlink
+ ewarn "Converting ${prefix}lib from a dir to a symlink"
+ rm -f "${prefix}lib"/.keep || die
+ if rmdir "${prefix}lib" 2>/dev/null ; then
+ ln -s ${def_libdir} "${prefix}lib" || die
+ else
+ die "non-empty dir found where we needed a symlink: ${prefix}lib"
+ fi
+ else
+ # nothing exists, so just set it up sanely
+ ewarn "Initializing ${prefix}lib as a symlink"
+ mkdir -p "${prefix}" || die
+ rm -f "${prefix}lib" || die
+ ln -s ${def_libdir} "${prefix}lib" || die
+ mkdir -p "${prefix}${def_libdir}" || die #423571
+ fi
+ else
+ # we need to make sure "lib" is a dir
+ if [ -h "${prefix}lib" ] ; then
+ # "lib" is a symlink, so need to convert to a dir
+ ewarn "Converting ${prefix}lib from a symlink to a dir"
+ rm -f "${prefix}lib" || die
+ if [ -d "${prefix}lib32" ] ; then
+ ewarn "Migrating ${prefix}lib32 to ${prefix}lib"
+ mv "${prefix}lib32" "${prefix}lib" || die
+ else
+ mkdir -p "${prefix}lib" || die
+ fi
+ elif [ -d "${prefix}lib" ] && ! has lib32 ${libdirs} ; then
+ # make sure the old "lib" ABI location does not exist; we
+ # only symlinked the lib dir on systems where we moved it
+ # to "lib32" ...
+ case ${CHOST} in
+ i?86*|x86_64*|powerpc*|sparc*|s390*)
+ if [[ -d ${prefix}lib32 && ! -h ${prefix}lib32 ]] ; then
+ rm -f "${prefix}lib32"/.keep || die
+ if ! rmdir "${prefix}lib32" 2>/dev/null ; then
+ ewarn "You need to merge ${prefix}lib32 into ${prefix}lib"
+ die "non-empty dir found where there should be none: ${prefix}lib32"
+ fi
+ fi
+ ;;
+ esac
+ else
+ # nothing exists, so just set it up sanely
+ ewarn "Initializing ${prefix}lib as a dir"
+ mkdir -p "${prefix}lib" || die
+ fi
+ fi
+ done
+ if ! use split-usr ; then
+ for libdir in ${libdirs}; do
+ if [[ ! -e "${EROOT}${libdir}" ]]; then
+ ln -s usr/"${libdir}" "${EROOT}${libdir}" ||
+ die "Unable to make ${EROOT}${libdir} symlink"
+ fi
+ done
+ fi
+}
+
+pkg_setup() {
+ multilib_layout
+}
+
+src_prepare() {
+ default
+
+ # don't want symlinked directories in PATH on systems with usr-merge
+ if ! use split-usr && ! use prefix-guest; then
+ sed \
+ -e 's|:/usr/sbin:|:|g' \
+ -e 's|:/sbin:|:|g' \
+ -e 's|:/bin:|:|g' \
+ -i etc/env.d/50baselayout || die
+ fi
+
+ if use prefix; then
+ hprefixify -e "/EUID/s,0,${EUID}," -q '"' etc/profile
+ hprefixify etc/shells share/passwd
+ hprefixify -w '/PATH=/' etc/env.d/50baselayout
+ hprefixify -w 1 etc/env.d/50baselayout
+ echo PATH=/usr/sbin:/sbin:/usr/bin:/bin >> etc/env.d/99host
+ echo ROOTPATH=/usr/sbin:/sbin:/usr/bin:/bin >> etc/env.d/99host
+ echo MANPATH=/usr/share/man >> etc/env.d/99host
+
+ # change branding
+ sed -i \
+ -e '/gentoo-release/s/Gentoo Base/Gentoo Prefix Base/' \
+ -e '/make_os_release/s/${OS}/Prefix/' \
+ Makefile || die
+ fi
+
+ # handle multilib paths. do it here because we want this behavior
+ # regardless of the C library that you're using. we do explicitly
+ # list paths which the native ldconfig searches, but this isn't
+ # problematic as it doesn't change the resulting ld.so.cache or
+ # take longer to generate. similarly, listing both the native
+ # path and the symlinked path doesn't change the resulting cache.
+ local libdir ldpaths
+ for libdir in $(get_all_libdirs) ; do
+ if use split-usr || use prefix-guest; then
+ ldpaths+=":${EPREFIX}/${libdir}"
+ fi
+ ldpaths+=":${EPREFIX}/usr/${libdir}"
+ ldpaths+=":${EPREFIX}/usr/local/${libdir}"
+ done
+ echo "LDPATH='${ldpaths#:}'" >> etc/env.d/50baselayout
+}
+
+src_install() {
+ emake \
+ DESTDIR="${ED}" \
+ install
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # add SDK path which contains development manpages
+ echo "MANPATH=${EPREFIX}/MacOSX.sdk/usr/share/man" \
+ > "${ED}"/etc/env.d/98macos-sdk
+ fi
+
+ # need the makefile in pkg_preinst
+ insinto /usr/share/${PN}
+ doins Makefile
+
+ dodoc ChangeLog
+
+ # bug 858596
+ if use prefix-guest ; then
+ dodir sbin
+ cat > "${ED}"/sbin/runscript <<- EOF
+ #!/usr/bin/env sh
+ source "${EPREFIX}/lib/gentoo/functions.sh"
+
+ eerror "runscript/openrc-run not supported by Gentoo Prefix Base System release ${PV}" 1>&2
+ exit 1
+ EOF
+ chmod 755 "${ED}"/sbin/runscript || die
+ cp "${ED}"/sbin/{runscript,openrc-run} || die
+ fi
+}
+
+pkg_preinst() {
+ # We need to install directories and maybe some dev nodes when building
+ # stages, but they cannot be in CONTENTS.
+ # Also, we cannot reference $S as binpkg will break so we do this.
+ multilib_layout
+ if use build ; then
+ if use split-usr ; then
+ emake -C "${ED}/usr/share/${PN}" DESTDIR="${EROOT}" layout
+ else
+ emake -C "${ED}/usr/share/${PN}" DESTDIR="${EROOT}" layout-usrmerge
+ fi
+ fi
+ rm -f "${ED}"/usr/share/${PN}/Makefile || die
+
+ # Create symlinks in pkg_preinst to avoid Portage collision check.
+ # Create the symlinks in ${ED} via dosym so that we own it.
+ # Only create the symlinks if it wont cause a conflict in ${EROOT}.
+ if [[ -L ${EROOT}/var/lock || ! -e ${EROOT}/var/lock ]]; then
+ dosym ../run/lock /var/lock
+ fi
+ if [[ -L ${EROOT}/var/run || ! -e ${EROOT}/var/run ]]; then
+ dosym ../run /var/run
+ fi
+}
+
+pkg_postinst() {
+ local x
+
+ # We installed some files to /usr/share/baselayout instead of /etc to stop
+ # (1) overwriting the user's settings
+ # (2) screwing things up when attempting to merge files
+ # (3) accidentally packaging up personal files with quickpkg
+ # If they don't exist then we install them
+ for x in master.passwd passwd shadow group fstab ; do
+ [ -e "${EROOT}/etc/${x}" ] && continue
+ [ -e "${EROOT}/usr/share/baselayout/${x}" ] || continue
+ cp -p "${EROOT}/usr/share/baselayout/${x}" "${EROOT}"/etc || die
+ done
+
+ # Force shadow permissions to not be world-readable #260993
+ for x in shadow ; do
+ if [ -e "${EROOT}/etc/${x}" ] ; then
+ chmod o-rwx "${EROOT}/etc/${x}" || die
+ fi
+ done
+ # whine about users that lack passwords #193541
+ if [[ -e "${EROOT}"/etc/shadow ]] ; then
+ local bad_users=$(sed -n '/^[^:]*::/s|^\([^:]*\)::.*|\1|p' "${EROOT}"/etc/shadow)
+ if [[ -n ${bad_users} ]] ; then
+ echo
+ ewarn "The following users lack passwords!"
+ ewarn ${bad_users}
+ fi
+ fi
+
+ # whine about users with invalid shells #215698
+ if [[ -e "${EROOT}"/etc/passwd ]] ; then
+ local bad_shells=$(awk -F: 'system("test -e ${ROOT}" $7) { print $1 " - " $7}' "${EROOT}"/etc/passwd | sort)
+ if [[ -n ${bad_shells} ]] ; then
+ echo
+ ewarn "The following users have non-existent shells!"
+ ewarn "${bad_shells}"
+ fi
+ fi
+
+ # https://bugs.gentoo.org/361349
+ if use kernel_linux; then
+ mkdir -p "${EROOT}"/run || die
+
+ local found fstype mountpoint
+ while read -r _ mountpoint fstype _; do
+ [[ ${mountpoint} = /run ]] && [[ ${fstype} = tmpfs ]] && found=1
+ done < "${ROOT}"/proc/mounts
+ [[ -z ${found} ]] &&
+ ewarn "You should reboot now to get /run mounted with tmpfs!"
+ fi
+
+ if [[ -e "${EROOT}"/etc/env.d/00basic ]]; then
+ ewarn "${EROOT}/etc/env.d/00basic is now ${EROOT}/etc/env.d/50baselayout"
+ ewarn "Please migrate your changes."
+ fi
+}
diff --git a/sys-apps/usbredir/Manifest b/sys-apps/usbredir/Manifest
index 1b079d52fb02..468de133b84e 100644
--- a/sys-apps/usbredir/Manifest
+++ b/sys-apps/usbredir/Manifest
@@ -1,4 +1,5 @@
DIST usbredir-usbredir-0.13.0.tar.bz2 68836 BLAKE2B c0efabd12dec51bffa6e639db0a82547ec5c93ca649de823a6240373154d0929df599924ab3868d24ad74c7795202ad92ff1221589f37799944e34424acadf2d SHA512 b71eb1814ef456bebf62bac2e273f9a41b1451ae50941018c36d79298d74ac29c1137b66a4a928fd46c1fcd2905b83d3774fab703d88f9ea7e3e4e14420958ca
+DIST usbredir-usbredir-0.14.0.tar.bz2 69515 BLAKE2B c521a08b789eade8947c4deac1c840efa519b67efd376121371dd9999b9a4864b3e3a6a6cbc999f5f4ee2b1c60e8ff12ddf8656b6386928b2312c2d782120c13 SHA512 cbae84c472de71d8784b24bb4e903fdb350f58d80cb595c180b8cfc3e1e727c6c6ce9de9e2929c88b0c041c7ed91de4d1c89a3dd2016a97fd32d66e6c0b34998
EBUILD usbredir-0.13.0-r1.ebuild 956 BLAKE2B 9662ce1d00fd1034f75dcdea3fd19f45e2dd267354fbe7cfc6c7226e75024e1cf4fcf3c37152ccfdbda26584f42b3823e0d44ea9f7d817eb2c44f03993ee2474 SHA512 5a146d92961c47d3c6d509993fcfa67a91b55289c6f4c954ca5fe77f562df80884aa44086dbf0a7c8af17c1283737aa40c352b8a5952c4427010763524ce8e3d
-EBUILD usbredir-0.13.0.ebuild 859 BLAKE2B 977095e1b7f80622b066a007aa4040e1a733981eae32712c2e66e1a067b21b43626baaebd07c4235b7372fb2405b6a6bda2b5867a90d0ee86f703e46e090c0f2 SHA512 a25861ec7c667cc3d7b3f3f9b179149c2bc557d390f24c09f9dda3872efb29a726630971d9080a91a3ea045c12ca8d45c4cd917821dccb85a4aff4fce2b45e4c
+EBUILD usbredir-0.14.0.ebuild 962 BLAKE2B b0b4209d2a3ba0bd62d3b3844529331254ff81bda495c34d98b7b6104300483a3ec2fb85f2428a3d768959f9388c1caec9a7efcff03ea1239d3fb4e9a0e3b766 SHA512 7344797121cf1bc4378ec610304d9fe6a4fe8a2a751ce2b401faedeed841f9040c38aa39d6ad2255e806d26bf57ca1dd6d59279753d45f6e412db9a8b396f3af
MISC metadata.xml 481 BLAKE2B 705eee8b08c628f347b7f31d7f45b2323660442520fd6644a41ca16bf28605f904b80a451e3821fbfe07362d09242bf2b041067ba19563052385f61efd5d67be SHA512 8d68d6428971fed1283fd6d0eb91819cf9b87a9b00efb228e437115d636f4eb7c3c1c6d07fb11697a3a6b825f1975b53431068675df0624be3a55ffed9efaf50
diff --git a/sys-apps/usbredir/usbredir-0.13.0.ebuild b/sys-apps/usbredir/usbredir-0.14.0.ebuild
index 14d387242d5d..55f0935bdece 100644
--- a/sys-apps/usbredir/usbredir-0.13.0.ebuild
+++ b/sys-apps/usbredir/usbredir-0.14.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,7 @@ S="${WORKDIR}"/usbredir-${P}
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~loong ppc ppc64 ~riscv ~sparc x86"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
@@ -24,6 +24,9 @@ RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
src_configure() {
+ # This overrides our toolchain default.
+ sed -i -e '/-D_FORTIFY_SOURCE=2/d' meson.build || die
+
local emesonargs=(
-Dgit_werror=disabled
$(meson_feature test tests)