summaryrefslogtreecommitdiff
path: root/sys-apps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-17 00:13:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-17 00:13:57 +0000
commit27b3683509c5229cce540418778a8b64afbc0009 (patch)
treeb7164898142b8b093b91c8254c4387b6eec679ee /sys-apps
parentf2bdc27fe0f79f8f9a3945eb2b1163ce75c56439 (diff)
gentoo auto-resync : 17:02:2025 - 00:13:57
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/Manifest.gzbin51554 -> 51552 bytes
-rw-r--r--sys-apps/xdg-dbus-proxy/Manifest2
-rw-r--r--sys-apps/xdg-dbus-proxy/xdg-dbus-proxy-0.1.6.ebuild37
3 files changed, 39 insertions, 0 deletions
diff --git a/sys-apps/Manifest.gz b/sys-apps/Manifest.gz
index 1b0bc464e326..e8b3fd84c438 100644
--- a/sys-apps/Manifest.gz
+++ b/sys-apps/Manifest.gz
Binary files differ
diff --git a/sys-apps/xdg-dbus-proxy/Manifest b/sys-apps/xdg-dbus-proxy/Manifest
index 3f3db897618d..afad8e218e0c 100644
--- a/sys-apps/xdg-dbus-proxy/Manifest
+++ b/sys-apps/xdg-dbus-proxy/Manifest
@@ -1,3 +1,5 @@
DIST xdg-dbus-proxy-0.1.5.tar.xz 124780 BLAKE2B bb9e1c42826ebfab1a93351f43ab09d7280dc27883bfd23d00c8c919bd7b0ea12b87acffe8025d4c41301593c71a98af4ccf10b6c780479e84e020529a8d08bb SHA512 4b079c060aa4c1d7f305216d03166b9edc19cb73ef1230e14a882f07a6400929f62afc8535338c8560ea032a519c0934fbc69533f5bebb555fecb8f090330a33
+DIST xdg-dbus-proxy-0.1.6.tar.xz 48920 BLAKE2B be5b59e3b9e59a52e0ad1a59d69eab5baa56d484b80413fd763556ad1da33c5d720afb3a61dec2e41c9a6ffcfbd974ec44999872dd724315ec97cfe01c651e7b SHA512 9aeb3c00c8507b583954ba928171d7b373159a614eb9df15a4352d4b929d0c76d836b522cdc031e2f38a076ab5ec363441208e403a899aa9f0e58d703791ed2d
EBUILD xdg-dbus-proxy-0.1.5.ebuild 735 BLAKE2B ffe0ecda25c71ff6e835bcda5ad2c6ec7e7f41e805843c8f56660716e2e21656f373ba2c19ee3ae085f84fc60642ba99d2115136b7f1aa9b95bf2901444d0be9 SHA512 23885cec171c8b56187c1116f05810bb71b50b0e3035d45ed1923d309f477a9a6ea1a3fe1278fb18baaaa06f6fef9770bec17e99b274812b352c96bd3e41d7ce
+EBUILD xdg-dbus-proxy-0.1.6.ebuild 741 BLAKE2B 902b82403890538d67e95a94ad0d7c787feb4dece07fed54cf5fc0114b2534998d80fe3fd5001197db3b8968e69dc22db07ba3ed8c73a62cb516bb88584778c4 SHA512 3702435ed952d2359667cf64528710c1ea0d53c595c5008fbfbf3c9db1861a38f23f580a2c9943ec2a01faa121a4f66cc0916606d51fce355afd35d7480b9649
MISC metadata.xml 341 BLAKE2B 4bf518fc7deed5c52f79f3dcac23bacb777ffb758ce4d7aeefa9c17b7631cea92730ac133b22717866075c0e087c054a570cbfad63b6e90a28439ea884e69b72 SHA512 2fdb239af65e50174d60d74d9069c3a1577ee9de45e41b1b2f8ef5df28d05b2e44f41b4ec9a4559246525d2fbaafe88b631ce7f994695e3043bc97367605b494
diff --git a/sys-apps/xdg-dbus-proxy/xdg-dbus-proxy-0.1.6.ebuild b/sys-apps/xdg-dbus-proxy/xdg-dbus-proxy-0.1.6.ebuild
new file mode 100644
index 000000000000..ba615d50f0c0
--- /dev/null
+++ b/sys-apps/xdg-dbus-proxy/xdg-dbus-proxy-0.1.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Filtering proxy for D-Bus connections"
+HOMEPAGE="https://github.com/flatpak/xdg-dbus-proxy"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+"
+DEPEND="${RDEPEND}
+ test? ( sys-apps/dbus )
+"
+BDEPEND="
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dinstalled_tests=false
+ -Dman=enabled
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}