summaryrefslogtreecommitdiff
path: root/sys-apps/yarn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /sys-apps/yarn
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'sys-apps/yarn')
-rw-r--r--sys-apps/yarn/Manifest2
-rw-r--r--sys-apps/yarn/yarn-1.22.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/yarn/Manifest b/sys-apps/yarn/Manifest
index 3d4716923bd7..cbb36611c23a 100644
--- a/sys-apps/yarn/Manifest
+++ b/sys-apps/yarn/Manifest
@@ -1,5 +1,7 @@
DIST yarn-v1.19.2.tar.gz 1244018 BLAKE2B f88d0b6c5c3bdb6e02c0dd8c36fa981d35a0e46da143399dbbd8a39fac13669dc1b459f3ecd192c99d767fc477f54e61d74caeafaf9d1f0cdfdc4fba0b405fb6 SHA512 39d2cdfcafec03e2a75b8820350c0760ae9825d2e4496c5bc7a21877e588409eb10df93c08860a72405fc06c530660da125b96b3cdc89f38c50a652a3eda58fb
DIST yarn-v1.21.1.tar.gz 1244168 BLAKE2B 351ee6421fd85563ceb5d1e49f600b4f315041d85b412cd36a0bcfe352cd974ddf6c53e03171bf173794400c31eabc4fca5f3ae2402770441a9d9942ec79cf82 SHA512 75082626febbe97fcd41cce96e20ed73686c13fa69a460c9033c25462003313bc5cd86ddc4f8f658ee0f70dcab892b767388ec08ca6df14151287528ceddb519
+DIST yarn-v1.22.0.tar.gz 1244012 BLAKE2B 2764704103e281de8fd8c2c28abae56c7ba863365989b884add045d2f80810f0f8b83acd77baeef2375fe1424ad54cabfd89e4d14b38068114552115d3b7a812 SHA512 28c1cffc9ab9de364a4d8f624d4b77748565fdb7ba50fb3620da3debe0676472cac583537f03269601d368c5b2199a0eef8448e00205be75a162b5ead9448992
EBUILD yarn-1.19.2.ebuild 983 BLAKE2B c2704e1e8d808e0092971ce0fb027c36f4b4d5e21edd38740de3578156d13a0127db6bd5674af08ddba1e2ebaa54d85b4de13ad85ae9b412a9973f17c0e7f5de SHA512 367b7ce5e5b178d1f5678bee8a7ad0f1dbe87c0c10403d5d91ca96f0901d66f28a4ee66ee1093bbc43965b1759722a99d92b2f749b356daa635fcae3689678d4
EBUILD yarn-1.21.1.ebuild 1058 BLAKE2B be9fcdd3e7c70238e3efd9431b333cd6252dfe09d5ee7e3cd05c6b448d7ff76b63aecf6047eee373e549b2d119897fb0f9362df5f10eadbc340b0b03017cc5bf SHA512 3ccce50a4f4aea6cb1c9a568943828f3a3ba1e9820e5ad8c3a00ba65494f71c2c4437f559ece09b7a1fbb8f772413eea6eb60cfb6d186d5c535654593d91f2fb
+EBUILD yarn-1.22.0.ebuild 1058 BLAKE2B cc521c197011573800b7671b187d0f5507df0dfb9283f4f5355cb29fc9c1f72a7e5e34589928bab4fea27a2d26f735b6274b011486efa70c6f347ff51327c4cd SHA512 ccdce002d42bd31f614e92bb8703eeba3c713504b1e2feb03120d76c35475328ff40772c1b3b237c48e87e09a86f4ba149bf3f38aed3d52a3a6f303b33621dc4
MISC metadata.xml 545 BLAKE2B 223f9132b5cbabf71b64028e2fd75d4de88566b59069db3e1ebcf195cf3143e1c4c0f04dfa05d911a65f9d8ff29504385a9d8ed3001f66473e39ee2bca2417ba SHA512 f742b0908db5b89cd69b910497da75f129a0bc73b6068df891a4b8673d233b3bacc5347d98a872fdf8984f588c4991ae6c2b65ab60fbf81bfc5474402efae44a
diff --git a/sys-apps/yarn/yarn-1.22.0.ebuild b/sys-apps/yarn/yarn-1.22.0.ebuild
new file mode 100644
index 000000000000..706453936e75
--- /dev/null
+++ b/sys-apps/yarn/yarn-1.22.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${PN}-v${PV}"
+
+DESCRIPTION="Fast, reliable, and secure node dependency management"
+HOMEPAGE="https://yarnpkg.com"
+SRC_URI="https://github.com/yarnpkg/yarn/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!dev-util/cmdtest
+ net-libs/nodejs"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ sed -i 's/"installationMethod": "tar"/"installationMethod": "portage"/g' "${S}/package.json" || die
+}
+
+src_install() {
+ local install_dir="/usr/$(get_libdir)/node_modules/yarn" path shebang
+ insinto "${install_dir}"
+ doins -r .
+ dosym "../$(get_libdir)/node_modules/yarn/bin/yarn.js" "/usr/bin/yarn"
+ dosym "../$(get_libdir)/node_modules/yarn/bin/yarnpkg" "/usr/bin/yarnpkg"
+
+ while read -r -d '' path; do
+ read -r shebang < "${ED}${path}" || die
+ [[ "${shebang}" == \#\!* ]] || continue
+ fperms +x "${path}"
+ done < <(find "${ED}" -type f -printf '/%P\0' || die)
+}