summaryrefslogtreecommitdiff
path: root/sys-apps/yarn/yarn-1.12.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /sys-apps/yarn/yarn-1.12.3.ebuild
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'sys-apps/yarn/yarn-1.12.3.ebuild')
-rw-r--r--sys-apps/yarn/yarn-1.12.3.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-apps/yarn/yarn-1.12.3.ebuild b/sys-apps/yarn/yarn-1.12.3.ebuild
index 7bd9670239d3..d2f20fcebb47 100644
--- a/sys-apps/yarn/yarn-1.12.3.ebuild
+++ b/sys-apps/yarn/yarn-1.12.3.ebuild
@@ -20,6 +20,11 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
+src_prepare() {
+ default
+ sed -i 's/"installationMethod": "tar"/"installationMethod": "portage"/g' "${S}/package.json" || die
+}
+
src_install() {
local install_dir="/usr/$(get_libdir)/node_modules/yarn" path shebang
insinto "${install_dir}"