summaryrefslogtreecommitdiff
path: root/sys-apps/yarn/yarn-1.12.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /sys-apps/yarn/yarn-1.12.3.ebuild
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'sys-apps/yarn/yarn-1.12.3.ebuild')
-rw-r--r--sys-apps/yarn/yarn-1.12.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/yarn/yarn-1.12.3.ebuild b/sys-apps/yarn/yarn-1.12.3.ebuild
new file mode 100644
index 000000000000..7bd9670239d3
--- /dev/null
+++ b/sys-apps/yarn/yarn-1.12.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${PN}-v${PV}"
+
+DESCRIPTION="Fast, reliable, and secure node dependency management"
+HOMEPAGE="https://yarnpkg.com"
+SRC_URI="https://github.com/yarnpkg/yarn/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!dev-util/cmdtest
+ net-libs/nodejs"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ local install_dir="/usr/$(get_libdir)/node_modules/yarn" path shebang
+ insinto "${install_dir}"
+ doins -r .
+ dosym "../$(get_libdir)/node_modules/yarn/bin/yarn.js" "/usr/bin/yarn"
+
+ while read -r -d '' path; do
+ read -r shebang < ${path} || die
+ [[ "${shebang}" == \#\!* ]] || continue
+ chmod +x "${path}" || die #614094
+ done < <(find "${ED}" -type f -print0 || die)
+}