summaryrefslogtreecommitdiff
path: root/sys-apps/yarn/yarn-1.10.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /sys-apps/yarn/yarn-1.10.1.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'sys-apps/yarn/yarn-1.10.1.ebuild')
-rw-r--r--sys-apps/yarn/yarn-1.10.1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/sys-apps/yarn/yarn-1.10.1.ebuild b/sys-apps/yarn/yarn-1.10.1.ebuild
deleted file mode 100644
index d2f20fcebb47..000000000000
--- a/sys-apps/yarn/yarn-1.10.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_P="${PN}-v${PV}"
-
-DESCRIPTION="Fast, reliable, and secure node dependency management"
-HOMEPAGE="https://yarnpkg.com"
-SRC_URI="https://github.com/yarnpkg/yarn/releases/download/v${PV}/${MY_P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="!dev-util/cmdtest
- net-libs/nodejs"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- default
- sed -i 's/"installationMethod": "tar"/"installationMethod": "portage"/g' "${S}/package.json" || die
-}
-
-src_install() {
- local install_dir="/usr/$(get_libdir)/node_modules/yarn" path shebang
- insinto "${install_dir}"
- doins -r .
- dosym "../$(get_libdir)/node_modules/yarn/bin/yarn.js" "/usr/bin/yarn"
-
- while read -r -d '' path; do
- read -r shebang < ${path} || die
- [[ "${shebang}" == \#\!* ]] || continue
- chmod +x "${path}" || die #614094
- done < <(find "${ED}" -type f -print0 || die)
-}