summaryrefslogtreecommitdiff
path: root/sys-apps/xdg-desktop-portal
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /sys-apps/xdg-desktop-portal
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'sys-apps/xdg-desktop-portal')
-rw-r--r--sys-apps/xdg-desktop-portal/Manifest2
-rw-r--r--sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.14.2.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal/Manifest b/sys-apps/xdg-desktop-portal/Manifest
index a9e563c7ec74..c21b50e13bdf 100644
--- a/sys-apps/xdg-desktop-portal/Manifest
+++ b/sys-apps/xdg-desktop-portal/Manifest
@@ -1,3 +1,5 @@
DIST xdg-desktop-portal-1.12.1.tar.xz 484352 BLAKE2B afa14ab78f35cb1c0e66514f313f5dc297ceef88af1ca7b3028305faa8398bdae1b9e897289b18a93b1cda1a8290c0e51bf73e66c9dce231f57a58652fb9e120 SHA512 62df427e2d8d54acd9a34a02a77c26ae3911fbb4c5844eff4a253dc839775c929c6945401b93549ba200ba637d315146767e41f18a831d7627b35de880de0da1
+DIST xdg-desktop-portal-1.14.2.tar.xz 504088 BLAKE2B e0a378c1f1d80afda7d73fd8e545f7304eeab349cf3298ebb616021c7e16e8a088360681e31eedca9ac90978eb04167a7e857ddaa5e023a2a8c24c9f959f9b2c SHA512 7164d6c0d89843d117e03bc46963d72f24dae2b9fc8e173f06a78bbc80655ccf192d86f951d3c404c88bf5da88d9d2053ea52cf3e541b833ee937b6931d803d7
EBUILD xdg-desktop-portal-1.12.1.ebuild 987 BLAKE2B 94bb8e58df78606aca537d7d824fa28624d1363ecbb851da6cf26c1c9c9df001c374700ce1927d9c8e21c4f9ba57f8f0401b67384b402955884b22e34f498323 SHA512 8364ffd4409b01f374b3e192bfb7e955f00e9c8fe056439b34ec5cc2b2ca750fb69ddef02469d5b542f6bee51f4de8885802acabccd6f112184920c9dcb814e4
+EBUILD xdg-desktop-portal-1.14.2.ebuild 1057 BLAKE2B 96717ed1de8af640d5a2e9ba776e04b9901c2980654d4bac60146201abe0ba5a9e13251ad49d25d89bd027fb3dd7619b5551d33075443babeb0c0c0a5ad5816f SHA512 e9e4de40e97bd48e80a88246c307a470c14a62cd76c1e1a0292958569a6f42e9ae0ac1f42b8ad0f23f3ca041339ee6fccde010b46cb032114cdea1622c26725e
MISC metadata.xml 361 BLAKE2B 29f050b1cf9380b76d4a779066ae0db5704da11ba9d97e1b2ed7c8d15003d534ecb83c4cd186e7f47e0e89b10e51299ee7bdd9acff9a02f9dc721647bca283da SHA512 872fc2c477635667b5593856f3fef346b96add82b754f9978c36c3c4e56a00516196faab14bac0adff40636c481ba436889b13549b2fc29412f3a21d1166fa25
diff --git a/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.14.2.ebuild b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.14.2.ebuild
new file mode 100644
index 000000000000..32e526740664
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.14.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="Desktop integration portal"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="geolocation screencast systemd"
+
+DEPEND="
+ >=dev-libs/glib-2.66:2
+ dev-libs/json-glib
+ >=sys-fs/fuse-3.10.0:3
+ x11-libs/gdk-pixbuf
+ geolocation? ( >=app-misc/geoclue-2.5.3:2.0 )
+ screencast? ( >=media-video/pipewire-0.3:= )
+"
+RDEPEND="${DEPEND}
+ sys-apps/dbus
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-docbook-docs # requires flatpak
+ --disable-libportal # not packaged
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ $(use_enable geolocation geoclue)
+ $(use_enable screencast pipewire)
+ $(use_with systemd)
+ )
+ econf "${myeconfargs[@]}"
+}