summaryrefslogtreecommitdiff
path: root/sys-apps/xdg-desktop-portal
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
commit0f15659d48c193027158492acb726297501202c5 (patch)
tree5502ba879a78b759da28441d418dbbfe08bd8f03 /sys-apps/xdg-desktop-portal
parent93a93e9a3b53c1a73142a305ea1f8136846942ee (diff)
gentoo xmass resync : 25.12.2021
Diffstat (limited to 'sys-apps/xdg-desktop-portal')
-rw-r--r--sys-apps/xdg-desktop-portal/Manifest2
-rw-r--r--sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.12.1.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal/Manifest b/sys-apps/xdg-desktop-portal/Manifest
index aed79789ddc1..b9395f41803c 100644
--- a/sys-apps/xdg-desktop-portal/Manifest
+++ b/sys-apps/xdg-desktop-portal/Manifest
@@ -1,3 +1,5 @@
DIST xdg-desktop-portal-1.10.1.tar.xz 479660 BLAKE2B 88a2b8ea890036bf0d4192fae4ae143e350d903a528e09a0bd7ffc7bda2a58b5c04ae80f1cec4357bb05cba8db417b6193fc6ef7f7dd65bf414f80a8ac2800c5 SHA512 5db0bd866674ff016d864646ea7f91f09a1b8fbc5ec735e4c97165af71770d2c7d3333e771062644dd522b32f67ead72bc7ef99186e3b069671c174d4d601fdc
+DIST xdg-desktop-portal-1.12.1.tar.xz 484352 BLAKE2B afa14ab78f35cb1c0e66514f313f5dc297ceef88af1ca7b3028305faa8398bdae1b9e897289b18a93b1cda1a8290c0e51bf73e66c9dce231f57a58652fb9e120 SHA512 62df427e2d8d54acd9a34a02a77c26ae3911fbb4c5844eff4a253dc839775c929c6945401b93549ba200ba637d315146767e41f18a831d7627b35de880de0da1
EBUILD xdg-desktop-portal-1.10.1.ebuild 987 BLAKE2B ad57dd3a283dc008a022b61bdb0a23c8aa3476ca466a528387aa7ebffce602a75e9f1349f53e0f806d50e94a61eeb74774452bf0955cdf8b05ca3e40e438fd10 SHA512 6e9b80266a96c9b9f7752849395e0543bf083ccaa1490a94f73891530c9bfa03d25338a00b53f234c21ffecde74714690f9208d326d83e9aadf69f4458f972a7
+EBUILD xdg-desktop-portal-1.12.1.ebuild 990 BLAKE2B 69077d25af98362d53549b448b3eb3d0b29bf6e4732ae99c835636e147ac91d432aa0cd98799da15f2e7d78becdebd88f3fe67b6049e11c91c9b2091006d1cb9 SHA512 95db5a9f0a322f602b9520c67be1a6eb76a56c42be893649dd434ee1ad0d8fd89266a03e84a35248f38350b45c1621518a342e1af9ff30e3ae0d6f1b6a559167
MISC metadata.xml 361 BLAKE2B 29f050b1cf9380b76d4a779066ae0db5704da11ba9d97e1b2ed7c8d15003d534ecb83c4cd186e7f47e0e89b10e51299ee7bdd9acff9a02f9dc721647bca283da SHA512 872fc2c477635667b5593856f3fef346b96add82b754f9978c36c3c4e56a00516196faab14bac0adff40636c481ba436889b13549b2fc29412f3a21d1166fa25
diff --git a/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.12.1.ebuild b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.12.1.ebuild
new file mode 100644
index 000000000000..1b6590b6ba9b
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.12.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="Desktop integration portal"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="geolocation screencast"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib
+ sys-fs/fuse:0
+ geolocation? ( >=app-misc/geoclue-2.5.3:2.0 )
+ screencast? ( >=media-video/pipewire-0.3:= )
+"
+RDEPEND="${DEPEND}
+ sys-apps/dbus
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-docbook-docs # requires flatpak
+ --disable-libportal # not packaged
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ $(use_enable geolocation geoclue)
+ $(use_enable screencast pipewire)
+ )
+ econf "${myeconfargs[@]}"
+}