summaryrefslogtreecommitdiff
path: root/sys-apps/xdg-desktop-portal
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-23 21:45:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-23 21:45:48 +0000
commit0530006d7f63d6c158b4ff5ea0c3f7ef3bae9cc4 (patch)
treeb3f2e1932614978a64f3fff0cf39d188bcb8a4d3 /sys-apps/xdg-desktop-portal
parent9217a0cce81e89f5648599fcda4e549903c7b9bd (diff)
gentoo auto-resync : 23:02:2023 - 21:45:48
Diffstat (limited to 'sys-apps/xdg-desktop-portal')
-rw-r--r--sys-apps/xdg-desktop-portal/Manifest2
-rw-r--r--sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.16.0.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal/Manifest b/sys-apps/xdg-desktop-portal/Manifest
index 89817243d0f3..f39673471321 100644
--- a/sys-apps/xdg-desktop-portal/Manifest
+++ b/sys-apps/xdg-desktop-portal/Manifest
@@ -1,3 +1,5 @@
DIST xdg-desktop-portal-1.15.0.tar.xz 521732 BLAKE2B a49ab7a1462771c628a24f9759e239dd3f8233b26c2a5f6e9fc848e00eb36c74a21cd1fd4d43af0c0f46782c46d6a822af86fd7b49fa1f77a1cbd96452a00348 SHA512 98b36841c54bdd5221c0719e9646abb7f117351ff780682591c269d2a57f7b1946deaef38c2caa6474e1048e283a68c55a791e8d2a0be000ca9e563ed98c28ef
+DIST xdg-desktop-portal-1.16.0.tar.xz 250524 BLAKE2B 9d5bd760621b114a19c1cc8895f91c43fcfed0dd067ba9678de0f11dc7835ec29c4a2c452274adbd36ee1318359caa8d7ca0c585558eb73a2a4e53528e6b02da SHA512 f7e7e96d3a6757901fbc4c0310aac0afbf37882c279a2859e06f63528049cd9b50dd2d55445d1386f03f62557c1a2ec81d4ee081200367d6269d2dffc75f0912
EBUILD xdg-desktop-portal-1.15.0.ebuild 1705 BLAKE2B 787d37227f646a0990a9629cb603fd4c058f57ec204ee4f8d6c3b9f6fd337e3b31ff9dd762380e3f078f724b02e9be0cb4d0c64ac6a31a4656f1f857e7b402f7 SHA512 2a44b986668963f58a23dece2613787acf2ee6f880dbc7168bf8fcfbacfc83e6c250c37c3b30b7cc5f6fde0a2ca8caee93300ebf31773c0738704c74fa462b6b
+EBUILD xdg-desktop-portal-1.16.0.ebuild 1759 BLAKE2B d65bfdcaa39510ca667bc241fb16e1618b73e274be8461e47756a5917a8560bfd42133ee60ae86fee9f3ece4724bcb69992dbb3fa7350dec7ea2452c69543cdf SHA512 2759ba7332be0527e643cb23e9f639f8ba3ed816fcacc65b44f3d34f8876b2bc40aaa4b4b9c2355d1d85d91805af21dd0e0b5bf2ee646cba93c01ca43b154558
MISC metadata.xml 250 BLAKE2B f3e9395137ebb9adf46cd35c1b6156f82c04cfa94f964f6da24fe71eb560cf51b4f70ebfa10daaa4884400ec22782d819ab794dfd29e7a47559f07208397195d SHA512 78c4ff15eed76ba883b457be95dabd41e928a0e64a42b758b5eab4d8a95afca27d5ea6a7cfe0948de578b169153a05f08aadfce1ddd41a88732212a1e76e565f
diff --git a/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.16.0.ebuild b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.16.0.ebuild
new file mode 100644
index 000000000000..5f3a38ec9574
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.16.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd
+
+DESCRIPTION="Desktop integration portal"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="geolocation screencast systemd"
+
+DEPEND="
+ >=dev-libs/glib-2.66:2
+ dev-libs/json-glib
+ >=sys-fs/fuse-3.10.0:3[suid]
+ x11-libs/gdk-pixbuf
+ geolocation? ( >=app-misc/geoclue-2.5.3:2.0 )
+ screencast? ( >=media-video/pipewire-0.3:= )
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}
+ sys-apps/dbus
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-docbook-docs # requires flatpak
+ --disable-libportal # not packaged
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ $(use_enable geolocation geoclue)
+ $(use_enable screencast pipewire)
+ $(use_with systemd)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+pkg_postinst() {
+ if ! has_version gui-libs/xdg-desktop-portal-lxqt && ! has_version gui-libs/xdg-desktop-portal-wlr && \
+ ! has_version kde-plasma/xdg-desktop-portal-kde && ! has_version sys-apps/xdg-desktop-portal-gnome && \
+ ! has_version sys-apps/xdg-desktop-portal-gtk; then
+ elog "${PN} is not usable without any of the following XDP"
+ elog "implementations installed:"
+ elog " gui-libs/xdg-desktop-portal-lxqt"
+ elog " gui-libs/xdg-desktop-portal-wlr"
+ elog " kde-plasma/xdg-desktop-portal-kde"
+ elog " sys-apps/xdg-desktop-portal-gnome"
+ elog " sys-apps/xdg-desktop-portal-gtk"
+ fi
+}