summaryrefslogtreecommitdiff
path: root/sys-apps/xdg-desktop-portal-xapp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-15 23:36:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-15 23:36:27 +0000
commit31c69c39a3648b52dd931a40b198714249e8a5ec (patch)
treec7bfb4db01cf185b6b8f7bde72d9cc5d14d8db22 /sys-apps/xdg-desktop-portal-xapp
parentdce60e5aa0a12ccc07c10a0a2c3f8f063393b32a (diff)
gentoo auto-resync : 15:02:2024 - 23:36:26
Diffstat (limited to 'sys-apps/xdg-desktop-portal-xapp')
-rw-r--r--sys-apps/xdg-desktop-portal-xapp/Manifest3
-rw-r--r--sys-apps/xdg-desktop-portal-xapp/metadata.xml15
-rw-r--r--sys-apps/xdg-desktop-portal-xapp/xdg-desktop-portal-xapp-1.0.4.ebuild36
3 files changed, 54 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal-xapp/Manifest b/sys-apps/xdg-desktop-portal-xapp/Manifest
new file mode 100644
index 000000000000..21e984264ffa
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-xapp/Manifest
@@ -0,0 +1,3 @@
+DIST xdg-desktop-portal-xapp-1.0.4.tar.gz 88429 BLAKE2B 7f45a252a5c0dd433238a58012c65369240e7974a93d3d2b5b73bdbc91509480977ad1ce381a6f4ee3a0c87bfabd11ce87bf99839018811a84378e54be1ef36f SHA512 3f861473a763c37a1af95e3beb13c3364a04f557310d5a6520845bc754941149eb3d80a4e2893699715ff11b135edb2859f6349b6aa6fbe0aa1e173263e22dba
+EBUILD xdg-desktop-portal-xapp-1.0.4.ebuild 806 BLAKE2B 714d9163aed078d2b82859a61744125dce309d2c487b6ae176d9c6911d584df31ee265831db03fb9d6056de22dbb78adf76484d3d009d3e6cbf4058a9b5b95b9 SHA512 dfb1f964ab78da32c43a2b10177a456d248f443014b9a68c4b3863b7911bdc2c574ec3ae846b968273384425916faac3e18da3e176c222fc9b93614c07772cfc
+MISC metadata.xml 503 BLAKE2B d18cb4ecc008c396116061965eb5a07fccdab52684891a4200da5141d7f2f26d519eef4c81980e05f86d8ab337e5b8aadc5da19ee73b951ff632cb0e998ff7bc SHA512 72cae90440ff0c8d50361d9a2bc5b9e1dc6c4e4f59e12197aeb664b75cfc1d38f5f00e2bb051c953451932198ce0bbb53e295f8391ddc9090b0cde26e06be98e
diff --git a/sys-apps/xdg-desktop-portal-xapp/metadata.xml b/sys-apps/xdg-desktop-portal-xapp/metadata.xml
new file mode 100644
index 000000000000..47039577a973
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-xapp/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>sparky@bluefang-logic.com</email>
+ <name>Matthew Turnbull</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">linuxmint/xdg-desktop-portal-xapp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/xdg-desktop-portal-xapp/xdg-desktop-portal-xapp-1.0.4.ebuild b/sys-apps/xdg-desktop-portal-xapp/xdg-desktop-portal-xapp-1.0.4.ebuild
new file mode 100644
index 000000000000..9d6c9bec552a
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-xapp/xdg-desktop-portal-xapp-1.0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson systemd
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using Cinnamon/MATE/Xfce"
+HOMEPAGE="https://github.com/linuxmint/xdg-desktop-portal-xapp/"
+SRC_URI="https://github.com/linuxmint/xdg-desktop-portal-xapp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.44:2
+ >=sys-apps/xdg-desktop-portal-1.5
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/xdg-desktop-portal-gtk
+ >=x11-libs/xapp-2.8.1
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ )
+ meson_src_configure
+}