summaryrefslogtreecommitdiff
path: root/sys-apps/xdg-desktop-portal-gtk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /sys-apps/xdg-desktop-portal-gtk
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'sys-apps/xdg-desktop-portal-gtk')
-rw-r--r--sys-apps/xdg-desktop-portal-gtk/Manifest2
-rw-r--r--sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.14.0.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal-gtk/Manifest b/sys-apps/xdg-desktop-portal-gtk/Manifest
index 1933a1af39d2..cf118ede03c8 100644
--- a/sys-apps/xdg-desktop-portal-gtk/Manifest
+++ b/sys-apps/xdg-desktop-portal-gtk/Manifest
@@ -1,3 +1,5 @@
+DIST xdg-desktop-portal-gtk-1.14.0.tar.xz 381316 BLAKE2B 73a1e1d9944c4776ef2ebff33b26559767aad10784e9518690d31575a6216014bd0c518bde9a3b4e92d6a7edbf1aaa3510d669a025b7574c4df978f7c24b83ac SHA512 b0ba54e1ddbdfbd22b8b31bf4ece261dc0beba303e642f10afc72659dd5477438a30688c9d018e3d1ed2adbc053ddf4e3a2d70de8cac03d9519355772862fafc
DIST xdg-desktop-portal-gtk-1.8.0.tar.xz 370196 BLAKE2B d15a054e8fbc74718db7ad2d0f7b53c86b392e729fb4d5b8bdd87b16c0ebbf4feb11b29bc27da12990b351f520faa23bde694721819589513b6cfd1e4ea2f092 SHA512 832b3c4cb9ea738f2ab7641fbd7e14beaa5f6a1ae88f012cd44b12f4bc51588f61868b5982301e3dfd67965d6a69fd8669a9832b6ec7017168d611c87d76689b
+EBUILD xdg-desktop-portal-gtk-1.14.0.ebuild 1338 BLAKE2B d407d7c35c9a8b8c8f9f50a8a9327630adac6eb2626e32ad579f77a8f95d0b61300e6ec23776e60ee2c5841cdc8b8cccfb57533206045ce6ed6dae3e3a83e118 SHA512 93f29ce337740af77d3106e8b9746a8153289f96ea538b7080678e21325f80d82ad2a38212505a620b4656911e68c24fda7f2e97b2be335de3a01a8eb3032e8d
EBUILD xdg-desktop-portal-gtk-1.8.0.ebuild 983 BLAKE2B a08a593be0d458d342b1a4b00abd38f6a20e09812b5219d75fe268c02908e9f2abd26727e220c8da1808341144e17ea000f9fb7136b45ba13418eb76effd24a4 SHA512 666f331b55f8c55475e559576c5321bdd998f413cc6e1ac9b4ba5e6fadbd993cc4f69878af5663ddd41331e98e87606e02899499ff22a1ee75500a3252ddcf33
MISC metadata.xml 254 BLAKE2B de7a97001e5947704f42973c8a0c3a23c2d80afb976254f5fd21e9d372a946e055d4cdc3c0eaed010505f87929b56e8b1e650c945e2a302644adbc9440833be8 SHA512 c81da4f9b80e5691a167f4590906952e25356604ec17689c005be14efb394c0634776bbe84df936edde239480bdf46db41216b00da4a3a45f670e9ca18ab0132
diff --git a/sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.14.0.ebuild b/sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.14.0.ebuild
new file mode 100644
index 000000000000..9e8da15268bc
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.14.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+MY_PV="${PV//_pre*}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using GTK+"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal-gtk"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${MY_PV}/${MY_P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="wayland X"
+
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DEPEND="
+ dev-libs/glib:2
+ media-libs/fontconfig
+ sys-apps/dbus
+ >=sys-apps/xdg-desktop-portal-1.14.0
+ x11-libs/cairo[X?]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3[wayland?,X?]
+"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ # As done in Fedora:
+ # All backends that are disabled are instead provided by
+ # xdg-desktop-portal-gnome to keep this package free of GNOME dependencies.
+ # The appchooser and settings backends are enabled for non-GNOME GTK
+ # applications.
+ local myeconfargs=(
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ --enable-appchooser
+ --enable-settings
+ --disable-background
+ --disable-lockdown
+ --disable-screencast
+ --disable-screenshot
+ --disable-wallpaper
+ )
+
+ econf "${myeconfargs[@]}"
+}