summaryrefslogtreecommitdiff
path: root/sys-apps/xdg-desktop-portal-gtk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /sys-apps/xdg-desktop-portal-gtk
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'sys-apps/xdg-desktop-portal-gtk')
-rw-r--r--sys-apps/xdg-desktop-portal-gtk/Manifest3
-rw-r--r--sys-apps/xdg-desktop-portal-gtk/metadata.xml8
-rw-r--r--sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.7.1_pre.ebuild47
3 files changed, 58 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal-gtk/Manifest b/sys-apps/xdg-desktop-portal-gtk/Manifest
new file mode 100644
index 000000000000..00eacc253567
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gtk/Manifest
@@ -0,0 +1,3 @@
+DIST xdg-desktop-portal-gtk-1.7.1.tar.xz 369932 BLAKE2B 510652a0025fc27d447a0482552a0ae9c8e08f0471166466356043c026c922b1b0779053bcc7902f041f93ccd71e2e71882594eee7f4dda8cea295e419192941 SHA512 2a2326559a4ed7e44ffddc1a6881c25f14822465f5660bc806e7d8a120d66268e2987329f4bc9f7821329eea41ee96b15a39c5f7ac805a1e04d0604a88b31c08
+EBUILD xdg-desktop-portal-gtk-1.7.1_pre.ebuild 954 BLAKE2B 585d0c8aab3bd3da4367ef1a16a6f7fef458ae48197725a08e6984d3920159c0939a4a26aa3d6490e6bd78e44e6baaa073c748d639baac87cea7ecca0fcdfa7e SHA512 e1f4505340f25307ec7e4ac1ff572aba38df46e51580b738b9ed0c76a4758b2d75ab804f77a924d7cf3396d91302d0682997f90b95335943917aa243deda6a73
+MISC metadata.xml 253 BLAKE2B a1efbd3751efaa83ee173f557ec1c8a4497a90b60896cf5a7a07da40b4f94a7a299ca0385477e82b2f5e5dbdf9afa482ccbe21f35ef44214e9c451d764b65529 SHA512 8d59f413993268ca783f7407b676900bb2d964754bf705d4175e2bafbe058a52af74f3928e4bd84d292518f8cf13fab7051486ab7cdc61d02fae6e0188d44442
diff --git a/sys-apps/xdg-desktop-portal-gtk/metadata.xml b/sys-apps/xdg-desktop-portal-gtk/metadata.xml
new file mode 100644
index 000000000000..996e7cacd217
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gtk/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.7.1_pre.ebuild b/sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.7.1_pre.ebuild
new file mode 100644
index 000000000000..ed07582361da
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.7.1_pre.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+MY_PV="${PV//_pre*}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="portal backend implementation that is using GTK+ and various pieces of GNOME"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal-gtk"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${MY_PV}/${MY_P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE="wayland X"
+
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DEPEND="
+ dev-libs/glib:2
+ gnome-base/gnome-desktop:3=
+ media-libs/fontconfig
+ sys-apps/dbus
+ >=sys-apps/xdg-desktop-portal-1.7
+ x11-libs/cairo[X?]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3[wayland?,X?]
+"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local myeconfargs=(
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ )
+
+ econf "${myeconfargs[@]}"
+}