summaryrefslogtreecommitdiff
path: root/sys-apps/xdg-dbus-proxy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sys-apps/xdg-dbus-proxy
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sys-apps/xdg-dbus-proxy')
-rw-r--r--sys-apps/xdg-dbus-proxy/Manifest2
-rw-r--r--sys-apps/xdg-dbus-proxy/xdg-dbus-proxy-0.1.4.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/xdg-dbus-proxy/Manifest b/sys-apps/xdg-dbus-proxy/Manifest
index abfb41b44ad4..c9b005612a1d 100644
--- a/sys-apps/xdg-dbus-proxy/Manifest
+++ b/sys-apps/xdg-dbus-proxy/Manifest
@@ -1,3 +1,5 @@
DIST xdg-dbus-proxy-0.1.3.tar.xz 119896 BLAKE2B c789ad697c1cda84a4cde2c84b90370869bdaeb76736c2891270a58834296e3acbf83b311ba153a0d1e9f3266de0cc1eda63866e2808dcbb4aeac451f90da7f6 SHA512 bb730366efca9d0d199983063dd5cd7b8a8aac8d9efd8e3d6b6090166e5e09a74ef241a07388cfbb2f108e66b3a29114671a6d955324626aebefa1d6c2423632
+DIST xdg-dbus-proxy-0.1.4.tar.xz 122112 BLAKE2B c7d2898b703c51d6b53838996a0ae74e7a4e163b9611e28dfded54ab1a44c0473fa25daa13e94977c918544e0741bf0dd4747dfcae858468bc4abd288613cb8b SHA512 d50fa916d07f23e080ab53cf290b5d6db73cfd8262253a48b9f012ce6c182e201d0a67efaeb7f28a844d3ef146aa48936dfbe4279a59b909a6dc4419d5f15b04
EBUILD xdg-dbus-proxy-0.1.3.ebuild 621 BLAKE2B f972dcbee8a8acfead30601ddc92388f26cc7d4b5a20ed3e3690d1f38cc66daf1eff676279d6dac6a7bff11de95af2f211bab3895d1d49f93a9f3f15b9c9da72 SHA512 95cecbb2dca547bc3b7822ce00fbf9e03e295d1a55c383bc4605db481dfe6332c126c8b548aca8c428f0b9f8744a1ef3600d43967064eb6818010a9e42cf36fe
+EBUILD xdg-dbus-proxy-0.1.4.ebuild 708 BLAKE2B bca9efa9b55c47828cbb291650d5b47e9ff20b8e06412d24c5c36d61d44e331b8fc1ca34e05b40658c622f3531b9c93debe2ff29ba1e946449c5bccf01dcb686 SHA512 b69d192cc74ec0f4ab97c4903705d7f1a805ff0649923f1b707218d7d9479766091f8cfb20e4bdf2c5ccd90273dc19b01fc7d3c93b79c344f0a88f807cf29049
MISC metadata.xml 254 BLAKE2B de7a97001e5947704f42973c8a0c3a23c2d80afb976254f5fd21e9d372a946e055d4cdc3c0eaed010505f87929b56e8b1e650c945e2a302644adbc9440833be8 SHA512 c81da4f9b80e5691a167f4590906952e25356604ec17689c005be14efb394c0634776bbe84df936edde239480bdf46db41216b00da4a3a45f670e9ca18ab0132
diff --git a/sys-apps/xdg-dbus-proxy/xdg-dbus-proxy-0.1.4.ebuild b/sys-apps/xdg-dbus-proxy/xdg-dbus-proxy-0.1.4.ebuild
new file mode 100644
index 000000000000..23744c014949
--- /dev/null
+++ b/sys-apps/xdg-dbus-proxy/xdg-dbus-proxy-0.1.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Filtering proxy for D-Bus connections"
+HOMEPAGE="https://github.com/flatpak/xdg-dbus-proxy"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+"
+DEPEND="${RDEPEND}
+ test? ( sys-apps/dbus )
+"
+BDEPEND="
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman=enabled
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}