summaryrefslogtreecommitdiff
path: root/sys-apps/x86info/x86info-1.31.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sys-apps/x86info/x86info-1.31.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sys-apps/x86info/x86info-1.31.ebuild')
-rw-r--r--sys-apps/x86info/x86info-1.31.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/sys-apps/x86info/x86info-1.31.ebuild b/sys-apps/x86info/x86info-1.31.ebuild
new file mode 100644
index 000000000000..b695f1e7be37
--- /dev/null
+++ b/sys-apps/x86info/x86info-1.31.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit flag-o-matic linux-info python-any-r1 toolchain-funcs
+
+# Upstream stopped versioned releases entirely
+COMMIT="8ea5ed19fae1d209eba9257171a10f7afd474618"
+
+DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
+HOMEPAGE="http://www.codemonkey.org.uk/projects/x86info/"
+SRC_URI="https://github.com/kernelslacker/x86info/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="sys-apps/pciutils:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.30-pic.patch #270388
+ "${FILESDIR}"/${PN}-1.30-makefile.patch
+)
+
+pkg_setup() {
+ CONFIG_CHECK="~MTRR ~X86_CPUID"
+ linux-info_pkg_setup
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ # These flags taken from the 1.29 ebuild
+ append-flags -Wall -Wshadow -Wextra -Wmissing-declarations \
+ -Wdeclaration-after-statement -Wredundant-decls
+ append-ldflags -Wl,-z,relro,-z,now
+
+ tc-export CC PKG_CONFIG
+}
+
+src_compile() {
+ emake x86info
+}
+
+src_install() {
+ dobin x86info
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/x86info-modules.conf-rc x86info.conf
+
+ einstalldocs
+ doman x86info.1
+}
+
+pkg_preinst() {
+ if [[ -a "${EROOT}"/etc/modules.d/x86info ]] && [[ ! -a "${EROOT}"/etc/modprobe.d/x86info ]]; then
+ elog "Moving x86info from /etc/modules.d/ to /etc/modprobe.d/"
+ mv "${EROOT}"/etc/{modules,modprobe}.d/x86info
+ fi
+ if [[ -a "${EROOT}"/etc/modprobe.d/x86info ]] && [[ ! -a "${EROOT}"/etc/modprobe.d/x86info.conf ]]; then
+ elog "Adding .conf suffix to x86info in /etc/modprobe.d/"
+ mv "${EROOT}"/etc/modprobe.d/x86info{,.conf}
+ fi
+}