summaryrefslogtreecommitdiff
path: root/sys-apps/x86info/x86info-1.30_p20190617.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /sys-apps/x86info/x86info-1.30_p20190617.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'sys-apps/x86info/x86info-1.30_p20190617.ebuild')
-rw-r--r--sys-apps/x86info/x86info-1.30_p20190617.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/sys-apps/x86info/x86info-1.30_p20190617.ebuild b/sys-apps/x86info/x86info-1.30_p20190617.ebuild
index f56ec2fe5718..af2a213c7833 100644
--- a/sys-apps/x86info/x86info-1.30_p20190617.ebuild
+++ b/sys-apps/x86info/x86info-1.30_p20190617.ebuild
@@ -1,17 +1,19 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..8} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit flag-o-matic linux-info python-any-r1 toolchain-funcs
-DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
-HOMEPAGE="http://www.codemonkey.org.uk/projects/x86info/"
# Upstream stopped versioned releases entirely
COMMIT="8ea5ed19fae1d209eba9257171a10f7afd474618"
+
+DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
+HOMEPAGE="http://www.codemonkey.org.uk/projects/x86info/"
SRC_URI="https://github.com/kernelslacker/x86info/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
LICENSE="GPL-2"
SLOT="0"
@@ -23,15 +25,13 @@ BDEPEND="
${PYTHON_DEPS}
virtual/pkgconfig"
-CONFIG_CHECK="~MTRR ~X86_CPUID"
-S="${WORKDIR}/${PN}-${COMMIT}"
-
PATCHES=(
"${FILESDIR}"/${PN}-1.30-pic.patch #270388
"${FILESDIR}"/${PN}-1.30-makefile.patch
)
pkg_setup() {
+ CONFIG_CHECK="~MTRR ~X86_CPUID"
linux-info_pkg_setup
python-any-r1_pkg_setup
}