summaryrefslogtreecommitdiff
path: root/sys-apps/x86info/x86info-1.30_p20190617.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /sys-apps/x86info/x86info-1.30_p20190617.ebuild
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'sys-apps/x86info/x86info-1.30_p20190617.ebuild')
-rw-r--r--sys-apps/x86info/x86info-1.30_p20190617.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/sys-apps/x86info/x86info-1.30_p20190617.ebuild b/sys-apps/x86info/x86info-1.30_p20190617.ebuild
new file mode 100644
index 000000000000..d8a3b48dfadf
--- /dev/null
+++ b/sys-apps/x86info/x86info-1.30_p20190617.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4..8} )
+
+inherit flag-o-matic linux-info python-any-r1 toolchain-funcs
+
+DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
+HOMEPAGE="http://www.codemonkey.org.uk/projects/x86info/"
+# Upstream stopped versioned releases entirely
+COMMIT="8ea5ed19fae1d209eba9257171a10f7afd474618"
+SRC_URI="https://github.com/kernelslacker/x86info/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/pciutils:="
+DEPEND="
+ ${PYTHON_DEPS}
+ ${RDEPEND}"
+
+CONFIG_CHECK="~MTRR ~X86_CPUID"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+PATCHES=(
+ #"${FILESDIR}"/1.21-pic.patch
+ "${FILESDIR}"/${PN}-1.24-pic.patch #270388
+ #"${FILESDIR}"/${PN}-1.29-parallel-make-cleanup.patch
+ #"${FILESDIR}"/${PN}-1.30-fix-build-system.patch
+)
+
+pkg_setup() {
+ linux-info_pkg_setup
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ # These flags taken from the 1.29 ebuild
+ append-flags -Wall -Wshadow -Wextra -Wmissing-declarations \
+ -Wdeclaration-after-statement -Wredundant-decls
+ append-ldflags -Wl,-z,relro,-z,now
+
+ tc-export CC
+}
+
+src_compile() {
+ emake x86info
+}
+
+src_install() {
+ dobin x86info
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/x86info-modules.conf-rc x86info.conf
+
+ einstalldocs
+ doman x86info.1
+}
+
+pkg_preinst() {
+ if [[ -a "${EROOT}"/etc/modules.d/x86info ]] && [[ ! -a "${EROOT}"/etc/modprobe.d/x86info ]]; then
+ elog "Moving x86info from /etc/modules.d/ to /etc/modprobe.d/"
+ mv "${EROOT}"/etc/{modules,modprobe}.d/x86info
+ fi
+ if [[ -a "${EROOT}"/etc/modprobe.d/x86info ]] && [[ ! -a "${EROOT}"/etc/modprobe.d/x86info.conf ]]; then
+ elog "Adding .conf suffix to x86info in /etc/modprobe.d/"
+ mv "${EROOT}"/etc/modprobe.d/x86info{,.conf}
+ fi
+}