summaryrefslogtreecommitdiff
path: root/sys-apps/watchdog/watchdog-5.16-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
commit81b8f20732954c4508baf2f77472b5435e3f851f (patch)
tree4180177cb7ba85eab50159ce96218c2419fb24a6 /sys-apps/watchdog/watchdog-5.16-r1.ebuild
parent946859e0e36904cffb3e0ccbccb6b7b1347c1cc8 (diff)
gentoo auto-resync : 14:09:2022 - 11:10:10
Diffstat (limited to 'sys-apps/watchdog/watchdog-5.16-r1.ebuild')
-rw-r--r--sys-apps/watchdog/watchdog-5.16-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/watchdog/watchdog-5.16-r1.ebuild b/sys-apps/watchdog/watchdog-5.16-r1.ebuild
new file mode 100644
index 000000000000..896261cadca2
--- /dev/null
+++ b/sys-apps/watchdog/watchdog-5.16-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic systemd toolchain-funcs
+
+DESCRIPTION="A software watchdog and /dev/watchdog daemon"
+HOMEPAGE="https://sourceforge.net/projects/watchdog/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="nfs"
+
+RDEPEND="nfs? ( net-libs/libtirpc )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.16-implicit-func-decls-musl.patch
+)
+
+src_configure() {
+ if use nfs; then
+ append-cppflags "$($(tc-getPKG_CONFIG) libtirpc --cflags)"
+ append-libs "$($(tc-getPKG_CONFIG) libtirpc --libs)"
+ fi
+ econf $(use_enable nfs)
+}
+
+src_install() {
+ default
+ dodoc -r examples
+
+ newconfd "${FILESDIR}"/${PN}-conf.d ${PN}
+ newinitd "${FILESDIR}"/${PN}-init.d-r1 ${PN}
+ systemd_dounit "${FILESDIR}"/watchdog.service
+}