summaryrefslogtreecommitdiff
path: root/sys-apps/util-linux/util-linux-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /sys-apps/util-linux/util-linux-9999.ebuild
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'sys-apps/util-linux/util-linux-9999.ebuild')
-rw-r--r--sys-apps/util-linux/util-linux-9999.ebuild29
1 files changed, 2 insertions, 27 deletions
diff --git a/sys-apps/util-linux/util-linux-9999.ebuild b/sys-apps/util-linux/util-linux-9999.ebuild
index 66a36a6cd0cb..141bdf409cb5 100644
--- a/sys-apps/util-linux/util-linux-9999.ebuild
+++ b/sys-apps/util-linux/util-linux-9999.ebuild
@@ -17,8 +17,7 @@ if [[ ${PV} == 9999 ]] ; then
else
[[ "${PV}" = *_rc* ]] || \
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
- SRC_URI="https://www.kernel.org/pub/linux/utils/util-linux/v${PV:0:4}/${MY_P}.tar.xz
- https://dev.gentoo.org/~polynomial-c/${MY_P}-manpages.tar.xz"
+ SRC_URI="https://www.kernel.org/pub/linux/utils/util-linux/v${PV:0:4}/${MY_P}.tar.xz"
fi
DESCRIPTION="Various useful Linux utilities"
@@ -38,7 +37,7 @@ RDEPEND="
cryptsetup? ( sys-fs/cryptsetup )
hardlink? ( dev-libs/libpcre2:= )
ncurses? (
- >=sys-libs/ncurses-5.2-r2:0=[unicode?]
+ sys-libs/ncurses:=[unicode(+)?]
magic? ( sys-apps/file:0= )
)
nls? ( virtual/libintl[${MULTILIB_USEDEP}] )
@@ -87,18 +86,6 @@ RESTRICT="!test? ( test )"
S="${WORKDIR}/${MY_P}"
-PATCHES=(
-)
-
-rm_man() {
- [[ -n $1 ]] || die
- local el
- for el in $1 ; do
- find "${WORKDIR}/man" -type f -name "${el}.?" -delete \
- || die
- done
-}
-
src_prepare() {
default
@@ -117,14 +104,6 @@ src_prepare() {
if [[ ${PV} == 9999 ]] ; then
po/update-potfiles
eautoreconf
- else
- # Conditionally remove some man-pages
- use hardlink || rm_man "hardlink"
- use kill || rm_man "kill"
- use logger || rm_man "logger"
- use ncurses || rm_man "pg"
- use su || rm_man "su"
- use tty-helpers || rm_man "mesg wall write"
fi
elibtoolize
@@ -320,10 +299,6 @@ multilib_src_install_all() {
# e2fsprogs-libs didnt install .la files, and .pc work fine
find "${ED}" -name "*.la" -delete || die
- if [[ ${PV} != 9999 ]] ; then
- doman "${WORKDIR}"/man/man*/*
- fi
-
if ! use userland_GNU ; then
# manpage collisions
# TODO: figure out a good way to keep them