summaryrefslogtreecommitdiff
path: root/sys-apps/usbredir
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sys-apps/usbredir
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sys-apps/usbredir')
-rw-r--r--sys-apps/usbredir/Manifest5
-rw-r--r--sys-apps/usbredir/usbredir-0.12.0.ebuild26
-rw-r--r--sys-apps/usbredir/usbredir-0.9.0.ebuild45
-rw-r--r--sys-apps/usbredir/usbredir-9999.ebuild40
4 files changed, 28 insertions, 88 deletions
diff --git a/sys-apps/usbredir/Manifest b/sys-apps/usbredir/Manifest
index af7ca8975648..5cc5f3e2b6be 100644
--- a/sys-apps/usbredir/Manifest
+++ b/sys-apps/usbredir/Manifest
@@ -1,4 +1,3 @@
-DIST usbredir-0.9.0.tar.bz2 72498 BLAKE2B 857b83795ac082d412b2872a4ca06b1602d556698f3217379698e8b1f54edd09b012600069045ff0f7583703253853998b900f34d861a538047783510b3fb2e9 SHA512 5df62fb6e49161be974776c86f026a58322ccf1c1964447958707408492c02175100ead9dc4a7e77bb7a9112a33b91461d64761425e7aee7d44c71ff6913588a
-EBUILD usbredir-0.9.0.ebuild 998 BLAKE2B ceaaf641528cab53b99b3e103d5babda64c0062d36360feca7e23b91dcf572aa7d1fac663c5ff82ce311eabcda9c0ead3c8ad217d2a490c294f8b92363b3e2c4 SHA512 d1d17f41c3e4fb75569942bdda439066adc5c1a455db8a5e8015b26404bb7fa382c3573f2221b3f1eacf83c4decb5613bba32b60c837276ccb221660df8dc3a7
-EBUILD usbredir-9999.ebuild 850 BLAKE2B b01f925aea22d8f2e288a5e4fd8a093409f7370d2b6399add5df799de1af24694dde48dc971579c108917860773bf715e419a806e7e3e5db7684d694182e4f06 SHA512 47a51143cd9587b0aa280792375fd8329b547d434245ee4cde3187f06750521c1d1e9cd2d2e3e56c3c1229fc9ee9a4ef15f45720b55f668332c04f3691eab25d
+DIST usbredir-0.12.0.tar.bz2 70102 BLAKE2B c6891e14a7951520066fdc7e8095c905599aa3186c72ff378d25e46335843df6daa746937619f8bcb9e60447f19ce671317e9b21e6ce127d2b977d82cb39a337 SHA512 586465d3a18c3bbf621e6b7d1dc24edb333e00491dbd0d0dc781a9e0640f3483a8abf73c55d4ad76b3be0a27a4b1801d08dffb77db3f9aab2234039a60a605ca
+EBUILD usbredir-0.12.0.ebuild 702 BLAKE2B a0f54f19b14c44174e742c1e5193a629fe54829482c62b08253993ce3987977ae4de06b03607ba658900476920296a4b01f24a31ea6062b8cf5908cad6b5a65e SHA512 88b3087854b7f3d2d75e7e0b7930398f8eecef24fabbec7fd6d5041a1b1741d3610820d87a13208d07abd0da71a0b1ef12ecda91463dd73a827955c99af7adec
MISC metadata.xml 382 BLAKE2B 8bd3bd664b50e3dcf570f21612316c2df894729fa763cfca93327095dcde26b5e820d59803a6c35035f3c09ebe17e1ff58314e3279ff92fefd5c0dc6692faaf8 SHA512 4d625ff4d3055998db9643cf4fac7c8c64dab96e60c68916629071c6f1792a89a20e6b2a0a86ba254eeed200f33ff4996630a2249fe22853f5aadbb678b866b6
diff --git a/sys-apps/usbredir/usbredir-0.12.0.ebuild b/sys-apps/usbredir/usbredir-0.12.0.ebuild
new file mode 100644
index 000000000000..02efb451b768
--- /dev/null
+++ b/sys-apps/usbredir/usbredir-0.12.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="TCP daemon and set of libraries for usbredir protocol (redirecting USB traffic)"
+HOMEPAGE="https://www.spice-space.org/usbredir.html https://gitlab.freedesktop.org/spice/usbredir"
+SRC_URI="https://gitlab.freedesktop.org/spice/usbredir/-/archive/${P}/${PN}-${P}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 ~riscv ~sparc x86"
+
+DEPEND="dev-libs/glib:2
+ virtual/libusb:1"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/usbredir-${P}"
+
+src_install() {
+ meson_src_install
+ dodoc -r docs/.
+}
diff --git a/sys-apps/usbredir/usbredir-0.9.0.ebuild b/sys-apps/usbredir/usbredir-0.9.0.ebuild
deleted file mode 100644
index b72e69206ca5..000000000000
--- a/sys-apps/usbredir/usbredir-0.9.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic
-
-MY_PV=${PV/_p*/}
-
-DESCRIPTION="TCP daemon and set of libraries for usbredir protocol (redirecting USB traffic)"
-HOMEPAGE="https://www.spice-space.org/usbredir.html"
-SRC_URI="https://gitlab.freedesktop.org/spice/${PN}/-/archive/${P}/${PN}-${P}.tar.bz2 -> ${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 ~riscv ~sparc x86"
-IUSE="static-libs"
-
-RDEPEND="virtual/libusb:1"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-S="${WORKDIR}/${PN}-${PN}-${MY_PV}"
-
-DOCS="README* TODO *.txt"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- # https://bugs.freedesktop.org/show_bug.cgi?id=54643
- append-cflags -Wno-error
-
- econf $(use_enable static-libs static)
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-
- # noinst_PROGRAMS
- dobin usbredirtestclient/.libs/usbredirtestclient
-}
diff --git a/sys-apps/usbredir/usbredir-9999.ebuild b/sys-apps/usbredir/usbredir-9999.ebuild
deleted file mode 100644
index c673028d9e2d..000000000000
--- a/sys-apps/usbredir/usbredir-9999.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic git-r3
-
-DESCRIPTION="TCP daemon and set of libraries for usbredir protocol (redirecting USB traffic)"
-HOMEPAGE="https://www.spice-space.org/usbredir.html"
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/spice/usbredir.git"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-IUSE="static-libs"
-
-RDEPEND="virtual/libusb:1"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-DOCS="README* TODO *.txt"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- # https://bugs.freedesktop.org/show_bug.cgi?id=54643
- append-cflags -Wno-error
-
- econf $(use_enable static-libs static)
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-
- # noinst_PROGRAMS
- dobin usbredirtestclient/.libs/usbredirtestclient
-}