summaryrefslogtreecommitdiff
path: root/sys-apps/unscd/unscd-0.52-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/unscd/unscd-0.52-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/unscd/unscd-0.52-r2.ebuild')
-rw-r--r--sys-apps/unscd/unscd-0.52-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/unscd/unscd-0.52-r2.ebuild b/sys-apps/unscd/unscd-0.52-r2.ebuild
new file mode 100644
index 000000000000..f61fb7591b5f
--- /dev/null
+++ b/sys-apps/unscd/unscd-0.52-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="simple & stable nscd replacement"
+HOMEPAGE="https://busybox.net/~vda/unscd/README"
+SRC_URI="https://busybox.net/~vda/unscd/nscd-${PV}.c"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="sys-libs/glibc[nscd(+)]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp "${DISTDIR}"/nscd-${PV}.c ${PN}.c || die
+}
+
+src_compile() {
+ tc-export CC
+ emake unscd
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/unscd.initd-r1 unscd
+ systemd_newtmpfilesd "${FILESDIR}"/unscd-tmpfiles.conf unscd.conf
+ systemd_dounit "${FILESDIR}"/unscd.service
+ dosbin unscd
+}