summaryrefslogtreecommitdiff
path: root/sys-apps/uam/uam-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/uam/uam-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/uam/uam-9999.ebuild')
-rw-r--r--sys-apps/uam/uam-9999.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-apps/uam/uam-9999.ebuild b/sys-apps/uam/uam-9999.ebuild
new file mode 100644
index 000000000000..512c8e51355b
--- /dev/null
+++ b/sys-apps/uam/uam-9999.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}.git"
+
+inherit git-r3
+#endif
+
+inherit autotools-utils udev user
+
+DESCRIPTION="Simple udev-based automounter for removable USB media"
+HOMEPAGE="https://bitbucket.org/mgorny/uam/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/udev"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+pkg_postinst() {
+ # The plugdev group is created by pam, pmount and many other ebuilds
+ # in gx86. As we don't want to depend on any of them (even pmount is
+ # optional), we create it ourself too.
+ enewgroup plugdev
+
+ elog "To be able to access uam-mounted filesystems, you have to be"
+ elog "a member of the 'plugdev' group."
+ elog
+ elog "Note that uam doesn't provide any way to allow unprivileged user"
+ elog "to manually umount devices. The upstream suggested solution"
+ elog "is to use [sys-apps/pmount]. If you don't feel like installing"
+ elog "additional tools, remember to sync before removing your USB stick."
+ elog
+ elog "If you'd like uam to mount ejectable media like CDs/DVDs, you need"
+ elog "to enable in-kernel media polling, e.g.:"
+ elog " echo 5000 > /sys/module/block/parameters/events_dfl_poll_msecs"
+ elog "where 5000 would mean a poll will occur every 5 seconds."
+ elog
+ elog "If you'd like to receive libnotify-based notifications, you need"
+ elog "to install the [x11-misc/sw-notify-send] tool."
+
+ udev_reload
+}