summaryrefslogtreecommitdiff
path: root/sys-apps/tuned
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /sys-apps/tuned
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'sys-apps/tuned')
-rw-r--r--sys-apps/tuned/Manifest2
-rw-r--r--sys-apps/tuned/tuned-2.15.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/sys-apps/tuned/Manifest b/sys-apps/tuned/Manifest
index de752c4b47fd..dcd31583e141 100644
--- a/sys-apps/tuned/Manifest
+++ b/sys-apps/tuned/Manifest
@@ -1,4 +1,6 @@
AUX tuned.initd 421 BLAKE2B b60d6fbf4110ba7e0b5c36159dc9624460ccb8774f101a50b89e633bb177a8ef9d7c36fa425a27d8c5ec6c7b9b19965212cb5ee4b60e02abb3c3990beb26840a SHA512 0123e60def031887040df8690222cc553d93b3c5eb7413e19f722ef04ccf2aeb6468709f66866d432d4d0b0c0ed6875929f1292fde8ad18c4a6b589d1b40fab4
DIST tuned-2.13.0.tar.gz 193816 BLAKE2B 1e51a9da855f54db9ac8ed6e764c091d513c1101771422a62c7c501dc3c8741430eb3503803b408709868d16d4791fbedb9dbc088b36fb693f065a1b6054fa15 SHA512 d81b0a80f911fe808ca324319da3e42c3c15196c0c37343d33b45c2b34f33e205e2913d77ffda8598379a91ef72ab73d88d7b83a4684b6a067e3f36d98a85927
+DIST tuned-2.15.0.tar.gz 207775 BLAKE2B 307b0598d9e99831526f2b26d5544df3832db7e17f28935c6f8d9293ec0d03729fb66906dca4739d48690e488f05383d448e7e714f6ae4824489564c295784c9 SHA512 67acdf10ecccd7910c4dcfd737610b4cb7651c7bf937bc0ed9c51869262d9f3a46f262d0b7636bc7a86a8abf579542a46f551e4f6c7561a061d8d58459be4589
EBUILD tuned-2.13.0-r1.ebuild 1328 BLAKE2B 43c9abb31c7253a9fa6c1e6734ade3cbff8e8a4f08756b8eb7e368719c86748637e1073ad5c4a3cbfce719e0ce36fd2a4b8f11c0ed4e6bcbeb19477408854da3 SHA512 fc8f6a57e78f8723a15a1d167fecf59242ec20d2cb70077fda0511907bc765c91d837f0a18d3d6208c24929ff0073ed484fb3c44d09ba245126013120ecf9592
+EBUILD tuned-2.15.0.ebuild 1381 BLAKE2B f1871b0149edc249e8730a53df67536a5ab3e7cc929cea10a222658e1fc6421e872ac1102301403518f3043312e590bb61102d9f6c7a80b88c637c91d9169815 SHA512 6d592fc209e7efc1bcf757fdee1b93c5d38a313f8d0772887dfb354cc19a74eac2b03c6f3fd19a01277fad05016361bf17fafc737d3d850b5b4386905b95c14c
MISC metadata.xml 388 BLAKE2B fba6c8b1e8afb1e474dca668ef0f1d9adc633f9c382ce7772235a8a38c1530dcb9329730d9b1c912a7b44a48ef43572f046751f51c3efcce3f4a6c7c2cdc012e SHA512 6f25c8d915777f95c6f134ba77006290b2d4c02ba70c7254ce7225062da042d8c9f7eb312f842a2988866804ff5069f5f3871e54f97d23bfac936da994d456ea
diff --git a/sys-apps/tuned/tuned-2.15.0.ebuild b/sys-apps/tuned/tuned-2.15.0.ebuild
new file mode 100644
index 000000000000..58b76e9dde2c
--- /dev/null
+++ b/sys-apps/tuned/tuned-2.15.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit python-single-r1 xdg-utils
+
+DESCRIPTION="Daemon for monitoring and adaptive tuning of system devices"
+HOMEPAGE="https://github.com/redhat-performance/tuned"
+SRC_URI="https://github.com/redhat-performance/tuned/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/configobj[${PYTHON_MULTI_USEDEP}]
+ dev-python/decorator[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyudev[${PYTHON_MULTI_USEDEP}]
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/python-linux-procfs[${PYTHON_MULTI_USEDEP}]
+ ')"
+
+RDEPEND="
+ ${DEPEND}
+ sys-apps/dbus
+ sys-apps/ethtool
+ sys-power/powertop
+ dev-util/systemtap"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "/^PYTHON/s:/usr/bin/python3:${EPYTHON}:" \
+ -e "/^export DOCDIR/s/$/&\-\$(VERSION)/g" \
+ -e "/\$(DESTDIR)\/run\/tuned/d" \
+ -e "/\$(DESTDIR)\/var\/lib\/tuned/d" \
+ -e "/\$(DESTDIR)\/var\/log\/tuned/d" \
+ Makefile || die
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ python_fix_shebang "${D}"
+ python_optimize
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}