summaryrefslogtreecommitdiff
path: root/sys-apps/texinfo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-20 07:59:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-20 07:59:50 +0100
commit2eda3a3b8ebdb3fc8552feb6f49e466d3bc8e88c (patch)
tree69a469da2fa8c3f4920325ac5595300929f5d884 /sys-apps/texinfo
parent9ed0c42eb618229fa6f45e10155ee535e1f605a2 (diff)
gentoo auto-resync : 20:10:2022 - 07:59:49
Diffstat (limited to 'sys-apps/texinfo')
-rw-r--r--sys-apps/texinfo/Manifest2
-rw-r--r--sys-apps/texinfo/texinfo-6.8.90.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/sys-apps/texinfo/Manifest b/sys-apps/texinfo/Manifest
index 824a55b20a51..7be3e143e4de 100644
--- a/sys-apps/texinfo/Manifest
+++ b/sys-apps/texinfo/Manifest
@@ -1,4 +1,6 @@
AUX texinfo-6.8-undo-gnulib-nonnul.patch 7627 BLAKE2B d8edefca829682e0bbebfecf1c97fd25874ecf0ec65228643c1a5d54558a22970ec2e6d532d37269fdb8a7359eb02c990b2c221591c8ececa3f17c6642c47516 SHA512 c6a482433af9a44e597ace4e92b6d5faf1c7aa6deaab7e474f4158769c31e4cf203f21d4697e071d29104b6b78ae06f353becc5da6aa1276ae9a3e39506a2af9
+DIST texinfo-6.8.90.tar.xz 6324912 BLAKE2B 106dfa2c415cfd40c54befa3b431f5b07eb5561af5f46083d00cac58e74f24c72d955f7796a393687a94703348cb66012d10e9264d23f5995d8dad070eaa55ff SHA512 afcdba96aecbc480ff8a9955d6e86f7c5e95ee8c09a88c483246ef8d90d42665b8823f2a34aad08aa68a498d8ae97bca5cae07e0c4cbe6f2bd5f72ed039c8da6
DIST texinfo-6.8.tar.xz 4961528 BLAKE2B 0256dac5ba9c7f171c970644907b763f7a88fd9995111244df0458591aed1a0fe94c76045dde69f9138d65d6f780aae6869bbbc013f58e04ae7c62456b222bbb SHA512 0ff9290b14e4d83e32b889cfa24e6d065f98b2a764daf6b92c6c895fddbb35258398da6257c113220d5a4d886f7b54b09c4b117ca5eacfee6797f9bffde0f909
+EBUILD texinfo-6.8.90.ebuild 1764 BLAKE2B e6849d98ece1daf1ca21c84f0f14c06cb86b8bd77ce4f114cb63f43886c2c9c39a04ecf8dd350c615ed412618bda09a49e7b3a20630b246fac917be4a5332264 SHA512 04e757a415afb014425591634d634c109cc4c1dd5fc3b7ed61795d426c4a521df84e103e4d1e37234b49326d6d10d00e31dd476b60eba60c71ab4ba904eae72a
EBUILD texinfo-6.8.ebuild 1716 BLAKE2B 4194a080e1dfb4f405330b000838f461a4bd19a253249b41034595449e8ab8f75e075383a5e970506db9d8970f29e30f84611f81a6c032edcc930786898f6533 SHA512 55afd3cf0f842dc8894162940abe2ccd384b0491fcd4fe877255c509031002cd0e8c83f5a4348dbc2432f124d80e224a3e7f127f475e40af5eeb3c0febe1601c
MISC metadata.xml 540 BLAKE2B 64b068c14cc3ce828768e85d21c46e25d8930f66287329bd6ec41893bb26b352a0384155688768aa472cf7c58113e02b79e88d99c98233c3f80b393a0d518443 SHA512 32c337ea240d5ec20130fbb17a9622e3736d8c4b577b6bdebebbe3344675cf9faf3140471ff9fe4c5862b75858017b5e9fd8fc34a1c1f53fe8babc106aa83af3
diff --git a/sys-apps/texinfo/texinfo-6.8.90.ebuild b/sys-apps/texinfo/texinfo-6.8.90.ebuild
new file mode 100644
index 000000000000..9013b3c925b7
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-6.8.90.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Note: if your package uses the texi2dvi utility, it must depend on the
+# virtual/texi2dvi package to pull in all the right deps. The tool is not
+# usable out-of-the-box because it requires the large tex packages.
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="The GNU info program and utilities"
+HOMEPAGE="https://www.gnu.org/software/texinfo/"
+
+if [[ $(ver_cut 3) -ge 90 ]] ; then
+ SRC_URI="https://alpha.gnu.org/gnu/${PN}/${P}.tar.xz"
+else
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="nls +standalone static"
+
+RDEPEND="
+ !=app-text/tetex-2*
+ >=sys-libs/ncurses-5.2-r2:=
+ virtual/perl-Data-Dumper
+ virtual/perl-Encode
+ standalone? ( >=dev-lang/perl-5.8.1 )
+ !standalone? ( >=dev-lang/perl-5.8.1:= )
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( >=sys-devel/gettext-0.19.6 )"
+
+src_prepare() {
+ default
+
+ if use prefix ; then
+ sed -i -e '1c\#!/usr/bin/env sh' util/texi2dvi util/texi2pdf || die
+ touch doc/{texi2dvi,texi2pdf,pdftexi2dvi}.1
+ fi
+}
+
+src_configure() {
+ # Respect compiler and CPPFLAGS/CFLAGS/LDFLAGS for Perl extensions
+ # bug #622576
+ local -x PERL_EXT_CC="$(tc-getCC)" PERL_EXT_CPPFLAGS="${CPPFLAGS}"
+ local -x PERL_EXT_CFLAGS="${CFLAGS}" PERL_EXT_LDFLAGS="${LDFLAGS}"
+
+ use static && append-ldflags -static
+
+ local myeconfargs=(
+ --cache-file="${S}"/config.cache
+ $(use_enable nls)
+ $(use_enable !standalone perl-xs)
+ )
+
+ econf "${myeconfargs[@]}"
+}