summaryrefslogtreecommitdiff
path: root/sys-apps/tas
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /sys-apps/tas
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'sys-apps/tas')
-rw-r--r--sys-apps/tas/Manifest6
-rw-r--r--sys-apps/tas/files/tas.ini8
-rw-r--r--sys-apps/tas/files/tas.initd17
-rw-r--r--sys-apps/tas/files/tas.service11
-rw-r--r--sys-apps/tas/metadata.xml25
-rw-r--r--sys-apps/tas/tas-1.5.2.180622.ebuild73
6 files changed, 140 insertions, 0 deletions
diff --git a/sys-apps/tas/Manifest b/sys-apps/tas/Manifest
new file mode 100644
index 000000000000..e689351fcde8
--- /dev/null
+++ b/sys-apps/tas/Manifest
@@ -0,0 +1,6 @@
+AUX tas.ini 81 BLAKE2B 2dd7bc87d72d00d7dd73e496d253810dfe110aa1d754f1fe923f4bf0bafa79c516bf24eaa684822155afd88d9067a6106ee49f7bc8847c75a2a436cf72e893da SHA512 d1e555341bf1aa5e0f4097c948e32cf274d788821eb9bbbc62f15107dbf5893cc14f41ab47f2a59fb6cb5df4b3e431b403f643743eaf7fd3c121d4ee458a8d99
+AUX tas.initd 422 BLAKE2B af394bb87952d7e5ddb20e3b688372f7e526ebde59a3862112a8c723252575683e8218297b801b0ef027b3953e8e78898407f6d85b7bec4f166fad4469d114ed SHA512 0cced493bd7a451bb8a76be1b24171fbc72c0571fb6337e52fe0140184a0990baac9a95e512738366433c3516b859f1958546a8e0ca8f718f7fc48b32f95c792
+AUX tas.service 162 BLAKE2B f9f8d8f9e8dbe1b6aa6e7c531cb69b3e6f39e563cc64f2630a0db2b48cc0425806b166f39d7b2dc356c55b4771da7023ab5c0f10dd2d2857beaff7699fa1a0a7 SHA512 53a6ad9f0d42b26f2a2e9462a5f14a31e4bbde4d8badf7beb9e96e2a916d81ccda96be9bad80fbcc1a8f9e4a72ac5cfb1e13112785de8fe978823d97de145efd
+DIST TAS_1.5.2_build.180622.zip 12434740 BLAKE2B 9017aee7512b6d467d2922dc9db3f3cc58046beb4f48838748ac806da1c0c84f99984e2b29867a36db4bcb58a90f3e23c29dbfd8d73e1049cac4bf82ac88d021 SHA512 166483fe514f09c2fbfd27a05072f0bfa0d2cc8f92428451e055ddd9fbc24dfa3e912de224775d16dbb8880391c79ddc2ee9ff55c1e31e0fcf2daa3b05eb7d60
+EBUILD tas-1.5.2.180622.ebuild 1592 BLAKE2B bb9283f667558351830f427b499685769c8d2c14ffe150189e75c35990d94fa11a355b5df24dddb82683aaea6aeede6a13827ac5ce1882434f1c051a2f0aa1fb SHA512 9f83615cad5fe5c83441609020cdd715ecee5a5635b303457256cf8082a3b9887c5ba50189add216d2e9ae6e50080605a208f34bb2639b9aa0a0814e69432015
+MISC metadata.xml 990 BLAKE2B 249221c6f6a6f24fd3ff7834b598a7fe358c5131c317716be168bbcd5818802fc89d55289163b7bf068e2779654d5b8598b5b381e708d7f416e18080a9233634 SHA512 bdd7210ceda97b24e38eb2734118e06dc5c49ba1d11f4af14e05511341570a8cc58eeb53b0af8b99187473499a99e25ac10ca6e0abf9c1e959fac863e90760fb
diff --git a/sys-apps/tas/files/tas.ini b/sys-apps/tas/files/tas.ini
new file mode 100644
index 000000000000..06f125000bbd
--- /dev/null
+++ b/sys-apps/tas/files/tas.ini
@@ -0,0 +1,8 @@
+Config :
+{
+ updateFreq = 10;
+};
+Path :
+{
+ installedPath = "/etc/supermicro";
+};
diff --git a/sys-apps/tas/files/tas.initd b/sys-apps/tas/files/tas.initd
new file mode 100644
index 000000000000..21b9bd14b0d5
--- /dev/null
+++ b/sys-apps/tas/files/tas.initd
@@ -0,0 +1,17 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+name="Supermicro Thin-Agent Service"
+pidfile="/run/${RC_SVCNAME}.pid"
+
+command="/usr/bin/IPMITAS"
+command_args="-agent start-service"
+command_args_stop="-agent stop-service"
+start_stop_daemon_args="--env LC_ALL=C"
+
+stop() {
+ ebegin "Stopping ${name}"
+ ${command} ${command_args_stop}
+ eend $?
+}
diff --git a/sys-apps/tas/files/tas.service b/sys-apps/tas/files/tas.service
new file mode 100644
index 000000000000..7bf6db6265ee
--- /dev/null
+++ b/sys-apps/tas/files/tas.service
@@ -0,0 +1,11 @@
+[Unit]
+After=network-online.target
+Description=TAS
+
+[Service]
+Environment="LC_ALL=C"
+ExecStart=/usr/bin/IPMITAS
+Type=simple
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sys-apps/tas/metadata.xml b/sys-apps/tas/metadata.xml
new file mode 100644
index 000000000000..51cf888b9566
--- /dev/null
+++ b/sys-apps/tas/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ TAS provides server usage information at the OS level,
+ that users could monitor on a system through the BMC/IPMI.
+ For HW Platforms, where there is not RAID controller in configuration,
+ it is recommended to install TAS.
+ Provides Asset and Health Information:
+ Hardware Information:
+ CPU, Memory, NIC, and HDD Health
+ Usage Monitoring: CPU workload, Memory Size, NIC State, and Disk Partition
+ Supports RAID and HDD SMART Failure Information:
+ Broadcom 3108 RAID Controller and Intel PCH/RSTe RAID Chipset
+ Generates State Event Log: Disk Failure and NIC State Change
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-apps/tas/tas-1.5.2.180622.ebuild b/sys-apps/tas/tas-1.5.2.180622.ebuild
new file mode 100644
index 000000000000..182dd6d61afb
--- /dev/null
+++ b/sys-apps/tas/tas-1.5.2.180622.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eapi7-ver linux-info systemd
+
+MY_DATE="$(ver_cut 4)"
+MY_PN="${PN^^}"
+MY_PV="$(ver_cut 1-3)"
+
+DESCRIPTION="Supermicro Thin-Agent Service for monitoring through the BMC/IPMI"
+HOMEPAGE="https://www.supermicro.com"
+SRC_URI="${MY_PN}_${MY_PV}_build.${MY_DATE}.zip"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="BSD supermicro"
+SLOT="0"
+
+RDEPEND="net-misc/networkmanager
+ sys-apps/ethtool
+ sys-apps/net-tools
+ sys-apps/smartmontools
+ sys-block/storcli
+ sys-devel/bc
+ sys-fs/lsscsi
+ sys-fs/mdadm"
+DEPEND="app-arch/unzip"
+
+RESTRICT="bindist fetch mirror"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="usr/bin/IPMITAS"
+
+DOCS=(
+ "clireadme.txt"
+ "ReleaseNotes.txt"
+ "software_license_agreement_pv.pdf"
+ "TAS_UserGuide.pdf"
+)
+
+CONFIG_CHECK="~IPMI_DEVICE_INTERFACE ~IPMI_HANDLER ~IPMI_SI"
+
+pkg_nofetch() {
+ elog "Please download ${A} from"
+ elog "https://www.supermicro.com/SwDownload/UserInfo.aspx?sw=0&cat=TAS"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_unpack() {
+ unpack ${A}
+ unpack "${S}"/${MY_PN}_${MY_PV}_build.${MY_DATE}_Linux.tar.gz
+}
+
+src_install() {
+ dobin $(usex amd64 '64' '32')bit/IPMITAS
+
+ insinto /etc/supermicro
+ doins "${FILESDIR}"/tas.ini
+
+ dodir /var/log/tas
+ local logfiles=( {starttime,tas,tas.com}.log )
+ for logfile in ${logfiles[@]}; do
+ touch "${ED%/}"/var/log/tas/${logfile} || die
+ dosym ../../var/log/tas/${logfile} /etc/supermicro/${logfile}
+ done
+
+ newinitd "${FILESDIR}"/tas.initd tas
+ systemd_newunit "${FILESDIR}"/tas.service tas.service
+
+ einstalldocs
+}