summaryrefslogtreecommitdiff
path: root/sys-apps/systemd/systemd-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-02 11:45:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-02 11:45:20 +0000
commit7e3d6dcede5749fe6a1adef4e673a9dde7703b7b (patch)
treed4b1fc995691d4c2cde45fc9d9875e80e85fda73 /sys-apps/systemd/systemd-9999.ebuild
parentcc4bdc5d184af171efd67a1b32de966071ee18d3 (diff)
gentoo auto-resync : 02:02:2024 - 11:45:20
Diffstat (limited to 'sys-apps/systemd/systemd-9999.ebuild')
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 058e82af1331..85965aed1d27 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -29,7 +29,7 @@ else
fi
fi
-inherit bash-completion-r1 linux-info meson-multilib pam python-single-r1
+inherit bash-completion-r1 linux-info meson-multilib optfeature pam python-single-r1
inherit secureboot systemd toolchain-funcs udev
DESCRIPTION="System and service manager for Linux"
@@ -505,6 +505,15 @@ pkg_postinst() {
eerror "systemd again."
eerror
fi
+
+ if use boot; then
+ optfeature "automatically installing the kernels in systemd-boot's native layout and updating the bootloader configuration" \
+ "sys-kernel/installkernel[systemd-boot]"
+ fi
+ if use ukify; then
+ optfeature "automatically generating an unified kernel image on each kernel installation" \
+ "sys-kernel/installkernel[ukify]"
+ fi
}
pkg_prerm() {