summaryrefslogtreecommitdiff
path: root/sys-apps/systemd/systemd-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-10 23:14:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-10 23:14:41 +0000
commit145b1805c3986974378af5c60767504ecc9ed280 (patch)
tree28dbd5be73a5af5dd20d4ea81d293394d975c9e0 /sys-apps/systemd/systemd-9999.ebuild
parent627302fc2f41a621644260ffa3f50e06ea5edd60 (diff)
gentoo auto-resync : 10:12:2023 - 23:14:40
Diffstat (limited to 'sys-apps/systemd/systemd-9999.ebuild')
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 412ecb66e468..a5c20a8b0bde 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -487,6 +487,12 @@ pkg_postinst() {
rm "${EROOT}/var/lib/systemd/timesync"
fi
+ if [[ -z ${ROOT} && -d /run/systemd/system ]]; then
+ ebegin "Reexecuting system manager (systemd)"
+ systemctl daemon-reexec
+ eend $? || FAIL=1
+ fi
+
if [[ ${FAIL} ]]; then
eerror "One of the postinst commands failed. Please check the postinst output"
eerror "for errors. You may need to clean up your system and/or try installing"