summaryrefslogtreecommitdiff
path: root/sys-apps/systemd-utils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-04 08:14:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-04 08:14:38 +0100
commitf4e04dc11a0252f8c6c535b7538703974cd06ea0 (patch)
tree6ba3be4a2ac2e0f44768521ed50444220fcfec85 /sys-apps/systemd-utils
parentba32ac7204934e0c69e1cc7529edce6efdbeb265 (diff)
gentoo auto-resync : 04:04:2024 - 08:14:38
Diffstat (limited to 'sys-apps/systemd-utils')
-rw-r--r--sys-apps/systemd-utils/Manifest2
-rw-r--r--sys-apps/systemd-utils/systemd-utils-255.4.ebuild12
2 files changed, 10 insertions, 4 deletions
diff --git a/sys-apps/systemd-utils/Manifest b/sys-apps/systemd-utils/Manifest
index 3985b800be7c..b182882580dd 100644
--- a/sys-apps/systemd-utils/Manifest
+++ b/sys-apps/systemd-utils/Manifest
@@ -12,5 +12,5 @@ DIST systemd-stable-254.8.tar.gz 14418468 BLAKE2B e5a151ece86e57c7224fc95bda1b4e
DIST systemd-stable-255.4.tar.gz 14952427 BLAKE2B 27f5080f83a9e870fbe8e3ebcb500a63c42022f1f96f26f35c76eeeea85dab691291c31ee716cab330b76df5e576910a6a82f51267eff4f766b1d4c304d815c9 SHA512 8a2bde11a55f7f788ba7751789a5e9be6ce9634e88d54e49f6e832c4c49020c6cacaf2a610fe26f92998b0cbf43c6c2150a96b2c0953d23261009f57d71ea979
EBUILD systemd-utils-254.10-r1.ebuild 13334 BLAKE2B 3b1b65640a512c13f25d0dca551127107ab040607a6da8d40527903d208e63121f16a443aa036a0e85c01fff3829973855288b68496bcd13a2031e9525a38b55 SHA512 e2d9d1101966fc993a7f2ef319ad2d1646143c63f9f52881019c590657d89ade4978ad5667ea29d7f05185e7e6813560ecd8f32e92b434143b7b5aa2326477fe
EBUILD systemd-utils-254.8-r1.ebuild 13366 BLAKE2B 81f0a307703bc42cf23ec753cd5467685b13d3b3e92b944dcbbb9104a629f977881812e7e4310be3f2e4f19b4537cabfe659f55003d7a6839cc4a3b660e3e2aa SHA512 4d3356c9c188333c1a4a69646a80f232c1efaf33961ee1c7ee867e72c1291bb8493e991aba128683e043e4a39281b181efbac567cad0dce499f5495dfe91869a
-EBUILD systemd-utils-255.4.ebuild 13456 BLAKE2B 35e5396e9907212e49161b09abc00a749ee92ba6403a7ef65e39d947b3030ef14c100889b07e8bdf53728a80a768eaf3b2216ae0eb9c471b65418e71595af817 SHA512 1720749c29d722985b6feffd1b0da1e57bb265fa5ae3345af9c7eb4466bb9f1897c3bd6f91d8228d5f6ce88372ad53a5f038a486358da5f92a9cadbb77552895
+EBUILD systemd-utils-255.4.ebuild 13753 BLAKE2B 96ae2f52c47ff4a22d5fe9c8d42bff6e70c00656c50cefc6353e9c96cfe58977b05c589567ef334f591ef0ee8459b44472c9ff06917227a5e563f0eba72d4540 SHA512 e2242b212c0f79cc2a06b0491fa1903b4381b2436dd5e8e844b8be9f39d3c01b8f351f6c20adb6e5d96f0cf1b5bd842e0751b93e44c9745bb637788be0dbd513
MISC metadata.xml 888 BLAKE2B b799e1d62a1208dbbec1a1cfb47592b069d5c79cb18efffef922c72b0d61e30938d26c6f4e0d3951f9c327601dd71de14062dad0a47e6b84a61b1a8b125f1a6b SHA512 6debd964f9c127ba4332e0c0b86e506d3cf10cbe3cd45442bf7955b16e790a9eccdd928d473b3722b11b4a75d34fe5bb91f4867a5dc92e786ba73d9ec3f54712
diff --git a/sys-apps/systemd-utils/systemd-utils-255.4.ebuild b/sys-apps/systemd-utils/systemd-utils-255.4.ebuild
index a4f60f47e7f3..4c64afbd80c1 100644
--- a/sys-apps/systemd-utils/systemd-utils-255.4.ebuild
+++ b/sys-apps/systemd-utils/systemd-utils-255.4.ebuild
@@ -253,7 +253,7 @@ multilib_src_configure() {
}
multilib_src_compile() {
- local targets=()
+ local targets=() optional_targets=()
if multilib_is_native_abi; then
if use boot; then
local efi_arch= efi_arch_alt=
@@ -275,7 +275,10 @@ multilib_src_compile() {
src/boot/efi/addon${efi_arch}.efi.stub
)
if [[ -n ${efi_arch_alt} ]]; then
- targets+=(
+ # If we have a multilib toolchain, meson.build will build the
+ # "alt" arch (ia32). There's no easy way to detect this, so try
+ # to build it and ignore failure.
+ optional_targets+=(
src/boot/efi/systemd-boot${efi_arch_alt}.efi
src/boot/efi/linux${efi_arch_alt}.efi.stub
src/boot/efi/addon${efi_arch_alt}.efi.stub
@@ -392,9 +395,12 @@ multilib_src_compile() {
)
fi
fi
- if multilib_is_native_abi || use udev; then
+ if [[ ${#targets[@]} -ne 0 ]]; then
meson_src_compile "${targets[@]}"
fi
+ if [[ ${#optional_targets[@]} -ne 0 ]]; then
+ nonfatal meson_src_compile "${optional_targets[@]}"
+ fi
}
multilib_src_test() {