summaryrefslogtreecommitdiff
path: root/sys-apps/systemd-utils/systemd-utils-254.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-02 11:45:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-02 11:45:20 +0000
commit7e3d6dcede5749fe6a1adef4e673a9dde7703b7b (patch)
treed4b1fc995691d4c2cde45fc9d9875e80e85fda73 /sys-apps/systemd-utils/systemd-utils-254.5-r2.ebuild
parentcc4bdc5d184af171efd67a1b32de966071ee18d3 (diff)
gentoo auto-resync : 02:02:2024 - 11:45:20
Diffstat (limited to 'sys-apps/systemd-utils/systemd-utils-254.5-r2.ebuild')
-rw-r--r--sys-apps/systemd-utils/systemd-utils-254.5-r2.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/sys-apps/systemd-utils/systemd-utils-254.5-r2.ebuild b/sys-apps/systemd-utils/systemd-utils-254.5-r2.ebuild
index d31c70d4444c..af0e5dfe3c6a 100644
--- a/sys-apps/systemd-utils/systemd-utils-254.5-r2.ebuild
+++ b/sys-apps/systemd-utils/systemd-utils-254.5-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,8 +6,8 @@ PYTHON_COMPAT=( python3_{10..12} )
QA_PKGCONFIG_VERSION=$(ver_cut 1)
-inherit bash-completion-r1 flag-o-matic linux-info meson-multilib python-single-r1
-inherit secureboot toolchain-funcs udev usr-ldscript
+inherit bash-completion-r1 flag-o-matic linux-info meson-multilib optfeature
+inherit python-single-r1 secureboot toolchain-funcs udev usr-ldscript
DESCRIPTION="Utilities split out from systemd for OpenRC users"
HOMEPAGE="https://systemd.io/"
@@ -572,4 +572,13 @@ pkg_postinst() {
eend $?
udev_reload
fi
+
+ if use boot; then
+ optfeature "automatically installing the kernels in systemd-boot's native layout and updating the bootloader configuration" \
+ "sys-kernel/installkernel[systemd-boot]"
+ fi
+ if use ukify; then
+ optfeature "automatically generating an unified kernel image on each kernel installation" \
+ "sys-kernel/installkernel[ukify]"
+ fi
}