summaryrefslogtreecommitdiff
path: root/sys-apps/systemd-utils/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-06 09:19:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-06 09:19:37 +0000
commit6003fc7a6eda56862fcff321f47e40cd34e60098 (patch)
tree342368c16c4837b5d9eaf8c4d8c0ea298d1e3308 /sys-apps/systemd-utils/files
parent30c2cb2c8971dc95b672303f9191d166d622fe47 (diff)
gentoo auto-resync : 06:11:2022 - 09:19:37
Diffstat (limited to 'sys-apps/systemd-utils/files')
-rw-r--r--sys-apps/systemd-utils/files/251-meson-0.64.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-apps/systemd-utils/files/251-meson-0.64.patch b/sys-apps/systemd-utils/files/251-meson-0.64.patch
new file mode 100644
index 000000000000..6cc200bbd87d
--- /dev/null
+++ b/sys-apps/systemd-utils/files/251-meson-0.64.patch
@@ -0,0 +1,26 @@
+From cddbc850270415a818aadabd71fe12dc0dddd508 Mon Sep 17 00:00:00 2001
+From: Jan Janssen <medhefgo@web.de>
+Date: Sun, 9 Oct 2022 17:16:12 +0200
+Subject: [PATCH] meson: Fix build with --optimization=plain
+
+Note that -O0 is deliberately filtered out as we have to compile with at
+least -O1 due to #24202.
+
+Fixes: #24323
+---
+ src/boot/efi/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/boot/efi/meson.build b/src/boot/efi/meson.build
+index e0cd4ebad993..395386d3eda7 100644
+--- a/src/boot/efi/meson.build
++++ b/src/boot/efi/meson.build
+@@ -223,7 +223,7 @@ endif
+ if get_option('debug') and get_option('mode') == 'developer'
+ efi_cflags += ['-ggdb', '-DEFI_DEBUG']
+ endif
+-if get_option('optimization') != '0'
++if get_option('optimization') in ['1', '2', '3', 's', 'g']
+ efi_cflags += ['-O' + get_option('optimization')]
+ endif
+ if get_option('b_ndebug') == 'true' or (