summaryrefslogtreecommitdiff
path: root/sys-apps/systemd-readahead
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/systemd-readahead
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/systemd-readahead')
-rw-r--r--sys-apps/systemd-readahead/Manifest5
-rw-r--r--sys-apps/systemd-readahead/metadata.xml8
-rw-r--r--sys-apps/systemd-readahead/systemd-readahead-216.ebuild160
3 files changed, 173 insertions, 0 deletions
diff --git a/sys-apps/systemd-readahead/Manifest b/sys-apps/systemd-readahead/Manifest
new file mode 100644
index 000000000000..c52e279ff60d
--- /dev/null
+++ b/sys-apps/systemd-readahead/Manifest
@@ -0,0 +1,5 @@
+DIST systemd-216.tar.xz 3612960 SHA256 945d3db7d840d6ffe98aa68394428e13317161ae79905397faab6671619728f3 SHA512 f4eee6664368168eafd61939f1355ac21c7eeecce6247de98ef36f40bb6a942d12c006ced4ee15f3d8f11699c194990222d5a5115b45f2aa81f2a1abafebbdd2 WHIRLPOOL 505e09b55209a4f9d8cec077970571b2e1298e8db02946a6c79df139dece9d1a08e46c86ef6c8053274abfd46c9a5ea09157f5bc9dc1f7461322c596e84ef494
+EBUILD systemd-readahead-216.ebuild 4183 SHA256 336529b89b3992e9138afe5f543dace0c863ea986be053e60e11f73d82e41ada SHA512 c54289a199d7d448afdaa83cc2f341bff37544398bb062fe7f36a1a0a0b4054c89532f0d427d2cce9df6979706c401a0560dfd89e4158f404534a622a815dd11 WHIRLPOOL 0d5ac928ec69f58d1d664466d44505f4643b25159515fa8c52731ceeeeb5dd44d93e33c8f5f50f5808868ed299590b3020410aba4c0bd605d3c529f237a2a6dd
+MISC ChangeLog 3033 SHA256 e075c48a70faeea7e7aff920f696b02bf0df2ebc8533a334e6f963cf1924e6a3 SHA512 fbd75e7204eb31124f207a54492559b2e602e762ae43d44934a5e5d0afc93a83175b83c2f267f1944fc8ee44ac6e2243f9c78863ef26bf95d9c8cab22aa8b1e2 WHIRLPOOL 649f8f5c5f166924bdbfc33c648fa2c10355f420692fdce6abbd43b5537a731a8577f9add759cd58bb910e5978d82790a84637b9331ec7c62af53b8df4a75e6b
+MISC ChangeLog-2015 469 SHA256 c0b861226a2fd82476ff5473a54e775a16fee4783b3a31013622b0daaa96ebfe SHA512 6603b1bc3332d7fce063049ca1d0ccac9be4589e23d69a51005282bbaa75b3bdde2db1fa5b74e691046872e101d6a530a17fa045c9e485e5af7d21cce76ca4e7 WHIRLPOOL f0293c3e877295f7cf11482ffacdec0e50f7fce5bd1593a3b3c457b28edc6e44e6e1114b7b382d778c52d7da150270db019ff3bddfdccf08147a703854b9ba32
+MISC metadata.xml 243 SHA256 c2902f16dc6be36b40d0e76de3275bf3ccdea37d5f0522492f5f5a624b2e9285 SHA512 640630eb9d42c319ca1da37b03a03677a3dd4e48f28ce2690b64f6e4e7d5885cfda41d439f3f9d8b009be04891b043a5b0ac6f9d43b701f65c8fcc0e0613b04a WHIRLPOOL 2279bba195f44213fecf0414bb604a75ae7487b85697f97d4325054f67fdfce2809e751a39b6dc677e5e42a9cdb136409b846597841f2e759485e38e2c5a921a
diff --git a/sys-apps/systemd-readahead/metadata.xml b/sys-apps/systemd-readahead/metadata.xml
new file mode 100644
index 000000000000..3da97a9953cc
--- /dev/null
+++ b/sys-apps/systemd-readahead/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>pacho@gentoo.org</email>
+ <name>Pacho Ramos</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-apps/systemd-readahead/systemd-readahead-216.ebuild b/sys-apps/systemd-readahead/systemd-readahead-216.ebuild
new file mode 100644
index 000000000000..e29293a0a6cc
--- /dev/null
+++ b/sys-apps/systemd-readahead/systemd-readahead-216.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit systemd toolchain-funcs udev
+
+DESCRIPTION="Split of readahead systemd implementation"
+HOMEPAGE="https://dev.gentoo.org/~pacho/systemd-readahead.html"
+SRC_URI="https://www.freedesktop.org/software/systemd/systemd-${PV}.tar.xz"
+
+LICENSE="LGPL-2.1 MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+S=${WORKDIR}/systemd-${PV}
+
+RDEPEND=">=sys-apps/systemd-217:="
+DEPEND="${RDEPEND}
+ app-arch/xz-utils:0
+ dev-util/gperf
+ >=dev-util/intltool-0.50
+ >=sys-apps/coreutils-8.16
+ >=sys-devel/binutils-2.23.1
+ >=sys-kernel/linux-headers-3.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # systemd-notify no longer supports readahead playing
+ sed -i -e 's:ExecStart=@SYSTEMD_NOTIFY@ --readahead=done:ExecStart=/bin/touch /run/systemd/readahead/done:' \
+ units/systemd-readahead-done.service.in || die
+}
+
+src_configure() {
+ # Keep using the one where the rules were installed.
+ MY_UDEVDIR=$(get_udevdir)
+ # Fix systems broken by bug #509454.
+ [[ ${MY_UDEVDIR} ]] || MY_UDEVDIR=/lib/udev
+
+ local myeconfargs=(
+ # disable -flto since it is an optimization flag
+ # and makes distcc less effective
+ cc_cv_CFLAGS__flto=no
+
+ --enable-readahead
+
+ --disable-maintainer-mode
+ --localstatedir=/var
+ # make sure we get /bin:/sbin in $PATH
+ --enable-split-usr
+ # For testing.
+ --with-rootprefix="${ROOTPREFIX-/usr}"
+ --with-rootlibdir="${ROOTPREFIX-/usr}/$(get_libdir)"
+ # disable sysv compatibility
+ --with-sysvinit-path=
+ --with-sysvrcnd-path=
+ # Disable most of the stuff
+ --disable-efi
+ --disable-ima
+ --disable-acl
+ --disable-apparmor
+ --disable-audit
+ --disable-libcryptsetup
+ --disable-libcurl
+ --disable-gtk-doc
+ --disable-elfutils
+ --disable-gcrypt
+ --disable-gudev
+ --disable-microhttpd
+ --disable-gnutls
+ --disable-libidn
+ --disable-introspection
+ --disable-kdbus
+ --disable-kmod
+ --disable-lz4
+ --disable-xz
+ --disable-pam
+ --disable-polkit
+ --without-python
+ --disable-python-devel
+ --disable-qrencode
+ --disable-seccomp
+ --disable-selinux
+ --disable-tests
+ --disable-dbus
+
+ --disable-smack
+ --disable-blkid
+ --disable-multi-seat-x
+ --disable-myhostname
+
+ # Disable optional binaries
+ --disable-backlight
+ --disable-binfmt
+ --disable-bootchart
+ --disable-coredump
+ --disable-firstboot
+ --disable-hostnamed
+ --disable-localed
+ --disable-logind
+ --disable-machined
+ --disable-networkd
+ --disable-quotacheck
+ --disable-randomseed
+ --disable-resolved
+ --disable-rfkill
+ --disable-sysusers
+ --disable-timedated
+ --disable-timesyncd
+ --disable-tmpfiles
+ --disable-vconsole
+
+ # not supported (avoid automagic deps in the future)
+ --disable-chkconfig
+
+ # dbus paths
+ --with-dbuspolicydir="${EPREFIX}/etc/dbus-1/system.d"
+ --with-dbussessionservicedir="${EPREFIX}/usr/share/dbus-1/services"
+ --with-dbussystemservicedir="${EPREFIX}/usr/share/dbus-1/system-services"
+ --with-dbusinterfacedir="${EPREFIX}/usr/share/dbus-1/interfaces"
+ )
+
+ # Work around bug 463846.
+ tc-export CC
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ echo 'BUILT_SOURCES: $(BUILT_SOURCES)' > "${T}"/Makefile.extra
+ emake -f Makefile -f "${T}"/Makefile.extra BUILT_SOURCES
+
+ emake systemd-readahead
+ emake units/systemd-readahead-{drop,collect,replay,done}.service units/systemd-readahead-done.timer
+ emake man/{sd-readahead.3,sd_readahead.3,systemd-readahead-replay.service.8}
+}
+
+src_test() {
+ einfo "No specific tests for this"
+}
+
+src_install() {
+ # Install main app
+ exeinto /usr/lib/systemd/
+ doexe systemd-readahead
+
+ # Install unit files
+ systemd_dounit units/systemd-readahead-{drop,collect,replay,done}.service units/systemd-readahead-done.timer
+
+ # Install manpages and aliases
+ doman man/{sd-readahead.3,sd_readahead.3,systemd-readahead-replay.service.8}
+ newman man/systemd-readahead-replay.service.8 systemd-readahead-collect.service.8
+ newman man/systemd-readahead-replay.service.8 systemd-readahead-done.service.8
+ newman man/systemd-readahead-replay.service.8 systemd-readahead-done.timer.8
+ newman man/systemd-readahead-replay.service.8 systemd-readahead.8
+
+ # Install docs
+ dodoc TODO README
+}