summaryrefslogtreecommitdiff
path: root/sys-apps/superiotool/superiotool-6637.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/superiotool/superiotool-6637.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/superiotool/superiotool-6637.ebuild')
-rw-r--r--sys-apps/superiotool/superiotool-6637.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-apps/superiotool/superiotool-6637.ebuild b/sys-apps/superiotool/superiotool-6637.ebuild
new file mode 100644
index 000000000000..9cd57fadcfca
--- /dev/null
+++ b/sys-apps/superiotool/superiotool-6637.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit toolchain-funcs eutils
+
+if [[ ${PV} == "99999999" ]] ; then
+ ESVN_REPO_URI="svn://coreboot.org/coreboot/trunk/util/${PN}"
+ inherit subversion
+ SRC_URI=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="util to detect Super I/O chips and functionality"
+HOMEPAGE="http://www.coreboot.org/Superiotool"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="pci"
+
+RDEPEND="pci? ( sys-apps/pciutils )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+src_prepare() {
+ sed -i \
+ -e 's:-Werror ::' \
+ -e 's:-O2 ::' \
+ -e 's:\s\+\?-lz\s\+\?::' \
+ -e "/^CONFIG_PCI =/s:=.*:=$(usex pci yes no):" \
+ -e '/PREFIX/s:=.*:= /usr:' \
+ Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ SVNDEF="-D'SUPERIOTOOL_VERSION=\"${ESVN_WC_REVISION}\"'"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc README
+}