summaryrefslogtreecommitdiff
path: root/sys-apps/sparc-utils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /sys-apps/sparc-utils
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'sys-apps/sparc-utils')
-rw-r--r--sys-apps/sparc-utils/Manifest1
-rw-r--r--sys-apps/sparc-utils/sparc-utils-1.9-r7.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/sys-apps/sparc-utils/Manifest b/sys-apps/sparc-utils/Manifest
index 67633d764205..34067326a0e3 100644
--- a/sys-apps/sparc-utils/Manifest
+++ b/sys-apps/sparc-utils/Manifest
@@ -3,4 +3,5 @@ AUX sparc-utils-1.9-no-implicit.patch 584 BLAKE2B 153440b685bfd044c24f3da8559889
DIST sparc-utils_1.9-4.diff.gz 9083 BLAKE2B e4b16c26fe67be73d0fd3ad8e1e80b19356d5961abac344f28650e4d355cac9c557999591947391c41be88d819ebb703ae1ff177b4fbe0d9bea7a411a791821f SHA512 ef79dc480471117da3a778450b3a122eaf64fdee69d35ff30b301f2360ff5d76c6343ce37c25cc188891c1619809daa0595d01c6e85781ddd7ddf1713c8378b7
DIST sparc-utils_1.9.orig.tar.gz 110080 BLAKE2B 52f47c130fb8e24b0340589c846292fb2e4e9b211a10cddf52a7a63edd70673e2b7d05c2415e558c5f2d1235f33f4ae65b777d3f8b2cf2c50a601d1f0a7a941a SHA512 bde05f1a98211aaf502be6dfd757ddfb21c136cedbb46ca84a4539706c71901815c9d8bedfebc3800c7340634b32276197c75f92f9cc829e4f50c37d203e9358
EBUILD sparc-utils-1.9-r6.ebuild 1585 BLAKE2B b91d32f573e973dd9fcfa68f28652da3d3a7ed29a786f40222fa865a65d887ab923e4d16be613d61190d3358af87f7975f49881bba375c09a47d229efd9d1c39 SHA512 79cb400fb36e2aab458eba75f9580ead604451986bee29b275570b5c1b91143fcbf0ccf5b657a383feeefb243c411cf13c239ba0ec23197c53fd94560c759703
+EBUILD sparc-utils-1.9-r7.ebuild 1586 BLAKE2B 6863cba0c0ee442437137d0c142dcc419816326787f43a5644a6c4cdd3eab50582927d815d920753bb2cdbf42549c9bf83a8f022c179d8e1191e39bd128d1325 SHA512 0a600262916b855c200e89cfc4f72478ad9340d2ac7748bb2b755c1af0a164ca66093f6f3b63ef5bcbdc112ee7b2d29460682479503dd0dbcf078bcc5848261c
MISC metadata.xml 416 BLAKE2B 3d0e052bc957750b869856cabb6e94d86dc1655e63da29ac3753c16d8437e7a9a97c89e225f03b6267bb32bdbe6215c25717f088684e493b5785a6d334854dd1 SHA512 c057eea9ea65b87cb366e802dd8962901024335a85b3ec53caa6c342c9e1a23e656dcadc2a70692e5e7ab55a0ac82637ef052699844f50061461a645613b688d
diff --git a/sys-apps/sparc-utils/sparc-utils-1.9-r7.ebuild b/sys-apps/sparc-utils/sparc-utils-1.9-r7.ebuild
new file mode 100644
index 000000000000..585dd2e6facb
--- /dev/null
+++ b/sys-apps/sparc-utils/sparc-utils-1.9-r7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Various sparc utilities from Debian GNU/Linux"
+HOMEPAGE="https://packages.debian.org/sparc-utils"
+SRC_URI="mirror://debian/pool/main/s/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/s/${PN}/${PN}_${PV}-4.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~sparc"
+IUSE=""
+
+DEPEND="virtual/os-headers"
+RDEPEND=">=sys-apps/util-linux-2.13-r1"
+
+S=${WORKDIR}/${P}.orig
+
+PATCHES=(
+ "${WORKDIR}/${PN}_${PV}-4.diff"
+ "${FILESDIR}"/${P}-no-implicit.patch
+ "${FILESDIR}"/elftoaout-2.3-64bit_fixes-1.patch
+)
+
+src_compile() {
+ emake -C elftoaout-2.3 \
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+ emake -C src piggyback piggyback64 \
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+ emake -C prtconf-1.3 all \
+ CC="$(tc-getCC)"
+}
+
+src_install() {
+ # since the debian/piggyback64.1 manpage is a pointer to the
+ # debian/piggyback.1 manpage, copy debian/piggyback.1 to
+ # debian/piggyback64.1
+
+ cp "${S}"/debian/piggyback.1 "${S}"/debian/piggyback64.1 || die
+
+ dobin elftoaout-2.3/elftoaout
+ dobin src/piggyback
+ dobin src/piggyback64
+ dosbin prtconf-1.3/prtconf
+ dosbin prtconf-1.3/eeprom
+
+ doman elftoaout-2.3/elftoaout.1
+ doman prtconf-1.3/prtconf.8
+ doman prtconf-1.3/eeprom.8
+ doman debian/piggyback.1
+ doman debian/piggyback64.1
+}
+
+pkg_postinst() {
+ ewarn "In order to have /usr/sbin/eeprom, make sure you build /dev/openprom"
+ ewarn "device support (CONFIG_SUN_OPENPROMIO) into the kernel, or as a"
+ ewarn "module (and that the module is loaded)."
+}