summaryrefslogtreecommitdiff
path: root/sys-apps/smc-sum
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:52:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:52:04 +0100
commit71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /sys-apps/smc-sum
parent6612a728ea11526a849618ec515ad57131d64416 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'sys-apps/smc-sum')
-rw-r--r--sys-apps/smc-sum/Manifest3
-rw-r--r--sys-apps/smc-sum/metadata.xml23
-rw-r--r--sys-apps/smc-sum/smc-sum-2.0.1.20180420.ebuild42
3 files changed, 68 insertions, 0 deletions
diff --git a/sys-apps/smc-sum/Manifest b/sys-apps/smc-sum/Manifest
new file mode 100644
index 000000000000..11b2e948e9d5
--- /dev/null
+++ b/sys-apps/smc-sum/Manifest
@@ -0,0 +1,3 @@
+DIST sum_2.0.1_Linux_x86_64_20180420.tar.gz 6150348 BLAKE2B 1aa520ac18f97bfe16b9160c632cf09bc2021d47789712dec5ea9c9789022cfc8a24f15b1cebd0bdfde65af639a97b2de1474ea0af07c9bf569a56d02e1e8e56 SHA512 61a46b7bc745267fb2f224151fa29b965a56d163ec0e30d46ebdc925b3fab036903f9364cf83428f3e17c6e57db93be48a1ec2a5e7ab6599588d7430af1af628
+EBUILD smc-sum-2.0.1.20180420.ebuild 960 BLAKE2B 0a75747290f3ee2b1939347080e55fece135f704c73f9d3f0a587999246754fd13e479982994152ebd4b194e9e4a948b0c97ffea184813e4a61442eafb6b2f8b SHA512 c113dabcf3a971b6dbbdf4333f23f6a8d66bf4b18488666b3cc162f796770128fc1f8121eb46df06f0314610ab76a0a5b94ecc7eedf6e359854d407b97be7197
+MISC metadata.xml 1136 BLAKE2B 4fbbabd1a17374af0549a687211c55f4633ae1beea70b844b85b5f90b8f0c1cf053e11d271c9fd61be371a443bb0dcff268ac08476b5ae8d27a2580fa35a8371 SHA512 0d16f9dc63d86b301ce11ca3ae269aa9ea0e755370f46d875dabaf33f0ea244eb304d622bfe22d92dafbf014eb259f56c69ac53dcd0d8688f4792760f267531b
diff --git a/sys-apps/smc-sum/metadata.xml b/sys-apps/smc-sum/metadata.xml
new file mode 100644
index 000000000000..f51d8926c17f
--- /dev/null
+++ b/sys-apps/smc-sum/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Supermicro Update Manager (SUM) can be used to manage the firmware and configuration
+ for Supermicro X9 (Romley), X10, B10, X11, B11, H11 generation motherboards.
+ SUM is a command line interface utility that can execute parallel commands
+ from a centralized management server. Two channels are possible for management:
+ the OOB (Out-Of-Band) channel, i.e. communication through the BMC/IPMI interface,
+ and the in-band channel, i.e. communication through the local system interfaces.
+ Through the OOB channel, most management commands can be executed independently
+ of the OS on the managed system and even before the system OS is installed.
+ Licensing: SFT-OOB-LIC or SFT-DCMS-Single required for each monitor node.
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-apps/smc-sum/smc-sum-2.0.1.20180420.ebuild b/sys-apps/smc-sum/smc-sum-2.0.1.20180420.ebuild
new file mode 100644
index 000000000000..cdbd078eb847
--- /dev/null
+++ b/sys-apps/smc-sum/smc-sum-2.0.1.20180420.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eapi7-ver
+
+MY_DATE="$(ver_cut 4)"
+MY_PN="${PN/smc-/}"
+MY_PV="$(ver_cut 1-3)"
+
+DESCRIPTION="Updates the BIOS and IPMI firmware and system settings on Supermicro mainboards"
+HOMEPAGE="https://www.supermicro.com"
+SRC_URI="${MY_PN}_${MY_PV}_Linux_x86_64_${MY_DATE}.tar.gz"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="supermicro"
+SLOT="0"
+
+RDEPEND="sys-apps/smc-sum-driver"
+
+RESTRICT="bindist fetch mirror strip"
+
+S="${WORKDIR}/${MY_PN}_${MY_PV}_Linux_x86_64"
+
+DOCS=( "ReleaseNote.txt" "SUM_UserGuide.pdf" "ExternalData/SMCIPID.txt" "ExternalData/VENID.txt" )
+
+QA_PREBUILT="usr/bin/smc-sum"
+
+pkg_nofetch() {
+ elog "Please download ${A} from"
+ elog "sftp://dataharbor.supermicro.com"
+ elog "Username: dpguest\$ts"
+ elog "Password: supermicro!@#"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_install() {
+ newbin sum smc-sum
+
+ einstalldocs
+}