summaryrefslogtreecommitdiff
path: root/sys-apps/smc-sum-driver
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:52:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:52:04 +0100
commit71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /sys-apps/smc-sum-driver
parent6612a728ea11526a849618ec515ad57131d64416 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'sys-apps/smc-sum-driver')
-rw-r--r--sys-apps/smc-sum-driver/Manifest4
-rw-r--r--sys-apps/smc-sum-driver/files/makefile15
-rw-r--r--sys-apps/smc-sum-driver/metadata.xml17
-rw-r--r--sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201.ebuild41
4 files changed, 77 insertions, 0 deletions
diff --git a/sys-apps/smc-sum-driver/Manifest b/sys-apps/smc-sum-driver/Manifest
new file mode 100644
index 000000000000..13fbf00e33e5
--- /dev/null
+++ b/sys-apps/smc-sum-driver/Manifest
@@ -0,0 +1,4 @@
+AUX makefile 298 BLAKE2B 58431440f52821bf8f1a6070075eace33f173dc1cbe19722c033cc6525b2ae4a6890aec2870f68b282368c9722b87796a14b53d364ce3e7002dfac452480e74e SHA512 862b6a2ae684da3b864eacef8b645c27ef4a6ccc4f577ccc9c5d88cd0426ce66a6462bcaaf01bdd0082898f7e3801cd6a00bc1c702af83faf7ca31b9de1c14e9
+DIST sum_driver_V1.6.0_20151201.tar.gz 1423921 BLAKE2B 76e2439148749b708a51e0d9c95545b53762f03793e6b2ea6e63e9f79aaad77432f728e94713e0cfd4085e8b090b6e0ff8e779e2627764e71794453cb7e02b49 SHA512 809fdf164e29aabde74306d966de7e07488d8dacc01963b56486477f23bdf3a469d059bc5d302aedbfd4b8dc854a82357747add2626cc22d0ab3898c7bc0a625
+EBUILD smc-sum-driver-1.6.0.20151201.ebuild 886 BLAKE2B d11e9409609902cf9a0c40c04646cdc990cfb190db7a399fc3d1e0aedfa06c6fb33a64de1d91952dada7eb45b14e572632a34c9e149813931af6f006562d4986 SHA512 1c5461d28af43409d444ba481f2f1a3246a732185802812fa2cce456d0931f265a9219812d96c68292c3c7d33d377d059cb31498b15bc660843f89d854a15621
+MISC metadata.xml 602 BLAKE2B 6bb453de4cd9a7cd7f52648c2994ac056bb756a8851659bd4075341e5d97a6cd81d056ef54cd4315ae25d6821ac684bafaee12d7928d7a998724e87af57cf05f SHA512 27d229c5f3ea94fb7098f4659edf321b048ecdba0624a41cfc53cec5b3d3c975914fc599494ebb03ae5dc8ea29993a23e90a9b7be76505cb7dcdf8ab1e3d9b5e
diff --git a/sys-apps/smc-sum-driver/files/makefile b/sys-apps/smc-sum-driver/files/makefile
new file mode 100644
index 000000000000..35564dcc8fec
--- /dev/null
+++ b/sys-apps/smc-sum-driver/files/makefile
@@ -0,0 +1,15 @@
+obj-m := sum_bios.o
+
+KVERSION := $(shell uname -r)
+KDIR := /lib/modules/$(KVERSION)/build
+PWD := $(shell pwd)
+
+EXTRA_CFLAGS = $(CFLAGS) -Wno-incompatible-pointer-types
+EXTRA_LDFLAGS = $(LDFLAGS)
+
+default:
+ $(MAKE) -C $(KDIR) M=$(PWD) modules
+
+install:
+ $(MAKE) -C $(KDIR) M=$(PWD) modules_install
+
diff --git a/sys-apps/smc-sum-driver/metadata.xml b/sys-apps/smc-sum-driver/metadata.xml
new file mode 100644
index 000000000000..3720c27565ed
--- /dev/null
+++ b/sys-apps/smc-sum-driver/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ This is the kernel module for the Supermicro Update Manager (SUM).
+ It's needed to access specific low level elements, like BIOS.
+ Supermicro SuperDoctor5 will also need this kernel module.
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201.ebuild b/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201.ebuild
new file mode 100644
index 000000000000..f37dc6d72d09
--- /dev/null
+++ b/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eapi7-ver linux-mod
+
+MY_DATE="$(ver_cut 4)"
+MY_PN="${PN//-/_}"
+MY_PV="$(ver_cut 1-3)"
+MY_P="${MY_PN/smc_/}_V${MY_PV}"
+
+DESCRIPTION="Supermicro Update Manager (SUM) kernel module"
+HOMEPAGE="https://www.supermicro.com"
+SRC_URI="${MY_P}_${MY_DATE}.tar.gz"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="supermicro"
+SLOT="0"
+
+RESTRICT="bindist fetch mirror"
+
+S="${WORKDIR}"/${MY_P}/Linux
+
+BUILD_TARGETS="default"
+MODULE_NAMES="sum_bios(misc:${S})"
+
+pkg_nofetch() {
+ elog "Please download ${A} from"
+ elog "sftp://dataharbor.supermicro.com"
+ elog "Username: dpguest\$ts"
+ elog "Password: supermicro!@#"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_prepare() {
+ # Install new Makefile to respect users CFLAGS and LDFLAGS
+ cp "${FILESDIR}"/makefile Makefile
+
+ default
+}