summaryrefslogtreecommitdiff
path: root/sys-apps/smartmontools/smartmontools-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sys-apps/smartmontools/smartmontools-9999.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sys-apps/smartmontools/smartmontools-9999.ebuild')
-rw-r--r--sys-apps/smartmontools/smartmontools-9999.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/sys-apps/smartmontools/smartmontools-9999.ebuild b/sys-apps/smartmontools/smartmontools-9999.ebuild
index c3e86bfcdb7b..1c0502087af3 100644
--- a/sys-apps/smartmontools/smartmontools-9999.ebuild
+++ b/sys-apps/smartmontools/smartmontools-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
inherit autotools flag-o-matic systemd
if [[ ${PV} == "9999" ]] ; then
@@ -22,13 +22,15 @@ IUSE="caps +daemon selinux static systemd +update-drivedb"
DEPEND="
caps? (
- static? ( sys-libs/libcap-ng[static-libs] )
- !static? ( sys-libs/libcap-ng )
+ static? ( sys-libs/libcap-ng:=[static-libs] )
+ !static? ( sys-libs/libcap-ng:= )
)
selinux? (
- sys-libs/libselinux
- )"
-RDEPEND="${DEPEND}
+ sys-libs/libselinux:=
+ )
+"
+RDEPEND="
+ ${DEPEND}
daemon? ( virtual/mailx )
selinux? ( sec-policy/selinux-smartmon )
systemd? ( sys-apps/systemd )
@@ -110,16 +112,16 @@ src_install() {
# Make sure we never install drivedb.h into the db location
# of the acutal image so we don't record hashes because user
# can modify that file
- rm -f "${ED%/}${db_path}/drivedb.h" || die
+ rm -f "${ED}${db_path}/drivedb.h" || die
# Bug #622072
- find "${ED%/}"/usr/share/doc -type f -exec chmod a-x '{}' \; || die
+ find "${ED}"/usr/share/doc -type f -exec chmod a-x '{}' \; || die
}
pkg_postinst() {
if use daemon || use update-drivedb; then
- local initial_db_file="${EROOT}usr/share/${PN}/drivedb.h"
- local db_path="${EROOT}var/db/${PN}"
+ local initial_db_file="${EROOT}/usr/share/${PN}/drivedb.h"
+ local db_path="${EROOT}/var/db/${PN}"
if [[ ! -f "${db_path}/drivedb.h" ]] ; then
# No initial database found