summaryrefslogtreecommitdiff
path: root/sys-apps/selinux-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
commit2891d29af8907ce881662f4a02844926d7a293c7 (patch)
tree56979d96839d0827aa52008b81b746b4934d88df /sys-apps/selinux-python
parentde49812990871e1705b64051c35161d5e6400269 (diff)
gentoo resync : 31.12.2018
Diffstat (limited to 'sys-apps/selinux-python')
-rw-r--r--sys-apps/selinux-python/Manifest3
-rw-r--r--sys-apps/selinux-python/selinux-python-2.8-r1.ebuild95
-rw-r--r--sys-apps/selinux-python/selinux-python-9999.ebuild6
3 files changed, 100 insertions, 4 deletions
diff --git a/sys-apps/selinux-python/Manifest b/sys-apps/selinux-python/Manifest
index ca55f6155418..93418ff49cd1 100644
--- a/sys-apps/selinux-python/Manifest
+++ b/sys-apps/selinux-python/Manifest
@@ -1,6 +1,7 @@
DIST selinux-python-2.7.tar.gz 2068004 BLAKE2B 57c7f324a8faddf57a576f9ec5c46c8dbbd085a3aff4355df645b0f391a0c2db718e8adb2719515cc4a9c386e11c3df053b5303d3f91ff4958fb91e80d440b51 SHA512 df8645e7ac9ca568f0c9d81c42b93d0abadc43c22f14d38451ab262b52132cfb7abd7742e3a00ab9c153f95dd5b23b3a496d84875debcd9787f75d940eb45c28
DIST selinux-python-2.8.tar.gz 2068101 BLAKE2B c28f12e4bd453955148a6ba82fd28621d1a4600f872ac63d97372f2e0153091adf1cf871f89765dd300bc6b7b2d610b96f87e3fc5accbfad713ed8a0d8f76f5a SHA512 e695c11122f7f8105b75d1ef98355fd2b82b40d93c2fd9e733dcd95d4d7c392f60b646df81203c43ad2a0e8447f9901083007e1572b78e17368ad2764ffa1aad
EBUILD selinux-python-2.7.ebuild 2673 BLAKE2B 14692ea38d55be1eb9b17dde7b4f1c7195139543347314896527c442931812bdac4524cd75c66b654d9b778ed4d6d213d21f2b8b1f3dc424b4bf8101da08bb07 SHA512 ad6d6047b551c82464d58de569cbe7c4137d0e5c87125164690bab4aac5bb48fa01059e31e1cb6de99a0abfd942c7294fefecced7e4b19d8dc4715b398c788c6
+EBUILD selinux-python-2.8-r1.ebuild 2574 BLAKE2B fd485f85d9131effc46be7741a5aa1fb2d772d71ce3a01108e59ab8885ea6bb02b28ffbe174eeb3a4b6f195424d04eb6a0d42df5f3c2104506c6b26823f36129 SHA512 a0311ff67fd075219d140e8811cf19872d1ddebe0fc51bdeb870d27a58350459559a54b04ac3bf41d3074fc33446f110279710310afbdbbbd1b3c8bbba7c49e5
EBUILD selinux-python-2.8.ebuild 2583 BLAKE2B db435532e1b00e5dda43f060753be5302b1c3ac490580e56756ee5f65f5ec1477de27afa9368c03f4501c789c071c44dfb926c5c8d26540bd709a6982099d97c SHA512 6a3c712d563d14e0bf203976a4251178bddb08a24725cab1b95c07664fd874631698c9c59c446499d87a2950bb1c29b2bf97e67465e3e2afa07f6cafdac101bf
-EBUILD selinux-python-9999.ebuild 2585 BLAKE2B 8e01d08781d9c53b2832b939073f0e720abfadddfa5de47a64e69fe4e99c813e1e94db5e593031981aba443b374f130fa0ae6d95ae6cf9178e64bf21b5183941 SHA512 cf4ac70801dcd0bb15c292c7b85e3818e34146d09176446a9068ab5826fe82d7167e8761f5548825f3a36b2545447c85f067d48468f70d52a094757a39811f4e
+EBUILD selinux-python-9999.ebuild 2574 BLAKE2B fd485f85d9131effc46be7741a5aa1fb2d772d71ce3a01108e59ab8885ea6bb02b28ffbe174eeb3a4b6f195424d04eb6a0d42df5f3c2104506c6b26823f36129 SHA512 a0311ff67fd075219d140e8811cf19872d1ddebe0fc51bdeb870d27a58350459559a54b04ac3bf41d3074fc33446f110279710310afbdbbbd1b3c8bbba7c49e5
MISC metadata.xml 718 BLAKE2B ca11527a8722aa1c1f74f1731409e950f866094492f15e9345c117622da63f06bb5681e806545083200a494d3b65f0c4f31e1454aea5fed923f438ef01aa91af SHA512 a45a1c3e516dd956e60be67ddce632d055a98ff0fb45b920adfb5d1253da77822286f9742865027a47e94386dad2a1478a5b51f2bf9a97e2c2571470fdb34e04
diff --git a/sys-apps/selinux-python/selinux-python-2.8-r1.ebuild b/sys-apps/selinux-python/selinux-python-2.8-r1.ebuild
new file mode 100644
index 000000000000..af8f4d4296f6
--- /dev/null
+++ b/sys-apps/selinux-python/selinux-python-2.8-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{3_5,3_6} )
+PYTHON_REQ_USE="xml"
+
+inherit python-r1 toolchain-funcs
+
+MY_P="${P//_/-}"
+
+MY_RELEASEDATE="20180524"
+SEPOL_VER="${PV}"
+SELNX_VER="${PV}"
+SEMNG_VER="${PV}"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DESCRIPTION="SELinux core utilities"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN#selinux-}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libselinux-${SELNX_VER}:=[python]
+ >=sys-libs/libsemanage-${SEMNG_VER}:=[python]
+ >=sys-libs/libsepol-${SEPOL_VER}:=
+ >=app-admin/setools-4.2.0[${PYTHON_USEDEP}]
+ dev-python/ipy[${PYTHON_USEDEP}]
+ !dev-python/sepolgen
+ ${PYTHON_DEPS}"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
+
+ python_copy_sources
+}
+
+src_compile() {
+ building() {
+ emake -C "${BUILD_DIR}" \
+ CC="$(tc-getCC)" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)"
+ }
+ python_foreach_impl building
+}
+
+src_install() {
+ installation() {
+ emake -C "${BUILD_DIR}" \
+ DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ install
+ python_optimize
+ }
+ python_foreach_impl installation
+
+ # Set version-specific scripts
+ for pyscript in audit2allow sepolgen-ifgen sepolicy chcat; do
+ python_replicate_script "${ED}/usr/bin/${pyscript}"
+ done
+ for pyscript in semanage; do
+ python_replicate_script "${ED}/usr/sbin/${pyscript}"
+ done
+
+ # Create sepolgen.conf with different devel location definition
+ if [[ -f /etc/selinux/config ]];
+ then
+ local selinuxtype=$(awk -F'=' '/^SELINUXTYPE/ {print $2}' /etc/selinux/config);
+ mkdir -p "${D}"/etc/selinux || die "Failed to create selinux directory";
+ echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
+ else
+ local selinuxtype="${POLICY_TYPES%% *}";
+ if [[ -n "${selinuxtype}" ]];
+ then
+ echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
+ else
+ echo "SELINUX_DEVEL_PATH=/usr/share/selinux/strict/include:/usr/share/selinux/strict" > "${D}"/etc/selinux/sepolgen.conf;
+ fi
+ fi
+}
diff --git a/sys-apps/selinux-python/selinux-python-9999.ebuild b/sys-apps/selinux-python/selinux-python-9999.ebuild
index 96a4fbaa8e14..af8f4d4296f6 100644
--- a/sys-apps/selinux-python/selinux-python-9999.ebuild
+++ b/sys-apps/selinux-python/selinux-python-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_COMPAT=( python{3_5,3_6} )
PYTHON_REQ_USE="xml"
inherit python-r1 toolchain-funcs
@@ -36,7 +36,7 @@ SLOT="0"
DEPEND=">=sys-libs/libselinux-${SELNX_VER}:=[python]
>=sys-libs/libsemanage-${SEMNG_VER}:=[python]
>=sys-libs/libsepol-${SEPOL_VER}:=
- >=app-admin/setools-4.1.1[${PYTHON_USEDEP}]
+ >=app-admin/setools-4.2.0[${PYTHON_USEDEP}]
dev-python/ipy[${PYTHON_USEDEP}]
!dev-python/sepolgen
${PYTHON_DEPS}"