summaryrefslogtreecommitdiff
path: root/sys-apps/selinux-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /sys-apps/selinux-python
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'sys-apps/selinux-python')
-rw-r--r--sys-apps/selinux-python/Manifest3
-rw-r--r--sys-apps/selinux-python/selinux-python-3.1-r2.ebuild93
-rw-r--r--sys-apps/selinux-python/selinux-python-9999.ebuild8
3 files changed, 98 insertions, 6 deletions
diff --git a/sys-apps/selinux-python/Manifest b/sys-apps/selinux-python/Manifest
index 46cd063ba698..2f1c7a27f0ce 100644
--- a/sys-apps/selinux-python/Manifest
+++ b/sys-apps/selinux-python/Manifest
@@ -1,4 +1,5 @@
DIST selinux-python-3.1.tar.gz 2100549 BLAKE2B c5d207bad60c379259e3bfc8f029f76d4572818cdd41a263498ed4434a70eaf7ff51af7772cfb27de0e9e4af03bcf9906ab0f6a59e88de10e81cbe0e8c5928b8 SHA512 5dd98f77ae8ea8bac6a89ec7def76e12496b9a9f8c9612c4cc1dac7a8e8c60380a00c857426bfefbcb4273706addd2594e9b467f69408ef284f082a09d45bd49
EBUILD selinux-python-3.1-r1.ebuild 2592 BLAKE2B 4e8887963e09d6138443885f7a52075206118bf5711e2ca1b4fbd3ce4251e3c7c7a2982d8ea263e45d9308211e6f614680870dad023465dd89d5c909a08a32f2 SHA512 da4d84af8e26af692c07b4009fdc7549c2fc13236dc7574d8967864976a83094ea877dde63591ad88a48c7be3391720ebfc8895476202fa39b7f29b73f5adea3
-EBUILD selinux-python-9999.ebuild 2594 BLAKE2B 253043520f734e82b27141c2e2d1088dbccb3ca016f35607ace5808f365498060400500172e7c5bd217168464f5fd14c09328ab3b19df47ad29ef74692aaa4eb SHA512 8814d31ee68f9bb1ca40b354b4f955982eff55f13a4f8022d433083cc9316e2fa3f32d799c8157e2a5573f6f083c3ef5c6794be8f812bafb6b5c803439bb4ce9
+EBUILD selinux-python-3.1-r2.ebuild 2545 BLAKE2B e9b6d9be2ef1d38cd1a096d3d959973e3b557fca3760eb51dbdd38b1d67d02c4e703c0506a603cab418e80c48e5c1b6afa8797511ea38456d09fa4bda75cfeee SHA512 df2f191dbfd26b1c642afffd6dbf22fd6f04f610fbb56f12606aeb534e39c7741b168aa2fcb47b713cfa18b4d583c286606cb015da43dda7b06ece6e2f2bed40
+EBUILD selinux-python-9999.ebuild 2545 BLAKE2B e9b6d9be2ef1d38cd1a096d3d959973e3b557fca3760eb51dbdd38b1d67d02c4e703c0506a603cab418e80c48e5c1b6afa8797511ea38456d09fa4bda75cfeee SHA512 df2f191dbfd26b1c642afffd6dbf22fd6f04f610fbb56f12606aeb534e39c7741b168aa2fcb47b713cfa18b4d583c286606cb015da43dda7b06ece6e2f2bed40
MISC metadata.xml 557 BLAKE2B 40a5075b9313be98cc5566696ebdf42dfa77814d2c5907832c06b8f846cb902023949bca3aa1b37a03a756649c6025f5f91357c0f6c73292b864396ea1c118cd SHA512 248d0177b4794bd342b35ce901f91a67227f1d8b256f6a56f06b3d424e94dbfb48b8500623bdccc2e0650402276cc1e50d1a7f475e2b04505ec0d4b4f2b590fe
diff --git a/sys-apps/selinux-python/selinux-python-3.1-r2.ebuild b/sys-apps/selinux-python/selinux-python-3.1-r2.ebuild
new file mode 100644
index 000000000000..b244747ca977
--- /dev/null
+++ b/sys-apps/selinux-python/selinux-python-3.1-r2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="xml"
+
+inherit python-r1 toolchain-funcs
+
+MY_P="${P//_/-}"
+
+MY_RELEASEDATE="20200710"
+SEPOL_VER="${PV}"
+SELNX_VER="${PV}"
+SEMNG_VER="${PV}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DESCRIPTION="SELinux core utilities"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN#selinux-}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libselinux-${SELNX_VER}:=[python]
+ >=sys-libs/libsemanage-${SEMNG_VER}:=[python(+)]
+ >=sys-libs/libsepol-${SEPOL_VER}:=
+ >=app-admin/setools-4.2.0[${PYTHON_USEDEP}]
+ >=sys-process/audit-1.5.1[python,${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
+
+ python_copy_sources
+}
+
+src_compile() {
+ building() {
+ emake -C "${BUILD_DIR}" \
+ CC="$(tc-getCC)" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)"
+ }
+ python_foreach_impl building
+}
+
+src_install() {
+ installation() {
+ emake -C "${BUILD_DIR}" \
+ DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ install
+ python_optimize
+ }
+ python_foreach_impl installation
+
+ # Set version-specific scripts
+ for pyscript in audit2allow sepolgen-ifgen sepolicy chcat; do
+ python_replicate_script "${ED}/usr/bin/${pyscript}"
+ done
+ for pyscript in semanage; do
+ python_replicate_script "${ED}/usr/sbin/${pyscript}"
+ done
+
+ # Create sepolgen.conf with different devel location definition
+ if [[ -f /etc/selinux/config ]];
+ then
+ local selinuxtype=$(awk -F'=' '/^SELINUXTYPE/ {print $2}' /etc/selinux/config);
+ mkdir -p "${D}"/etc/selinux || die "Failed to create selinux directory";
+ echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
+ else
+ local selinuxtype="${POLICY_TYPES%% *}";
+ if [[ -n "${selinuxtype}" ]];
+ then
+ echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
+ else
+ echo "SELINUX_DEVEL_PATH=/usr/share/selinux/strict/include:/usr/share/selinux/strict" > "${D}"/etc/selinux/sepolgen.conf;
+ fi
+ fi
+}
diff --git a/sys-apps/selinux-python/selinux-python-9999.ebuild b/sys-apps/selinux-python/selinux-python-9999.ebuild
index e3fe4738a86b..b244747ca977 100644
--- a/sys-apps/selinux-python/selinux-python-9999.ebuild
+++ b/sys-apps/selinux-python/selinux-python-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
PYTHON_REQ_USE="xml"
inherit python-r1 toolchain-funcs
@@ -14,7 +14,6 @@ SEPOL_VER="${PV}"
SELNX_VER="${PV}"
SEMNG_VER="${PV}"
-IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DESCRIPTION="SELinux core utilities"
@@ -37,7 +36,6 @@ DEPEND=">=sys-libs/libselinux-${SELNX_VER}:=[python]
>=sys-libs/libsemanage-${SEMNG_VER}:=[python(+)]
>=sys-libs/libsepol-${SEPOL_VER}:=
>=app-admin/setools-4.2.0[${PYTHON_USEDEP}]
- dev-python/ipy[${PYTHON_USEDEP}]
>=sys-process/audit-1.5.1[python,${PYTHON_USEDEP}]
${PYTHON_DEPS}"