summaryrefslogtreecommitdiff
path: root/sys-apps/selinux-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-17 02:06:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-17 02:06:03 +0000
commit20c23c152d2e7b44a6f93ec9476b808659e5ff1e (patch)
tree06b81787dda2fd1bc47b3967309795f95ddb7b3d /sys-apps/selinux-python
parent03aa42efc090f9ed79ad5d8cbb54789052863450 (diff)
gentoo auto-resync : 17:01:2024 - 02:06:03
Diffstat (limited to 'sys-apps/selinux-python')
-rw-r--r--sys-apps/selinux-python/Manifest4
-rw-r--r--sys-apps/selinux-python/selinux-python-3.6.ebuild114
-rw-r--r--sys-apps/selinux-python/selinux-python-9999.ebuild4
3 files changed, 119 insertions, 3 deletions
diff --git a/sys-apps/selinux-python/Manifest b/sys-apps/selinux-python/Manifest
index 73a77643f420..d15f2e7f4b64 100644
--- a/sys-apps/selinux-python/Manifest
+++ b/sys-apps/selinux-python/Manifest
@@ -1,4 +1,6 @@
DIST selinux-python-3.5.tar.gz 3604439 BLAKE2B 5a7fcd303c337cb0f5ae0066d13c945bb5cacaba472c7b17f0496295294998fcc6d81c153720ef704b749a01590c28b48b4f471a48fc386b8f02564c3550250b SHA512 2ac176a9f078f2b2721e5871ba21e92041eed54fc692fd8d809ff14327beee6de63b3084d0f1053a640b9e40bcc6461498915bb9b038a658cd772f77d80fd217
+DIST selinux-python-3.6.tar.gz 3633272 BLAKE2B c2b99779eda2c7698f7f68740e3136cbfa5ab471a5d154142aafd2694d8c32aa605df3609a3667c687449d3ba44e72bcc3b37c36adecba8e34fcc629b9f04de5 SHA512 6289f3f2a3038b2cb62f6b3b12c729a9981c34a5ee80c0830e6316e8c77f5283dffa46007f6e7dc073332b829ed9953ba54e64c986fb18c7dc40759ec0375dc9
EBUILD selinux-python-3.5.ebuild 3162 BLAKE2B 0273b02c35abae8d4aa5798b71398f9c949640fe09a2f40ab3347662cb5d12b979bd700ea6841eb6fa3dbdfdbcdcbdd9040840dfead606d24c51a388429981a6 SHA512 346c103082f36ba32ec65831109236df893bf7c9debec153c8a2ce604533a79bfcbb5d9f73d4dffa0366651df32b3c8080b0ed7d1ec4d972f928a0dbbdec32c8
-EBUILD selinux-python-9999.ebuild 3166 BLAKE2B cfa0a61e9b8c3da3c6ae9252a742b0ab199e7ce015e37426e36574837b2370971e913bd7c64629accc06c26fc49ced92fc67c33943c76ba201ffacfba0ef4339 SHA512 7a7094de4756093fc5624398c95faf85c90493282b75dfe8189a15772bce365cbd04bd3e7f09e71645a2439e35ebb803359b4f8f752cace6b81b532f3de4c9f7
+EBUILD selinux-python-3.6.ebuild 3167 BLAKE2B e3e65bf739532fb11ebf30cf445a28a3f949c56887f08c4fce9b8150e8cbeb7fc46cdb44017694f86355ebcf63e83cf5c6125f74357aba82fd6bb26267e8b623 SHA512 d3b837e4ed9b3ba280227a64d9d40c217d41d9263e4c172eefeb27c3945ab25a249a4aaf3dc51dfcd59d5f596780b6b75b84373a37e155e83fcdf11511474aaf
+EBUILD selinux-python-9999.ebuild 3167 BLAKE2B e3e65bf739532fb11ebf30cf445a28a3f949c56887f08c4fce9b8150e8cbeb7fc46cdb44017694f86355ebcf63e83cf5c6125f74357aba82fd6bb26267e8b623 SHA512 d3b837e4ed9b3ba280227a64d9d40c217d41d9263e4c172eefeb27c3945ab25a249a4aaf3dc51dfcd59d5f596780b6b75b84373a37e155e83fcdf11511474aaf
MISC metadata.xml 558 BLAKE2B 6fba5f27d19e5ea730bd1bfb9b63c536a86f0b47c7156388df9e9af9bda8856c8e4291bf822b469afb333638504d75f64215ef86f3bf65b68812a829b0e94f38 SHA512 df8eaff3f7e69d8d0f437d29dc38b654b81a5769c32e8c0fb98aeb83cf18a1598845d03d177b1837a6b0b628a34c524a52fae5672b7c186a6a8567f349b25304
diff --git a/sys-apps/selinux-python/selinux-python-3.6.ebuild b/sys-apps/selinux-python/selinux-python-3.6.ebuild
new file mode 100644
index 000000000000..20a1fea452bf
--- /dev/null
+++ b/sys-apps/selinux-python/selinux-python-3.6.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit python-r1 toolchain-funcs
+
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="SELinux core utilities"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN#selinux-}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND=">=sys-libs/libselinux-${PV}:=[python]
+ >=sys-libs/libsemanage-${PV}:=[python(+)]
+ >=sys-libs/libsepol-${PV}:=
+ >=app-admin/setools-4.2.0[${PYTHON_USEDEP}]
+ >=sys-process/audit-1.5.1[python,${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ >=sys-apps/secilc-${PV}
+ )"
+
+src_prepare() {
+ default
+ sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
+
+ python_copy_sources
+}
+
+src_compile() {
+ building() {
+ emake -C "${BUILD_DIR}" \
+ CC="$(tc-getCC)" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)"
+ }
+ python_foreach_impl building
+}
+
+src_test() {
+ testing() {
+ # The different subprojects have some interproject dependencies:
+ # - audit2allow depens on sepolgen
+ # - chcat depends on semanage
+ # and maybe others.
+ # Add all the modules of the individual subprojects to the
+ # PYTHONPATH, so they get actually found and used. In
+ # particular, already installed versions on the system are not
+ # used.
+ for dir in audit2allow chcat semanage sepolgen/src sepolicy ; do
+ PYTHONPATH="${BUILD_DIR}/${dir}:${PYTHONPATH}"
+ done
+ PYTHONPATH=${PYTHONPATH} \
+ emake -C "${BUILD_DIR}" \
+ test
+ }
+ python_foreach_impl testing
+}
+
+src_install() {
+ installation() {
+ emake -C "${BUILD_DIR}" \
+ DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ install
+ python_optimize
+ }
+ python_foreach_impl installation
+
+ # Set version-specific scripts
+ for pyscript in audit2allow sepolgen-ifgen sepolicy chcat; do
+ python_replicate_script "${ED}/usr/bin/${pyscript}"
+ done
+ for pyscript in semanage; do
+ python_replicate_script "${ED}/usr/sbin/${pyscript}"
+ done
+
+ # Create sepolgen.conf with different devel location definition
+ if [[ -f /etc/selinux/config ]];
+ then
+ local selinuxtype=$(awk -F'=' '/^SELINUXTYPE/ {print $2}' /etc/selinux/config);
+ mkdir -p "${D}"/etc/selinux || die "Failed to create selinux directory";
+ echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
+ else
+ local selinuxtype="${POLICY_TYPES%% *}";
+ if [[ -n "${selinuxtype}" ]];
+ then
+ echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
+ else
+ echo "SELINUX_DEVEL_PATH=/usr/share/selinux/strict/include:/usr/share/selinux/strict" > "${D}"/etc/selinux/sepolgen.conf;
+ fi
+ fi
+}
diff --git a/sys-apps/selinux-python/selinux-python-9999.ebuild b/sys-apps/selinux-python/selinux-python-9999.ebuild
index 470211f8d553..20a1fea452bf 100644
--- a/sys-apps/selinux-python/selinux-python-9999.ebuild
+++ b/sys-apps/selinux-python/selinux-python-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="xml(+)"
inherit python-r1 toolchain-funcs