summaryrefslogtreecommitdiff
path: root/sys-apps/sed/sed-4.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /sys-apps/sed/sed-4.7.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'sys-apps/sed/sed-4.7.ebuild')
-rw-r--r--sys-apps/sed/sed-4.7.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/sys-apps/sed/sed-4.7.ebuild b/sys-apps/sed/sed-4.7.ebuild
deleted file mode 100644
index c319f8bf409a..000000000000
--- a/sys-apps/sed/sed-4.7.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic
-
-DESCRIPTION="Super-useful stream editor"
-HOMEPAGE="http://sed.sourceforge.net/"
-SRC_URI="mirror://gnu/sed/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="acl nls selinux static"
-
-RDEPEND="
- !static? (
- acl? ( virtual/acl )
- nls? ( virtual/libintl )
- selinux? ( sys-libs/libselinux )
- )
-"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- static? (
- acl? ( virtual/acl[static-libs(+)] )
- nls? ( virtual/libintl[static-libs(+)] )
- selinux? ( sys-libs/libselinux[static-libs(+)] )
- )
-"
-
-src_configure() {
- local myconf=()
- if use userland_GNU; then
- myconf+=( --exec-prefix="${EPREFIX}" )
- else
- myconf+=( --program-prefix=g )
- fi
-
- export ac_cv_search_setfilecon=$(usex selinux -lselinux)
- export ac_cv_header_selinux_{context,selinux}_h=$(usex selinux)
- use static && append-ldflags -static
- myconf+=(
- $(use_enable acl)
- $(use_enable nls)
- )
- econf "${myconf[@]}"
-}