summaryrefslogtreecommitdiff
path: root/sys-apps/sed/sed-4.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /sys-apps/sed/sed-4.5.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'sys-apps/sed/sed-4.5.ebuild')
-rw-r--r--sys-apps/sed/sed-4.5.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/sys-apps/sed/sed-4.5.ebuild b/sys-apps/sed/sed-4.5.ebuild
deleted file mode 100644
index 773b7b0567cb..000000000000
--- a/sys-apps/sed/sed-4.5.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Super-useful stream editor"
-HOMEPAGE="http://sed.sourceforge.net/"
-SRC_URI="mirror://gnu/sed/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 m68k ~mips ppc ppc64 ~riscv s390 sparc x86"
-IUSE="acl nls selinux static"
-
-RDEPEND="
- !static? (
- acl? ( virtual/acl )
- nls? ( virtual/libintl )
- selinux? ( sys-libs/libselinux )
- )
-"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- static? (
- acl? ( virtual/acl[static-libs(+)] )
- nls? ( virtual/libintl[static-libs(+)] )
- selinux? ( sys-libs/libselinux[static-libs(+)] )
- )
-"
-
-src_configure() {
- local myconf=()
- if use userland_GNU; then
- myconf+=( --exec-prefix="${EPREFIX}" )
- else
- myconf+=( --program-prefix=g )
- fi
-
- export ac_cv_search_setfilecon=$(usex selinux -lselinux)
- export ac_cv_header_selinux_{context,selinux}_h=$(usex selinux)
- use static && append-ldflags -static
- myconf+=(
- $(use_enable acl)
- $(use_enable nls)
- )
- econf "${myconf[@]}"
-}