summaryrefslogtreecommitdiff
path: root/sys-apps/sandbox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /sys-apps/sandbox
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'sys-apps/sandbox')
-rw-r--r--sys-apps/sandbox/Manifest2
-rw-r--r--sys-apps/sandbox/sandbox-2.21.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/sys-apps/sandbox/Manifest b/sys-apps/sandbox/Manifest
index fcb2ab89bda0..1a223882db1f 100644
--- a/sys-apps/sandbox/Manifest
+++ b/sys-apps/sandbox/Manifest
@@ -1,4 +1,6 @@
AUX 09sandbox 37 BLAKE2B 181213e2cc0bcfa328310cced40bfaba4530d8d2f80e892cb5649d5277c5d59d345ce96ca802a5529a22892c929bafac04c616458fa147a3bee5c89d31b0baf1 SHA512 4e8a9c58debde6480224a45559c5f2db4765213d151e47937f9142f110cac3681bf6402acaf21249a37bb17398e7bc00ae7feee68ecdb5b9363c432eac1b052a
DIST sandbox-2.20.tar.xz 428400 BLAKE2B 11761631ce8e2e495adb41508f308bce875d416ec978e3eb3cb491d3d3a464d7653b8b81d4dcc7e5cd31e8a55069aafa263b85008651ee1d7318f32407fa4615 SHA512 06db36fc85bacf9a3a094c434b73277d8cdde986f2fad7676c42e8f84b3b8b653a1f4b1ec4af9fa1ff5484177419e18f5621275f56a8fbf3973ece524dd6d208
+DIST sandbox-2.21.tar.xz 434540 BLAKE2B c9af3b44e65d96d20b98996a4b9e35cccf6b62020d49522b9fcf50b097d4ffe3719bb334405226c5ee650943bced365547a5d8b0f707ed26ef5f12a4d15dadba SHA512 42b85e230bc89d0e02f22a7ee81b4efbb2c37ff9db24982b4b39487664a095d384101b16a4689863bd32ea91349347980b1c7f8eecb09225bc65619829c6a5b2
EBUILD sandbox-2.20.ebuild 1883 BLAKE2B eeb4c37d3397fca51ef4f89c3f4d89443291f6385e4ace9cda138dcadeb2ea019dda8d255aa05ffdd20f5f6e535009d6caa78f7fc78cd5b1bca2f2de2cc9f57b SHA512 0524497f51519aa3404f5426f2d77dba1beb1714455d31514ac0c07bf99541ed0ea0664466683a4b65bc82615fa5c1656ec21fbc7f0742c780957622d6e45642
+EBUILD sandbox-2.21.ebuild 1892 BLAKE2B 908d3c4e1f87c2dbd01b2c5a745756fbca721be5764957016049241f9e57be4b89ab5375570fec98b71862c21c6fdfe7e97f3d281497d656df884e9e0ebc93fa SHA512 6e102f8b0e1c84d88f660ae2365077ebb0ade4ec38dc176ade00ccb10a1c18abfd1d62ad351f83acca8e42851c2e51f20c9e441bee1635eab45adf5010ef74e3
MISC metadata.xml 252 BLAKE2B d709f9b334b2810c5ffe7d73ef430f0f347f26f7649bca4bb8803c8e0be106534bcee6efae4f80b6fb1781b09284bb3dbc32d8dff4a3aa01a924fd3437b9da7c SHA512 de8b6a78dcc379d1d34960caecdab8da9fdb9a9f010ec8611cab79487b5f28f6ae80c8b0884731fa91c4ae98482a195faa8d1ec911b1d95fafdfe9cd622cc5d9
diff --git a/sys-apps/sandbox/sandbox-2.21.ebuild b/sys-apps/sandbox/sandbox-2.21.ebuild
new file mode 100644
index 000000000000..0caadf280c6f
--- /dev/null
+++ b/sys-apps/sandbox/sandbox-2.21.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic multilib-minimal multiprocessing
+
+DESCRIPTION="sandbox'd LD_PRELOAD hack"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Sandbox"
+SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND="app-arch/xz-utils
+ >=app-misc/pax-utils-0.1.19" #265376
+RDEPEND=""
+
+has sandbox_death_notice ${EBUILD_DEATH_HOOKS} || EBUILD_DEATH_HOOKS="${EBUILD_DEATH_HOOKS} sandbox_death_notice"
+
+sandbox_death_notice() {
+ ewarn "If configure failed with a 'cannot run C compiled programs' error, try this:"
+ ewarn "FEATURES='-sandbox -usersandbox' emerge sandbox"
+}
+
+multilib_src_configure() {
+ filter-lfs-flags #90228
+
+ ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_test() {
+ # Default sandbox build will run with --jobs set to # cpus.
+ emake -j1 check TESTSUITEFLAGS="--jobs=$(makeopts_jobs)"
+}
+
+multilib_src_install_all() {
+ doenvd "${FILESDIR}"/09sandbox
+
+ keepdir /var/log/sandbox
+ fowners root:portage /var/log/sandbox
+ fperms 0770 /var/log/sandbox
+
+ dodoc AUTHORS ChangeLog* NEWS README
+}
+
+pkg_preinst() {
+ chown root:portage "${ED}"/var/log/sandbox
+ chmod 0770 "${ED}"/var/log/sandbox
+
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ # 1.x was removed from ::gentoo in 2016
+ if [[ ${v} == 1.* ]] ; then
+ local old=$(find "${EROOT}"/lib* -maxdepth 1 -name 'libsandbox*')
+ if [[ -n ${old} ]] ; then
+ elog "Removing old sandbox libraries for you:"
+ find "${EROOT}"/lib* -maxdepth 1 -name 'libsandbox*' -print -delete
+ fi
+ fi
+ done
+}
+
+pkg_postinst() {
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ # 1.x was removed from ::gentoo in 2016
+ if [[ ${v} == 1.* ]] ; then
+ chmod 0755 "${EROOT}"/etc/sandbox.d #265376
+ fi
+ done
+}