summaryrefslogtreecommitdiff
path: root/sys-apps/roccat-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /sys-apps/roccat-tools
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'sys-apps/roccat-tools')
-rw-r--r--sys-apps/roccat-tools/Manifest2
-rw-r--r--sys-apps/roccat-tools/roccat-tools-5.9.0.ebuild29
2 files changed, 16 insertions, 15 deletions
diff --git a/sys-apps/roccat-tools/Manifest b/sys-apps/roccat-tools/Manifest
index ed45039daa09..00d0b060c1a6 100644
--- a/sys-apps/roccat-tools/Manifest
+++ b/sys-apps/roccat-tools/Manifest
@@ -2,5 +2,5 @@ AUX README.gentoo 858 BLAKE2B d3cdc925b286481491fdad08de6c2a61c811fecb1eb36fa1e0
DIST roccat-tools-5.7.0.tar.bz2 3737735 BLAKE2B fdd86cef425f1f33309165673be52c8297380a1f0a722e827c2b3697c59dd787f4b473186ab5b8ff8fadcfc851f3bb5e76c8407d831b31f82cd360679d3c1a09 SHA512 209f9fa5302806a2d2681077e990a39a4913d47b82e73f9acd86f734affd8b3a7c0087e815e5cc1dfec1787d868d09b87211d9c2a90f2ced67c150eec1b2d290
DIST roccat-tools-5.9.0.tar.bz2 3736671 BLAKE2B 4cdd0c6b50021cfae127a692d5a2a7fff5e7e1281da7add0cf9cd8f5fbfd8882186142d56982bf929867bde2950440f26ced167b52707c9d810ab53a62a4bded SHA512 d825fc372654257f330abbc7e611e87c4888924288ad56c8e57c9db5c8c25426d454ae1ab4dd591ef3b930bed410497c0aa88095d5319e2708f4b263d16eca00
EBUILD roccat-tools-5.7.0.ebuild 2442 BLAKE2B ab3f4152fd8ff6f0575a5aa9a109e79044a2abc93315d6e93f07daa789a5bc15739218eafcaadc46258274951e688aa0252ca94c182868323f1822ebad5e9dba SHA512 b8cb3fdf8e5a28012155c324a9110a0ed8558be43795335da1ef57001119c104d26c12ff68e562502d481e46eccbba8b4000eeca35dc43ea7de634077c6fa28c
-EBUILD roccat-tools-5.9.0.ebuild 2743 BLAKE2B a51e580dbc48d7b054d973522113e3cba58d6059b4c7a84320ce57b2c6faccb1898af4b20b87daee54500ed88f72cf303d17c132d2f2824af617ceee050ae9ae SHA512 e24d6df50393cf536a82895d041c476ff268817e61364dc42cf5cd4f73d12ec01f6228325d9131629ff7f31993b1ca24a397cac74d8cf4f3cf4f874cdeb4cef2
+EBUILD roccat-tools-5.9.0.ebuild 2900 BLAKE2B f39932a29c8565de43dc20c6317c1b279d27425d0d0bea521e68b90eb94b4f42a1a2779c07939f95f9d2dede21fe0d2952a78dba2dfec393064679c13da1ccec SHA512 25a2cdc3ffe014c3db690a1de4ca33796fa67108747b84d55bd0488725e1097ab811c772912cec4751b7319d7a9363dde862d238189e023a2a18b44c899a22dc
MISC metadata.xml 327 BLAKE2B b3a42ce918857aaa3ebe1705560661d80d9dc1cce60b5d79bddc1ead356cced572fe18d8b8d18f6c8f2ebb80393cc02efc4df3ad711aca08a67a15a1abd93e60 SHA512 99ed72c1a2a183157d0aded6f95c41c81c9c3d97f81c7267743ad3431676e2af1d7e08e4904761583af17806f5befd7254ca9f2ad170266d038053c7076a630e
diff --git a/sys-apps/roccat-tools/roccat-tools-5.9.0.ebuild b/sys-apps/roccat-tools/roccat-tools-5.9.0.ebuild
index db2565cfe822..3cc91e932e03 100644
--- a/sys-apps/roccat-tools/roccat-tools-5.9.0.ebuild
+++ b/sys-apps/roccat-tools/roccat-tools-5.9.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit readme.gentoo-r1 cmake-utils udev user xdg
+inherit readme.gentoo-r1 cmake flag-o-matic toolchain-funcs udev user xdg
DESCRIPTION="Utility for advanced configuration of Roccat devices"
@@ -62,6 +62,9 @@ RDEPEND="
DEPEND="
${RDEPEND}
"
+BDEPEND="
+ virtual/pkgconfig
+"
DOCS=( Changelog KNOWN_LIMITATIONS README )
@@ -74,12 +77,18 @@ pkg_setup() {
done
}
-# Required because xdg.eclass overrides src_prepare() from cmake-utils.eclass
+# Required because xdg.eclass overrides src_prepare() from cmake.eclass
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
+ if has_version \>=x11-libs/pango-1.44.0 ; then
+ # Fix build with pango-1.44 which depends on harfbuzz
+ local PKGCONF="$(tc-getPKG_CONFIG)"
+ append-cflags "$(${PKGCONF} --cflags harfbuzz)"
+ fi
+
mycmakeargs=(
-DDEVICES="${USED_MODELS/;/}"
-DUDEVDIR="${EPREFIX}$(get_udevdir)/rules.d"
@@ -98,11 +107,11 @@ src_configure() {
fi
done
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
local stat_dir=/var/lib/roccat
keepdir ${stat_dir}
fowners root:roccat ${stat_dir}
@@ -110,10 +119,6 @@ src_install() {
readme.gentoo_create_doc
}
-pkg_preinst() {
- xdg_pkg_preinst
-}
-
pkg_postinst() {
xdg_pkg_postinst
readme.gentoo_print_elog
@@ -122,7 +127,3 @@ pkg_postinst() {
ewarn "affected folder(s) in /var/lib/roccat"
ewarn
}
-
-pkg_postrm() {
- xdg_pkg_postrm
-}