summaryrefslogtreecommitdiff
path: root/sys-apps/ripgrep
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /sys-apps/ripgrep
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'sys-apps/ripgrep')
-rw-r--r--sys-apps/ripgrep/Manifest2
-rw-r--r--sys-apps/ripgrep/ripgrep-0.10.0-r1.ebuild17
2 files changed, 5 insertions, 14 deletions
diff --git a/sys-apps/ripgrep/Manifest b/sys-apps/ripgrep/Manifest
index 5fab615fcbc8..32ecd4387c49 100644
--- a/sys-apps/ripgrep/Manifest
+++ b/sys-apps/ripgrep/Manifest
@@ -84,5 +84,5 @@ DIST winapi-i686-pc-windows-gnu-0.4.0.crate 2918815 BLAKE2B 4d357e4d30f955297217
DIST winapi-util-0.1.1.crate 7635 BLAKE2B 2a8047d0da762379f8e66578bf95309a7968d52b636a7bb57d98ce827edffcf85b20cf0441487f4fcd91dccc6db9d005a4c3d78140f0d85dcc99534f3b7aacd4 SHA512 003244d94a887d870b8eab7569f6aee432350eb9f13b5b90a0836eb105b05ac83b7835efe90d9915437f295730653b2dafe6251ab9c46011f1d8492fd4ab8a06
DIST winapi-x86_64-pc-windows-gnu-0.4.0.crate 2947998 BLAKE2B 2ad1ea8b5fa07d544e910ccba043ae925269b76b26c9da356305b34b86741dd8b9aff0b9ffe3d562db4fcd7d7c46a11ce9e3168b782b1d89ae6881742b7ede82 SHA512 4a654af6a5d649dc87e00497245096b35a2894ae66f155cb62389902c3b93ddcc5cf7d0d8b9dd97b291d2d80bc686af2298e80abef6ac69883f4a54e79712513
DIST wincolor-1.0.1.crate 4737 BLAKE2B b1519327a69d71845bc4d7ebf34205d63883aacbeb9284260e5cc89178193aac15525641546582e32c00128ca4a7c1967ba8f076fbfa98bf9d79a5fe2801555e SHA512 f9914b8b416f3810f5199e85b8088c669bff3cbc0f5b86fdb5b600bbd0554465a559bae3ac918fb7197780663e94bf645ede8f35b60ab0e6a6cf2305b1eb99e1
-EBUILD ripgrep-0.10.0-r1.ebuild 2941 BLAKE2B bc5e83e58efdadd420492f75bbc1e28605522a56ba6cb063d3f4c9662ca0ed637c9b8387af8a67ba9956e0462a37cb006ac02a8dd9b14c4fa28b855b7bf84141 SHA512 dc0f82b95e98969f6b909b8395baddfa9c94d32b45b35f82e103652e677f11921170d4a8f23fa3bb64fccb9b87733a72951cabb2db286c2de18598639e8a42f7
+EBUILD ripgrep-0.10.0-r1.ebuild 2686 BLAKE2B 7cff043b4373e613590c097862603c36144a70de30aa96d79eb98c2917cd3da875b999461bf03b4ba403a43fa8e19d2406ec6c99ada2e364d0eedff3b4c69e09 SHA512 b5d2f7284248626d2eab0f9124db37d20127ad7b045fa9fd20b8ac7606e88bae136e3cd8fff3e5470261dbc909f3cf6309d94ed1bf33f2d92519a32910ce3da3
MISC metadata.xml 837 BLAKE2B c7f5f0c13fdb6d695a24724c84105b873fb2674212896bf2184a9ceef2efe2fe98a17a6f98284eaa0776457ca18729a184eeb22d31214f0f77e30bca99f26352 SHA512 b45056a97c83bd9ddd5d49f94d5f5b1d3c00c53fe14263be8eff908b14a5635f9ff5151344ac7d8b656d9c62937b0d63f3a3a228ad3256da14fc7bae8981a934
diff --git a/sys-apps/ripgrep/ripgrep-0.10.0-r1.ebuild b/sys-apps/ripgrep/ripgrep-0.10.0-r1.ebuild
index f5c384a3c895..f7eda9ddd13b 100644
--- a/sys-apps/ripgrep/ripgrep-0.10.0-r1.ebuild
+++ b/sys-apps/ripgrep/ripgrep-0.10.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -116,25 +116,16 @@ src_test() {
}
src_compile() {
- export CARGO_HOME="${ECARGO_HOME}"
- cargo build -j $(makeopts_jobs) \
- $(usex debug "" --release) \
- $(usex pcre "--features pcre2" "") \
- || die "cargo build failed"
+ cargo_src_compile $(usex pcre "--features pcre2" "")
}
src_install() {
- cargo install -j $(makeopts_jobs) --root="${D}/usr" \
- $(usex debug --debug "") \
- $(usex pcre "--features pcre2" "") \
- || die "cargo install failed"
-
- rm -f "${D}/usr/.crates.toml" || die
+ cargo_src_install $(usex pcre "--features pcre2" "")
# hack to find/install generated files
# stamp file can be present in multiple dirs if we build additional features
# so grab fist match only
- local BUILD_DIR=$(dirname $(find target/release -name ripgrep-stamp -print -quit))
+ local BUILD_DIR="$(dirname $(find target/release -name ripgrep-stamp -print -quit))"
if use man ; then
doman "${BUILD_DIR}"/rg.1