summaryrefslogtreecommitdiff
path: root/sys-apps/restorecond
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/restorecond
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/restorecond')
-rw-r--r--sys-apps/restorecond/Manifest5
-rwxr-xr-xsys-apps/restorecond/files/restorecond.init30
-rw-r--r--sys-apps/restorecond/metadata.xml14
-rw-r--r--sys-apps/restorecond/restorecond-2.7.ebuild57
-rw-r--r--sys-apps/restorecond/restorecond-9999.ebuild57
5 files changed, 163 insertions, 0 deletions
diff --git a/sys-apps/restorecond/Manifest b/sys-apps/restorecond/Manifest
new file mode 100644
index 000000000000..0cd5d77f0413
--- /dev/null
+++ b/sys-apps/restorecond/Manifest
@@ -0,0 +1,5 @@
+AUX restorecond.init 650 SHA256 ecf64c87bb71852c42504f504764171d33ed10327f4005b6098fcfb00318fcba SHA512 ee0ff9bfe542124eff0217dbf9cc2e00586b4577e0eee2bfa67946f78a97fe009c6e5c337e8ad68e1cd9af2f69ec3ce3acba9157b4d53c2fdeeb01f9e0aa9d0a WHIRLPOOL 74cadd908737c58c384ba67b04f94c634c73800b2774a8caad6455951def8880a251b9ef75cd0c56967f22831c9b24297b7c4c53c584e552dac2d2587b4302f1
+DIST restorecond-2.7.tar.gz 17753 SHA256 cb8e0a8d706cb2c1f105125f3514dffffefcbcfb49199183a7f91ab0bdf1f24d SHA512 c81950e4f748a729c8951b13a4075ab1003530f8ada7a9d3fbe6428f76070df4819a37daaab557b63fc234aa8c8320ec41757fbdb24b76fa2c11747bde0038ad WHIRLPOOL 54ab5aec56100d459aecf2018326942498ee63236ccf9edcce33c8dbfd100a54c278ef895421b098ef4e2106fb777f116e7eab023491b7d26f9263090af3b6db
+EBUILD restorecond-2.7.ebuild 1230 SHA256 1dd287a84924470995963236346f661eaafc761d013f484d904106e4f55f2e31 SHA512 bac8e86d00ac5c116aa877938f69427a1fa5ce7758594db6400722d953e5ea3fd000f0c4520364a7390cb0e6cd91ba737487b747aea25a38358fbb9c7e8a38eb WHIRLPOOL f6ba9f2272239310141ec7c71f8bd4a7a77ed68eca6a153c98fd3d05ca49e49266ba7976ceeaeee9aa9d9b29725344eb2b51308c517667d40301f7b8c77ef536
+EBUILD restorecond-9999.ebuild 1232 SHA256 60759938fb135f16328c73c1befad49cca4c684df1a818955eca41b18adb5fc0 SHA512 0c51444d0c278aee93a8da5f35a122d6d9c0849eb1d78f1b347f91f5399e87e11d8cc40b141e1295d5a0df406921e21f16264fb63fb50fa488463a01b057b74e WHIRLPOOL a5fdd8a4a33455f39bc99c7e5548efe9a8b1b4af02f803ea1d98a0297f5518bda82072fb2487f25ecb3e742bd1ff0e96b9222040f0bdf0d89e529cc400f8ff22
+MISC metadata.xml 460 SHA256 6be09b1b665718a7177c8d3941ded31fe51ccc67ff29746a303bc2ec939cc0e6 SHA512 0e4910de5e3932eb2914ddf4ef3250ae919885428337b1939f6827037a4dc5a75b13c97531c7b81748b1c90e3eb2b10a4671c76ede69749dbd1955bc67b5ca0a WHIRLPOOL 932fd71c39bedb2b5f00a66bd6de2708ef473e5ad2573c72ff832d19047714e42c15fc8c77baf4098c40ba91821a4603a2cae4f0c81a600d362217d9a195045c
diff --git a/sys-apps/restorecond/files/restorecond.init b/sys-apps/restorecond/files/restorecond.init
new file mode 100755
index 000000000000..709f1d1b9ece
--- /dev/null
+++ b/sys-apps/restorecond/files/restorecond.init
@@ -0,0 +1,30 @@
+#!/sbin/openrc-run
+# Copyright 2006-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+is_selinux_enabled() {
+ local SE_ENABL="/usr/sbin/selinuxenabled"
+
+ if [ -x "$SE_ENABL" ]; then
+ $SE_ENABL && return 0 || return 1
+ else
+ ewarn "Restorecond: Unable to determine SELinux status"
+ return 1
+ fi
+}
+
+start() {
+ if is_selinux_enabled; then
+ ebegin "Starting restorecond"
+ start-stop-daemon --start --quiet --exec /usr/sbin/restorecond
+ eend $?
+ fi
+}
+
+stop() {
+ if is_selinux_enabled; then
+ ebegin "Stopping restorecond"
+ start-stop-daemon --stop --quiet --pidfile /var/run/restorecond.pid
+ eend $?
+ fi
+}
diff --git a/sys-apps/restorecond/metadata.xml b/sys-apps/restorecond/metadata.xml
new file mode 100644
index 000000000000..bad7d3fa425c
--- /dev/null
+++ b/sys-apps/restorecond/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>selinux@gentoo.org</email>
+ <name>SELinux Team</name>
+ </maintainer>
+ <longdescription>
+ daemon that watches for file creation and then sets the default SELinux file context
+ </longdescription>
+ <upstream>
+ <remote-id type="github">SELinuxProject/selinux</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/restorecond/restorecond-2.7.ebuild b/sys-apps/restorecond/restorecond-2.7.ebuild
new file mode 100644
index 000000000000..a63282f7029d
--- /dev/null
+++ b/sys-apps/restorecond/restorecond-2.7.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+MY_RELEASEDATE="20170804"
+
+MY_P="${P//_/-}"
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="amd64 ~arm ~arm64 ~mips x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Daemon to watch for creation and set default SELinux fcontexts"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${PV}:=
+ >=sys-libs/libselinux-${PV}:=
+ dev-libs/libpcre:=
+ >=sys-libs/libcap-1.10-r10:="
+
+RDEPEND="${DEPEND}
+ !<sys-apps/policycoreutils-2.7_pre"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ install
+
+ rm -rf "${D}/etc/rc.d" || die
+
+ newinitd "${FILESDIR}/restorecond.init" restorecond
+}
diff --git a/sys-apps/restorecond/restorecond-9999.ebuild b/sys-apps/restorecond/restorecond-9999.ebuild
new file mode 100644
index 000000000000..3d679bcf4c7e
--- /dev/null
+++ b/sys-apps/restorecond/restorecond-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+MY_RELEASEDATE="20170804"
+
+MY_P="${P//_/-}"
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Daemon to watch for creation and set default SELinux fcontexts"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${PV}:=
+ >=sys-libs/libselinux-${PV}:=
+ dev-libs/libpcre:=
+ >=sys-libs/libcap-1.10-r10:="
+
+RDEPEND="${DEPEND}
+ !<sys-apps/policycoreutils-2.7_pre"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ install
+
+ rm -rf "${D}/etc/rc.d" || die
+
+ newinitd "${FILESDIR}/restorecond.init" restorecond
+}