summaryrefslogtreecommitdiff
path: root/sys-apps/restorecond
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-17 02:06:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-17 02:06:03 +0000
commit20c23c152d2e7b44a6f93ec9476b808659e5ff1e (patch)
tree06b81787dda2fd1bc47b3967309795f95ddb7b3d /sys-apps/restorecond
parent03aa42efc090f9ed79ad5d8cbb54789052863450 (diff)
gentoo auto-resync : 17:01:2024 - 02:06:03
Diffstat (limited to 'sys-apps/restorecond')
-rw-r--r--sys-apps/restorecond/Manifest4
-rw-r--r--sys-apps/restorecond/restorecond-3.6.ebuild53
-rw-r--r--sys-apps/restorecond/restorecond-9999.ebuild3
3 files changed, 57 insertions, 3 deletions
diff --git a/sys-apps/restorecond/Manifest b/sys-apps/restorecond/Manifest
index ca14be518ed7..82a410139cdf 100644
--- a/sys-apps/restorecond/Manifest
+++ b/sys-apps/restorecond/Manifest
@@ -1,5 +1,7 @@
AUX restorecond.init 647 BLAKE2B e716293dee6f66a43d95cf43b6e4a50392d66d3d1fb2f082c9c9c9ef458ef87c48bf2e6cacc8c2603a51d9c639938056cffb49a0b089eb4b2a088a11af8eec0c SHA512 dd68ba095d67ccc6f698a8ab2d86942458763619d97a68f421eff0a48d72e66021df40121440107b9402a30a4e4351526d0878dca29a7eb57d68399052b1e2a6
DIST restorecond-3.5.tar.gz 19070 BLAKE2B 6db7d0fc9085a07669d346e025836a94acca610572e986e2c90974b0bd21b55e66b57a2dafd7d42011bed5f06363b654f5431ac43530fccf7b68d3edd9d63850 SHA512 80cb84e62c7072a12fe57ebaafc0bcb441c853862c67f9ea35b86faa2d8e49ea22a70b9e05a3ff24e8ce08ca2999604d7961efd534f89167cd6fcb05c852de40
+DIST restorecond-3.6.tar.gz 18020 BLAKE2B 306b4a7c9990c0b2f229cc7963dbd0481df5f9fbecd709b37d254839177fc604f6f85ac19235209f4fbb12d9186f01dd71a11f98deca5d01bd70c415240ddf5a SHA512 e21fa23bfea488f2bddd01b4bab353f22863e09247078e47db9852995d7a0153aee6483cbeaaaf033b482b60f80affad0b6a3e829f935c3901c034a7efb1ebef
EBUILD restorecond-3.5.ebuild 1157 BLAKE2B 4c2ae607b891a74674b86d62645fe393a73fea3b0e0d486d7b063b8acdec7cdde7b6fc21c8ca6088fec0abbbbd6866a2c1e766bab2a4d1a38795c091bd3b89c8 SHA512 abb97b62baf954c97b2627cae73c6db11aeb3945fad5674904c83dff379e3010e0f8723fa07576bc8a15c28c8da38d86c393c66beeb46945f314a354dfca0e80
-EBUILD restorecond-9999.ebuild 1161 BLAKE2B 59fc9cdff1f1d21f54c29325215de5189e34e7129c6a98a54cd1ebbaf540195044f99d82dd14b079578c2b3cd103d06cb25f601b44bdd8c9bd5156d9a60918ec SHA512 52ae3ee7c60e057b929f57d7c487b993aadb2a155e80db038539fcd4da79fa6fdc7f459d4869b6b33f9e5c32b92788da740a482231b2f26b941d852175663482
+EBUILD restorecond-3.6.ebuild 1153 BLAKE2B c1659b0f8f6445f3a39656a6828ae7f7a40c9a6f246a28f174d7c9328692113be9452300bf81773b673dbe186b58fea92c300117dbf4698bc04a2b64a52ad082 SHA512 65e783a2ed4176330d5a1142b3b86a7ed0a3ceba2dc968fb7497fadf8d0fcedd9cc557f0cf37f6941af416a01fb3a690a1b5086937fb6f16d9edfb2f9a94c9cd
+EBUILD restorecond-9999.ebuild 1153 BLAKE2B c1659b0f8f6445f3a39656a6828ae7f7a40c9a6f246a28f174d7c9328692113be9452300bf81773b673dbe186b58fea92c300117dbf4698bc04a2b64a52ad082 SHA512 65e783a2ed4176330d5a1142b3b86a7ed0a3ceba2dc968fb7497fadf8d0fcedd9cc557f0cf37f6941af416a01fb3a690a1b5086937fb6f16d9edfb2f9a94c9cd
MISC metadata.xml 335 BLAKE2B 72e72bc2d0ca05bf3caafd68121e0d4616306368f355541c2944254262a3ac96a3a6b8e5503ad691c2b7bc18dc6856101c81c47de3a623efc34b23185d9d4e60 SHA512 43cef46780c81459cc75b2a09181e84698a11e81196fea4e962b8081e712de437c8af032349aeb4f1ebe84ccef9cab4978467304d05801317db7a71521cf0664
diff --git a/sys-apps/restorecond/restorecond-3.6.ebuild b/sys-apps/restorecond/restorecond-3.6.ebuild
new file mode 100644
index 000000000000..794b84bc99e8
--- /dev/null
+++ b/sys-apps/restorecond/restorecond-3.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit systemd toolchain-funcs
+
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Daemon to watch for creation and set default SELinux fcontexts"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="dev-libs/glib:2
+ >=sys-libs/libsepol-${PV}:=
+ >=sys-libs/libselinux-${PV}:="
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ SYSTEMDSYSTEMUNITDIR="$(systemd_get_systemunitdir)" \
+ SYSTEMDUSERUNITDIR=$(systemd_get_userunitdir) \
+ install
+
+ rm -rf "${D}/etc/rc.d" || die
+
+ newinitd "${FILESDIR}/restorecond.init" restorecond
+}
diff --git a/sys-apps/restorecond/restorecond-9999.ebuild b/sys-apps/restorecond/restorecond-9999.ebuild
index a55a218edd6c..794b84bc99e8 100644
--- a/sys-apps/restorecond/restorecond-9999.ebuild
+++ b/sys-apps/restorecond/restorecond-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -23,7 +23,6 @@ HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
DEPEND="dev-libs/glib:2
>=sys-libs/libsepol-${PV}:=