summaryrefslogtreecommitdiff
path: root/sys-apps/rename/rename-1.3-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-26 02:06:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-26 02:06:21 +0000
commitf9fff8823e0cd1f6570b01337ac99e5bd49c824a (patch)
tree2a69b85ea6ba19c3a6b492d49ee8cd14c887472d /sys-apps/rename/rename-1.3-r3.ebuild
parentd117172e3b48fc4be82b7623ffc40bb6070ef361 (diff)
gentoo auto-resync : 26:12:2022 - 02:06:21
Diffstat (limited to 'sys-apps/rename/rename-1.3-r3.ebuild')
-rw-r--r--sys-apps/rename/rename-1.3-r3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/rename/rename-1.3-r3.ebuild b/sys-apps/rename/rename-1.3-r3.ebuild
new file mode 100644
index 000000000000..0b6df9d1ad66
--- /dev/null
+++ b/sys-apps/rename/rename-1.3-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Easily rename files"
+HOMEPAGE="http://rename.sourceforge.net/"
+SRC_URI="http://${PN}/sourceforge.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-rename.patch
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-gcc44.patch
+)
+
+DOCS=( README ChangeLog )
+
+src_prepare() {
+ sed -i \
+ -e '/^CFLAGS/s:-O3:@CFLAGS@:' \
+ -e '/strip /s:.*::' \
+ Makefile.in || die
+
+ default
+
+ # Clang 16
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+
+ default
+}
+
+src_install() {
+ newbin "${PN}" "${PN}xm"
+ newman "${PN}.1" "${PN}xm.1"
+}
+
+pkg_postinst() {
+ ewarn "This has been renamed to '${PN}xm' to avoid"
+ ewarn "a naming conflict with sys-apps/util-linux."
+}